Issue 3356

Summary: Additional styles not included in hyperlinking from TOC
Product: Writer Reporter: osavill <osavill>
Component: uiAssignee: Mathias_Bauer
Status: CLOSED FIXED QA Contact:
Severity: Trivial    
Priority: P3 CC: aaron, issues, jbf.faure, jeanweber, khbkhb, maison.godard
Version: 641   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
A simple document containing a TOC with no outline: hyperlinks don't work!
none
Index of Tables - no hyperlinks possible + workaround none

Description osavill 2002-03-05 15:15:37 UTC
Create a TOC and edit that TOC to include hyperlinks. Now edit the same TOC to 
include an additional style, say "StyleFoo". Now update the TOC. Result : 
There are no hyperlinks any where in the StyleFoo entries.
Comment 1 osavill 2002-03-05 15:48:46 UTC
Okay, I understand now. I have to sacrifice one of the Outline 
levels for my additional style. 

I have reduced this to enhancement because :
1) With enough additinal style you could run out of Outline 
levels being as there are only 10.
2) It is not made at all clear that this is what you have to do.
Comment 2 stefan.baltzer 2002-03-06 12:50:02 UTC
Reassigned to Christian.
Comment 3 christian.jansen 2003-02-11 16:25:26 UTC
Reassigned to Bettina.
Comment 4 eric.savary 2005-01-07 15:29:17 UTC
*** Issue 39835 has been marked as a duplicate of this issue. ***
Comment 5 grsingleton 2005-01-07 16:28:55 UTC
added to cc list
Comment 6 maison.godard 2005-01-07 16:49:44 UTC
comming from #39835 
it is said 
"This problem is already addressed by issue 3356 (which is, yes, an 
enhancement, 
because we need to think about and specify a new design of the dialog for 
this)" 
 
i think there is no need of new dialog design 
IMHO it is more a problem on taking outline numberring as TOC level which are 
two different things 
--> Entries Tab should handle TOC levels and not outline numberring levels( 
with one-to-one binding for toc level and outline numberring) 
Comment 7 lohmaier 2005-01-15 23:15:59 UTC
*** Issue 40728 has been marked as a duplicate of this issue. ***
Comment 8 eric.savary 2005-06-08 09:21:51 UTC
*** Issue 50449 has been marked as a duplicate of this issue. ***
Comment 9 eric.savary 2005-07-05 13:31:43 UTC
*** Issue 51531 has been marked as a duplicate of this issue. ***
Comment 10 aperomsik 2006-01-22 03:30:04 UTC
Ran across this in Ooo2. I am trying to make a PDF document with a table of
contents but no outline. The "add index entry" dialog allows me to specify the
TOC level and the TOC is properly indented as I specified. But there are no
hyperlinks... why not?
Comment 11 aperomsik 2006-01-22 03:44:25 UTC
Created attachment 33447 [details]
A simple document containing a TOC with no outline: hyperlinks don't work!
Comment 12 eric.savary 2006-03-16 16:09:42 UTC
*** Issue 63251 has been marked as a duplicate of this issue. ***
Comment 13 filipg 2006-04-29 04:26:49 UTC
Is this issue the same as creating an Index of Figures (or Tables) and being
unable to insert hyperlinks?

I think the underlying C++ does allow all of this to 'happen' but the UI + glue
make restrictions which someone felt were valid but now restrictive. But, I
didn't look at the code so I'm just guessing.

I attached a demonstration of this issue AND a workaround*.

Windows OO 2.0.2 (m160)

[*] Here's the workaround: insert the table as a Table of Contents, disable
Outline, enable Additional Styles and move Style “Table†to column #1. Then, go
to Tools->Outline Numbering and 'reserve' Level 9 (or 10, who cares) and assign
it “Table†style. Update ToC and hyperlinks will work. If you hover over the
links, you get some weirdness, but it works and that's how I got around this.
Comment 14 filipg 2006-04-29 04:28:13 UTC
Created attachment 36144 [details]
Index of Tables - no hyperlinks possible + workaround
Comment 15 eric.savary 2006-06-19 13:00:18 UTC
*** Issue 66447 has been marked as a duplicate of this issue. ***
Comment 16 luddite1812 2006-06-20 12:02:26 UTC
I would like to clarify, that my initial issue (66447) was about using captions
for things like tables, examples and figures to be used in compling list of each
of them. Those list are done using the "index/table" capability, just like the
Table of Contents.

The feature I would like to request is that hyperlinking is possible in
"index/table" with Captions, just like it is in Table of Contents.

For example, this forum post highlights the problem:

http://www.oooforum.org/forum/viewtopic.phtml?t=30097&highlight=index+table+link

I would hope for something more substantial than a workaround.

Thank you for your kind consideration.
Comment 17 eric.savary 2006-07-24 08:41:05 UTC
*** Issue 67677 has been marked as a duplicate of this issue. ***
Comment 18 skelem 2006-09-28 23:01:23 UTC
All the lists of Illustrations, Tables, Bibliography, etc, should have the same
interface, including being able to insert hyperlinks.
Comment 19 mvivit 2007-03-18 23:13:42 UTC
I have to create far too many documents requiring indexes. Please, oh, please 
get this one fixed. The workaround isn't appropriate in my situation.
Comment 20 khbkhb 2007-05-11 21:32:43 UTC
If/when this is fixed, there should be an option to NOT  include adthese
additional styles in the generated tagged PDF. The reason for this is that there
is currently no other control for subsetting the  TOC  generated PDF.  Sometimes
a formal TOC has more entries than makes sense for  the generated PDF bookmarks.
At the moment, the workaround proposed by  Hagar de l'Est which works quite
well, is to created derived styles and add them as additional styles to the TOC
... but if you simply fix  3this  then there will be no way to create such
subsets (rather than just an inconvienet and not terribly obvious way).
Comment 21 bettina.haberer 2007-09-26 16:01:29 UTC
Hi Mathias, I have changed the current owner to your owner. Please take the
ownership of these enhancements.
Comment 22 Regina Henschel 2007-10-19 20:27:46 UTC
*** Issue 82799 has been marked as a duplicate of this issue. ***
Comment 23 mhtml 2007-10-19 21:17:21 UTC
If hyperlinks in a table of contents is going to be an enhancement (ie, it
probably will not be fixed for a while), then the various howtos, tutorials and
help files should probably be updated to remove reference to this feature until
it is implemented.
Comment 24 Regina Henschel 2007-10-19 22:15:25 UTC
Hyperlinks in TOC work fine, if you generate the TOC from "outline", that means
you use those paragraph styles which are connected to an outline level in Tools
> Outline.
Comment 25 eric.savary 2008-01-24 14:33:18 UTC
*** Issue 85522 has been marked as a duplicate of this issue. ***
Comment 26 gerdb42 2009-01-14 10:35:04 UTC
Say you have a Document with digit numbering in normal text using the "HeadingX"
templates for headlines. You could make a TOC from outline with hyperlinks just
fine.
Now let's add some Appendices. Since we want them to have letter numbering on
the top level, we use different templates named "AppendixX" and add these as
additional styles to be included in the TOC. The result is a TOC where entries
referring to the mormal part are hyperlinked whereas entries referring to the
appendices are not. And if you export this to PDF you will have bookmarks for
normal text but not for appendices.
From a users point of view there is no reason why TOC entries are treated in
different ways. Please fix this. Could this be related to #44938, which is about
hyperlinking in non-TOC indices?
Comment 27 eric.savary 2009-01-23 18:58:17 UTC
*** Issue 97847 has been marked as a duplicate of this issue. ***
Comment 28 eric.savary 2009-01-23 19:53:45 UTC
*** Issue 97847 has been marked as a duplicate of this issue. ***
Comment 29 eric.savary 2009-01-23 21:13:58 UTC
*** Issue 97847 has been marked as a duplicate of this issue. ***
Comment 30 eric.savary 2009-05-20 09:39:26 UTC
*** Issue 102086 has been marked as a duplicate of this issue. ***
Comment 31 Oliver-Rainer Wittmann 2014-03-27 15:37:15 UTC
This issue had been solved when I introduced direct cross-refernces to headings and numbered paragraphs - see issue 81002 and 83479