Issue 33668

Summary: Mouse right-click on a toolbar to customize it
Product: ui Reporter: esperantisto <gdkbnx>
Component: uiAssignee: thorsten.martens
Status: CLOSED FIXED QA Contact: issues@ui <issues>
Severity: Trivial    
Priority: P3 CC: ansgar, hin.stone, issues, jeongkyu.kim, kpalagin, Mathias_Bauer, r.w.waters
Version: 680m84Keywords: oooqa
Target Milestone: OOo 3.0   
Hardware: All   
OS: All   
Issue Type: PATCH Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Mouse right-click on a toolbar to customize it
none
Mouse right-click on a toolbar to customize it none

Description esperantisto 2004-09-01 07:32:41 UTC
In OOo 1.1.2, I can invoke customize dialog for a toolbar by mouse right-click 
on it. However, this possibility is absent in latest developer builds (including 
m51). I suggest to bring it back.
Comment 1 michael.ruess 2004-09-01 08:16:59 UTC
MRU->ES: I think you know anything about what changed, right? ;-)
Comment 2 eric.savary 2004-09-01 12:49:09 UTC
You can reach the cutom dialog by clicking on the toolbar selector (the small
traiangle at the end of a toolbar) and choose Customize toolbar. This way you
get the Customize dialog with focus on the current toolbar.
Comment 3 eric.savary 2004-09-01 12:49:22 UTC
closed
Comment 4 esperantisto 2004-09-02 07:34:34 UTC
Sorry, for nagging, but:
1. That selector is a very small area, and with a small monitor it quite 
inconvenient.
2. Right-click on a toolbar not only opens the customize dialog, but also lets
a) enable/disable toolbars
b) enable/disable buttons on a toolbar
c) reset a toolbar.

This is a very handy feature. I can't understand, why it was removed from pre-1.
9 builds, considering the general trend to "microsoftize" OOo. In MS Office. 
right-click has a very simila behavior. I still believe, the developers must 
bring it back.
Comment 5 aschrage 2004-09-02 11:42:11 UTC
I also would strongly recommend to bring back the right mouse click to the
toolbar. Not only it is more like it is done in MS-Office, but also for the
current users of OOo 1.x. In my case I was confused when I first installed this
developer build and I'm using OOo a long time.
Comment 6 eric.savary 2004-09-04 12:59:04 UTC
ES->SSA: would it be a technical problem to reintroduce the context menu on
toolbars or is that a wanted behavior? (Please sync with UserEx)
Comment 7 stephan_schaefer 2004-09-08 14:50:23 UTC
ssa->cj: please give your comment. if it results in a new feature, this must be
handled by CD.  the timeframe, however, will probably not be OOo2.0, as feature
freeze has already been reached.
Comment 8 christian.jansen 2004-09-09 09:11:54 UTC
We shall display as context menu the feature set from the Customize menu of a
toolbar + a list of all toolbars. 

The context menu shall look like shown in the example below:

Toolbar 1
Toolbar 2
Toolbar 3
  ...
---------
Visible Buttons >
Customize Toolbar...
---------
Dock Toolbar
Dock All Toobars
---------
Lock Toolbar Position

I change this from enhancement to defect, because it is a feature we had in OO.o
1.1.
Comment 9 carsten.driesner 2004-09-16 16:18:18 UTC
CD: Discussed with CJ. RMB should also show the same context menu as clicking on
the rightmost toolbar button.
CD->SSA: Please add this to the VCL toolbar class as you are the only one who
can determine clipped items. If you use the same implementation as for the
rightmost button, nothing has to be changed in the framework base code.
Comment 10 stephan_schaefer 2004-09-17 10:35:46 UTC
Using for right mouse button click the very same menu as for the customize
button brings no real advantage to the user and would especially not bring back
the functionality the conetxt menu once had (ie choosing among all availabe
toolbars etc.)
So I suggest coming up with a properly designed context menu that has shortcuts
to the most important customization features, similar to those mentioned earlier
and may be even more.

This feature, however, canot be implemented in the OOo 2.0 timeframe anymore.
Comment 11 watersrw 2004-09-19 18:05:34 UTC
I think it is a great pity that this feature cannot be put back into ooo before
2.0 - many users will be frustrated by having to click on that very small area
to customize the tool bar.  
Comment 12 christian.jansen 2004-09-23 09:49:18 UTC
CJ: BAsed on SSAs statement, I'll set the target to Office later
Comment 13 aparan 2005-02-10 08:03:11 UTC
*** Issue 39794 has been marked as a duplicate of this issue. ***
Comment 14 arthit 2005-04-01 14:44:40 UTC
*** Issue 46452 has been marked as a duplicate of this issue. ***
Comment 15 arthit 2005-04-01 14:48:41 UTC
confirmed.

change Component from "word processor" to "ui", as it applies to other apps as well.
Comment 16 kpalagin 2006-12-05 13:18:59 UTC
*** Issue 41587 has been marked as a duplicate of this issue. ***
Comment 17 kpalagin 2006-12-05 14:46:18 UTC
*** Issue 31623 has been marked as a duplicate of this issue. ***
Comment 18 kpalagin 2006-12-05 16:12:28 UTC
*** Issue 42295 has been marked as a duplicate of this issue. ***
Comment 19 kpalagin 2006-12-05 16:29:43 UTC
*** Issue 26367 has been marked as a duplicate of this issue. ***
Comment 20 crolidge 2007-04-09 09:51:57 UTC
I agree it is a pity OO not having this feature. In my humble opinion it should
be implemented.
Comment 21 crolidge 2007-05-26 14:00:33 UTC
Hi guys, is there any advance on this issue ? Many thanks.
Comment 22 mbayer 2007-07-03 00:02:11 UTC
*** Issue 76000 has been marked as a duplicate of this issue. ***
Comment 23 Mathias_Bauer 2007-12-19 14:01:44 UTC
Christian, please comment. Either you deny the request (but have a look on the
huge number of duplicates!) or you agree and hand it over to development. I
think it's something we should be able to implement in 3.0.

Of course we must design the content of the menu.
Comment 24 christian.jansen 2007-12-19 14:53:50 UTC
I'll assign this bug to Carsten. Mathias, if he can't do the change please
assign this bug to anyone who wants to volunteer.

Regarding the Context Menu.

A context click on the toolbar should rise a pop-up menu,
which provides the entry "Customize...".

Selecting this entry calls up the "Customize" dialog
with the "Toolbar" tab and according Toolbar preselected.
Comment 25 christian.jansen 2007-12-19 14:54:29 UTC
Changed target to 3.0
Comment 26 kpalagin 2007-12-19 17:41:24 UTC
(Mathias, thank you very much for bringing this up!)

IMO, design idea by CJ at "Thu Sep 9 08:11:54 +0000 2004" 
(http://www.openoffice.org/issues/show_bug.cgi?id=33668#desc9) looks 
reasonable.
Comment 27 kpalagin 2008-03-02 14:24:04 UTC
Are we on track for 3.0 with this 3.0-targeted issue?
Comment 28 carsten.driesner 2008-03-12 09:30:15 UTC
cd->kpalagin: I have a developer who wants to implement this enhancement for OOo
3.0.
Comment 29 zhoubo.shi 2008-04-14 10:07:08 UTC
Created attachment 52799 [details]
Mouse right-click on a toolbar to customize it
Comment 30 zhoubo.shi 2008-04-14 10:08:00 UTC
Created attachment 52800 [details]
Mouse right-click on a toolbar to customize it
Comment 31 zhoubo.shi 2008-04-14 10:10:32 UTC
I have fixed the issue, thank Carsten for your help and everyone who provided
the suggestions
Comment 32 carsten.driesner 2008-04-15 07:24:24 UTC
cd: Fixed.
Comment 33 carsten.driesner 2008-04-15 11:47:47 UTC
cd: Set issue type to PATCH.
Comment 34 carsten.driesner 2008-05-30 13:10:11 UTC
cd->tm: Please verify.
Comment 35 thorsten.martens 2008-06-10 10:50:40 UTC
Checked and verified in cws fwk88 -> OK !
Comment 36 Raphael Bircher 2008-09-09 13:45:02 UTC
seems to be ok
Tested witz 3.0.0rc1 Mac version on PPC Tiger
closing issue