Issue 34141

Summary: Extra horizontal lines added after Arabic letters
Product: Internationalization Reporter: beroul <ben_geer>
Component: BiDiAssignee: hdu <hdu>
Status: CLOSED DUPLICATE QA Contact: issues@l10n <issues>
Severity: Trivial    
Priority: P3 CC: hdu, ht990332, issues, munzirtaha
Version: current   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 79434    
Attachments:
Description Flags
OOo Writer file in which extra lines occur after certain letters
none
Screenshot showing extra lines none

Description beroul 2004-09-13 23:37:39 UTC
In the attached OOo Writer file, some extra horizontal lines have been added
after certain letters.  These lines aren't part of the letters, and should not
be present.  In the attached screenshot, I've circled these lines in red.

This seems to happen only with certain fonts; the example is in KacstQurn, which
is available from: http://www.arabeyes.org/project.php?proj=Khotot

The lines don't always appear after the same letters; the problem is very
sensitive to context (e.g. the preceding letters and the preceding words in the
paragraph).

I've seen this problem with OOo 1.1.2 on Linux; I don't know whether it occurs
with more recent builds or on other platforms.
Comment 1 beroul 2004-09-13 23:38:19 UTC
Created attachment 17689 [details]
OOo Writer file in which extra lines occur after certain letters
Comment 2 beroul 2004-09-13 23:38:41 UTC
Created attachment 17690 [details]
Screenshot showing extra lines
Comment 3 beroul 2004-09-16 11:51:42 UTC
This problem does not occur in Microsoft Word (if I export the example document
to Microsoft Word format and open it using Microsoft Word, it looks fine in Word).
Comment 4 munzirtaha 2004-09-17 17:39:47 UTC
I confirm this problem happens with DecoType Naskh, DecoType Thuluth, ... 
Those fonts comes with the Arabic version of MS Office and the are very famous 
and professional. This bug is really serious. The situation of OO.o now is 
that it's not useful for any serious work in Arabic. 
 
(you can visit wiki.arabeyes.org/OpenBugs for a unified interface for the 
Arabic bugs) 
Comment 5 stefan.baltzer 2007-03-30 18:24:23 UTC
SBA: I have seen similar "non-kashidas" before. I remember that there were
things fixed (don't know the ID, sorry).
Please re-verify your findings in a current version (OOo 2.2 or SRC680m206
DevBuild) or younger) and comment here. Thank you.

Reassigned to ES (font-related issue), put HDU on CC. 
Comment 6 munzirtaha 2007-03-31 08:13:56 UTC
I confirm that the bug is still there in a OO.o 2.2.0 on feisty fawn. I choose
the font size to be 10 and see many horizonatal lines (displaced kashida's).
Comment 7 munzirtaha 2007-03-31 08:20:14 UTC
Ok I found an easier way to generate the bug. Choose the font size to be 10 then
type or copy the Arabic letter
م
Which is the letter on the same key as English letter "L". You would see a
horizonatal line attached to it!
Comment 8 Joost Andrae 2007-05-09 14:33:33 UTC
*** Issue 77127 has been marked as a duplicate of this issue. ***
Comment 9 hdu@apache.org 2007-07-03 09:38:38 UTC
Same root cause as issue 28203: SW uses the wrong justification method

*** This issue has been marked as a duplicate of 28203 ***
Comment 10 eric.savary 2007-07-03 10:24:26 UTC
closed
Comment 11 munzirtaha 2007-07-03 11:10:12 UTC
I believe this issue is not a duplicate of 28203 and shouldn't be closed either.

28203 happens for languages other than Arabic (e.g persian) with all the fonts
when the text is justified using kashida's.

This bug happens for all languages that use Arabic script even if the text is
not justified but for some fonts only like DecoType Naskh. The first bug could
be easily resolved by treating languages that use kashida justification (e.g
persian) like the Arabic language but this bug requires we figure out why only
some fonts would put horizontal lines or dots even while there is no
justification or kashida's involved.
Comment 12 munzirtaha 2007-07-03 12:00:59 UTC
A simple way to regenerate this bug is to type a couple of letters like
دو
With a DecoType Naskh font, size 14
You would see a dash or a dot after the last letter which shouldn't be there.
Comment 13 munzirtaha 2007-07-03 12:14:07 UTC
It is worth mentioning that for the minimal case I put the zoom level should be
set to 150%
Comment 14 eric.savary 2007-07-23 16:19:07 UTC
ES->HDU: please explain the relation with the duplicate issue or take over.
Comment 15 hdu@apache.org 2007-08-13 15:23:39 UTC
@ES: the "extra horizontal lines" are kashidas, which the Writer would position correctly if he used the 
"kashida justification" method instead of western justification. Writer can be forced select the correct 
method: in the Format->Character dialog manually select Arabic as the language of the CTL-font.

A fix for issue 28203 will fix this problem too, since then the correct justification method will be selected 
automatically.

*** This issue has been marked as a duplicate of 28023 ***
Comment 16 hdu@apache.org 2007-08-14 10:35:06 UTC
Issue 28203 instead of 28023
Comment 17 hdu@apache.org 2007-08-14 10:35:46 UTC
Issue 28203 instead of 28023

*** This issue has been marked as a duplicate of 28203 ***
Comment 18 Mechtilde 2008-11-05 20:29:47 UTC
close the duplicate