Issue 34428

Summary: Select all does not work as expected
Product: Writer Reporter: rom888 <richard.myers>
Component: uiAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1.2   
Target Milestone: ---   
Hardware: PC   
OS: Windows 2000   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description rom888 2004-09-21 10:20:04 UTC
If a text document starts with a table, the select all command does not work as
expected. It selects the table and not the rest of the document.

To reproduce:
1. Create a new text document
2. Insert > Table..., and click OK
3. Enter some text after the table
4. Edit > Select all
Only the table will be selected.

I suspect this arises because select all starts at the beginning of the document
and attempts to extend the selection until it reaches the end. Therefore this
behaviour may occur on other platforms.

While this behaviour is consistent with the notion of selections which begin in
tables not extending beyond them, I believe it is a UI glitch. Ever since
MacWrite, "Select All" has meant "Select the whole document".

Workaround: don't put tables right at the start of documents. However, this is
not a particularly user-friendly restriction.
Comment 1 michael.ruess 2004-09-21 10:32:37 UTC
This problem is know. Unfortunately this will mean a VERY HUGE effort to be
fixed with a small affect. Thus issue 7747 is marked as WONTFIX.

*** This issue has been marked as a duplicate of 7747 ***
Comment 2 michael.ruess 2004-09-21 10:33:56 UTC
Closed.
Comment 3 rom888 2004-09-21 11:29:06 UTC
Congratulations.
The only program I know of where "select all" does not mean "select all".
Think I'll stick with Word.