Issue 34767

Summary: Impossible to edit style when one sheet is protected
Product: Calc Reporter: lolomic <laurent-jp.michon>
Component: editingAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1.2   
Target Milestone: ---   
Hardware: PC   
OS: Windows 2000   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Example for this issue (Edit/Delete style) none

Description lolomic 2004-09-29 09:47:59 UTC
OOo 1.1.2 - French version
Win 2000 - SP3


1. Create a new spreadsheet, say it holds 2 sheets (2 pages).
2. Page one : edit, apply style
3. Page two : edit, don't apply any style. Protect this page (with or without 
password, it doesn't matter) with TOOLS/PROTECTION/SHEET.
4. Go back to first sheet. Call Style Navigator (F11)
5. Right click on a style and select "EDIT" (or "modify" in english, I don't 
know, I have the french version where it is indicated "Modifier")

Result : nothing happen. You are even not warned that at least 1 sheet is 
protected. Moreover, the "Edit" item is not greyed. EVEN if the second page 
(protected) doesn't have any style applied. Same with "Remove" item.

6. Go to second sheet (the protected one). Remove protection.

Result : you can now edit/delete style.

Conclusion : I understand that this EDIT function may be unavailable when one 
sheet is protected. However, it could be nice to grey the "Edit" or "Delete" or, 
better way, warn the user that at least one sheet is protected and it is 
therefore impossible to modify in any way the existing styles.

I put this issue to "ENHANCEMENT" as it doesn't seem to be a "DEFECT" strictly 
speaking.

Have a nice day.

L.
Comment 1 lolomic 2004-09-29 09:49:08 UTC
Created attachment 17989 [details]
Example for this issue (Edit/Delete style)
Comment 2 frank 2004-09-29 10:45:10 UTC
Hi,

this is a double to Issue 4679.

If you change a style and this style is set on the protected sheet, you can
change a protected sheet and this is not a good thing. The benefit of just
blocking style changes for protected sheets against the amount of work to
implement such feature is relativly small. This is why these Issues are set to
wontfix.

Frank

*** This issue has been marked as a duplicate of 4679 ***
Comment 3 frank 2004-09-29 10:46:02 UTC
closed double