Issue 36696

Summary: Mail Merge features incomplete, missing Hidden Paragraph / Text features
Product: Writer Reporter: phillg <phill.gillespie>
Component: uiAssignee: h.ilter
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: christian.jansen, cno, issues, os_ooo
Version: 680m60   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 56195    
Issue Blocks:    

Description phillg 2004-11-04 17:18:35 UTC
This issue of a simple interface to the hidden paragraph feature has been going
on for quite a few years now.  Even Microsoft Office 95 had this functionality
yet it continually is ignored by OOo.

Issue 20057 cannot be complete without basic empty line handling

Issue 10760 opened 18 months ago is not a duplicate of 20057 but is of this issue.


How hard can it be to include a "Tick here to supress blank lines for this
field" and /or "Tick here to supress blank lines for entire document"?


Correct me if I'm wrong, but surely the sudo code for this is along:

* Tick Box "Hide blank lines" on GUI which sets HBL

Insert Database Field Names routine {
if HBL = 1 then
  insert hiddenparagraph(not($FIELD)).$FIELD
else
  insert $FIELD
endif


OOo 2 surely can't go out of the door if it can't even match the basic mail
merge features of MS 95...
Comment 1 phillg 2004-11-04 17:19:17 UTC
Adding one comment from 10760:

------- Additional comments from ragweed Sat Oct 25 10:33:28 -0800 2003 -------

I'm creating labels using OOo's File->New->Labels feature, but several
of my labels have empty field values, and I'd like to suppress their
output when I do a mail merge.

Currently:
--------------
John Doe

Something, CA 38924
------------------------------

What I'd like:
----------------
John Doe
Something, CA 38924
------------------------------

Avery Wizard and MS Word offer a feature like Suppress Blank Lines. 

Thanks very much for your considering this bug.
Comment 2 phillg 2004-11-04 17:21:36 UTC
*** Issue 10760 has been marked as a duplicate of this issue. ***
Comment 3 phillg 2004-11-04 17:21:40 UTC
*** Issue 9435 has been marked as a duplicate of this issue. ***
Comment 4 phillg 2004-11-04 17:25:04 UTC
Confirmed that UI is absent from 1.9m60

Comment 5 michael.ruess 2004-11-05 07:33:25 UTC
reassigned to HI. Please evaluate.
Comment 6 h.ilter 2004-11-05 08:40:07 UTC
HI->CJ: Enhancement about the database section is requested.
Comment 7 phillg 2004-11-16 14:08:08 UTC
Please explain what enhancement is needed from the database section...
I'd like to help get this major issue sorted but need a few more details.  

As I saw it this is purely a frontend issue, for every field that is written to
the page the wizard justs needs to add HiddenParagaph(condition) to the same line...

Or is it the actual Hide Blank Lines option that needs to exist in the DB?
Comment 8 christian.jansen 2004-11-24 09:46:56 UTC
Hi Oliver,
I think this is something we should add to OO.o before we release OO.o 2.o.
Please ping me for further discussions.
Comment 9 phillg 2005-02-06 11:27:37 UTC
I know we are incredibly close to the 2.0 beta but doesn't anyone other than me
see the size of this bug?  Corporations (such as mine) will simply not tolerate
mail merges that leave blank lines in the letters or labels and secretaries do
not have the time or DB understanding to add hidden text or paragraph conditions!

Half of my company still use Word 97 and they use it for only one reason: 
simple mail merges.  If OOo2 comes out with this huge hole in functionality
compared to Microsoft then it will damage the release badly.  

CJ >  You seemed to recognise the severity of this issue, is there anything you
can do to try to sort this?
Comment 10 Oliver Specht 2005-05-17 08:12:59 UTC
Target set to OOo 2.01, Prio changed to 3
Comment 11 phillg 2005-07-29 15:45:45 UTC
*** Issue 42615 has been marked as a duplicate of this issue. ***
Comment 12 vreid47362 2005-07-29 23:23:15 UTC
The lack of a simple way to hide blank lines in a mail merge created by empty
database fields basically makes OpenOffice almost worthless to, I'd say, 90% +
of US secretaries.

Every company that I've ever worked for or provided consulting to will not
tolerate mail merges with blank lines in the address, etc.  In addition, when a
mail merge might be 500 to 1500 items, it is not cost effective to hand edit the
blank lines out.

Since becoming a self-employed computer consultant 2+ years ago, I have
consistently had clients reject widespread rollouts of OpenOffice because it is
nearly impossible for a non-technical person to send a professional looking
(read no blank lines in the address sections of letters, labels, and envelopes)
without manual intervention.  

I am pleading with you to not send OpenOffice 2.0 out the door without fixing
this basic functionality issue.  The steps required, currently, to hide blank
lines in mail merges, labels, and envelopes that are caused by blank fields
makes it impossible for all but the most technical to make a decent merge.

In case you are not familiar with U.S. mail address conventions, here are two
common address label formats and examples.  
1.
<Title> <FirstName> <MiddleInitial> <LastName> <NameSuffix>
<CompanyPosition>
<Company>
<StreetAddress1>
<StreetAddress2>
<City>, <State>  <Zip>

Example
Mr. Vaughn L. Reid III
Owner
Great Big Company
1525 Gregory Street
Apt. 227
Anytown, IN  99999 - 9999

2.
<Title> <FirstName> <LastName> <NameSuffix>
<Company>
<StreetAddress1>
<StreetAddress2>
<City>, <State>  <Zip>

Mr. Joe Smith Esquire
Another Big Company
2344 Big Sky Drive
MailStop 44
AnotherTown, IN  34567-3445

It is quite common for an address database to mix records with 2 row (or even 3
row) street addresses with records with 1 row of street addresses.  It is also
quite common to have a variety of completeness for many records.  For example,
in a single database some records may both the <CompanyPosition> field and the
<Company> filled completed others may have one of those field or neither field.
 This means, that, using the first address sample, you could have records that
look like the ones that follow from a single mail merge.  The ones with the
blank lines, as you can imagine, are quite unacceptable.  Here are some
incomplete examples.
1.
Mr. Joe   Smith


124 Way

Anytown, IN 43532

2.
 Joe   Smith
Owner


P.O. Box 99999
New Castle, IN 47362-4149

3.
Mr.  Smith

Big Company I Want To Impress
123 Blvd.

ATown, RI 12345

As you can see, the current mail merge makes my attempts to impress my
customers, etc. futile.  No one would want to do business with me unless I delve
into the mysteries of programming to remove hidden paragraphs or go back and
manually edit my 5000 record mail merge.

Please fix this extremely important issue before sending OpenOffice 2.0 out the
door.



Comment 13 sauron11 2005-07-30 16:55:43 UTC
I'd like to second the comment above - decent blank line handling is a critical
feature for many office workers.

I've deployed OO 2.0 betas for about 50 users, replacing MS Office 97 as part of
a rollout of new hardware. I'd have preferred to wait for the final version, but
timing was forced on me by external factors, and it was either deploy or buy MS
Office XP. Mail merge is by far the largest problem area that's come up.
Suppressing blank lines is effectively not possible for normal users, the only
work around we have is to create templates with hidden paragraphs set, and tell
users that they have to name their data sources appropriately to use the
templates, which is not an acceptable solution. Most of them are using old
copies of MS Office 97 on machines we haven't retired yet for mail merges.

Please, please fix this bug before shipping 2.0. I'd expect my organisation to
be representative of the average office, and if this doesn't get sorted, we will
have to consider whether or not it's viable to continue with OO. If we don't, I
suspect it'll be a long time before we try again.
Comment 14 bobharvey 2005-08-06 21:16:48 UTC
I have to agree.  The inability to handle blank fields attractively is so
fundamental that I am surprised this is an enhancement, not a bug.  To me it is
just plain wrong, not a "nice idea for the future".
Comment 15 vreid47362 2005-08-11 04:11:36 UTC
If development time and budget prevents fixing this issue before OpenOffice 2.0,
please consider adding information to the included mail merge help that
describes how to accurately configure the mail merge to suppress blank lines
when all the fields on the line are empty.  

Here are my suggestions to add to the help
1.  Place information on the mail merge screen stating that the default behavior
of the mail merge wizard is to not suppress blank lines caused by empty fields

2.  Place a link in the help that will take someone to the help about inserting
hidden paragraphs.

3.  Explain in the hidden paragraph help that each line that uses this feature
needs to be a separate paragraph.  

Note:  On my OpenOffice 1.9.m22 build it appears that the mail merge wizard
inserts paragraph breaks now by default.  That's good if that is the case. If
not, the instructions in 4 and 5 below need to be included.

4.  Note that the mail merge and label wizard do not insert paragraph breaks
between lines by default.  The user must do that manually.

5.  Include instructions explaining to the user that the easiest way to confirm
a paragraph return is to a.  Turn on hidden characters and b.  hit the enter key
at the end of each line and then backspace to remove the blank line

6.  Include a final step-by-step example of how to set up a mail merge with
hidden paragraphs if the fields on the line are blank.  A suggestion for this
example is how to set up a page of mailing labels.

Comment 16 mikeascott 2005-08-12 08:28:39 UTC
IMO this is a more general issue than one of hidden paragraphs.  In general,
fields are not one per line, and correct action needs to be taken if one or more
fields on a single line are empty. For example, a line containing a list of,
say, children's names may be present in a mailmerged output. Correct action in
this case may be inclusion of a separator such as a comma between non-blank
items. Or some label text may need inclusion (eg "NAME=doe FIRST=john
MIDDLE=james" where any field may be blank and the corresponding label should
not appear).

The present UI is amazingly difficult to use - and I count myself a technical
person. A non-techie will find this impossible - I fully concur with
vreid47362's comments.

(Additional OT note: merge to file always generates one file per database entry.
This is not always desirable, just like empty lines aren't!)
Comment 17 revnomad 2005-09-23 03:48:20 UTC
I know you are getting close but this is a major issue, especially as
Massachusetts announces moving away from MSO.  

It simply is impossible for most secretarial level or novice user to use Hidden
Paragraphs as it now stands.

Norman Prather
Comment 18 Oliver Specht 2005-09-26 13:29:23 UTC
Fixed in cws os67 in
officecfg/registry/schema/org/openoffice/Office/Writer.xcs
officecfg/registry/data/org/openoffice/Office/Writer.xcu

sw/source/ui/inc/mmconfigitem.hxx
sw/source/ui/dbui/mmconfigitem.cxx
sw/source/ui/dbui/mmaddressblockpage.cxx
sw/source/ui/dbui/mmaddressblockpage.hrc
sw/source/ui/dbui/mmaddressblockpage.hxx
sw/source/ui/dbui/mmaddressblockpage.src
sw/source/ui/dbui/mmlayoutpage.cxx
Comment 19 phillg 2005-09-26 13:54:39 UTC
I know the target milestone is 2.0.1 but is this workspace already integrated
with the RC1 build?  Will it make it into the next RC as a "special" bug fix...?
Comment 20 Oliver Specht 2005-09-26 14:25:38 UTC
->phillg:  Sorry, no and no are the answers.
Comment 21 phillg 2005-10-27 10:09:04 UTC
I've added Issue 56195 as a blocker for this issue.  Basically hidden paragraphs
do not work properly, the last record test results apply to all records on the page.

Although I've waited years for this bug to be fixed, until issue 56195 is
resolved this feature is useless :-(
Comment 22 phillg 2005-11-01 09:11:12 UTC
os:  Does this new feature need to be delayed until 2.0.2, i.e. when issue 56195
is scheduled to be included?  Surely this will be affected by the "form letter
wizard printing dialog" that seems to initiate the hidden paragraphs to behave
badly.

I haven't been able to test this feature as I'm relying on Pavel Janik's builds
and as yet it doesn't include os67...
Comment 23 phillg 2005-11-28 08:46:56 UTC
Correct me if I'm wrong but this issue has not been included in the 2.0.1RC1
build has it?  Does it need re-opening or re-targetting?
Comment 24 Oliver Specht 2005-11-28 08:51:02 UTC
It hasn't been included into OOo 2.0.1 because of missing QA resources
Target changed to OOo 2.0.2
Comment 25 Oliver Specht 2005-12-15 08:16:55 UTC
Reassigned for verification

re-open issue and reassign to hi@openoffice.org
Comment 26 Oliver Specht 2005-12-15 08:17:05 UTC
reassign to hi@openoffice.org
Comment 27 Oliver Specht 2005-12-15 08:17:13 UTC
reset resolution to FIXED
Comment 28 h.ilter 2006-01-05 13:25:35 UTC
Verified with cws os67 = ok
Comment 29 phillg 2006-01-11 13:51:45 UTC
Just tested this out in Pavel's build of 149 and it looks good to me (albeit the
string "surpress blank lines" or whatever is missing in my localisation). 
Unfortunately I can only see a way of surpressing blank lines during the Mail
Merge wizzard and NOT the New > Labels feature (even though a lot of this bug
talks about labels).  

os: Should this issue be re-opened in order to have the complete functionality
or have I missed something?
Comment 30 h.ilter 2006-01-23 10:12:29 UTC
*** Issue 61021 has been marked as a duplicate of this issue. ***
Comment 31 kingshome 2006-01-23 10:27:44 UTC
I see that 61021 has been marked as a duplicate, though it specifically refers
to suppressing blank lines in labels.  Since this issue (36696) is labelled as
fixed,  are we to understand that suppressing blank lines in labels will be
present in 2.0.2?  It certainly isn't present in developer snapshot 151.
Comment 32 phillg 2006-01-23 10:36:59 UTC
Agreed, one of these issues needs re-opening, I think it should be this one.

Re-opening as the fix for this issue is not complete (and 61021 has been marked
as a dupe of this by hi)
Comment 33 h.ilter 2006-01-23 15:22:02 UTC
Issue 61021 is corrected.
Comment 34 h.ilter 2006-01-26 12:55:41 UTC
Also ok in master 680m150_8995.
Comment 35 h.ilter 2006-01-26 12:58:43 UTC
closed
Comment 36 cno 2006-05-29 14:39:21 UTC
Hi *,

Just tested the hidden paragraph function. OOo 2.0.3RC3, Win XP SP1

It works OK in mail merge, with both 2.0-Wizard and with 1.1.x merge dialog.

However, if used with labels (more than one on a page), the labels with a hidden
paragraph in it, remain completely empty.
Sorry I've to write this  :-(
Comment 37 cno 2006-05-29 15:25:18 UTC
Sorry again.
It dóes work, only the label-wizard inserts line-feeds (shft-enters) rather than
paragraphs (enters).
Something to keep in mind when others have dificulties.