Issue 37133

Summary: Misplaced weak characters in mixed Hebrew/English text
Product: Impress Reporter: alan
Component: open-importAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, yba
Version: 680m60   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
PowerPoint presentation with mixed Hebrew/English text (slide 3)
none
Slide 3 as it appears in PowerPoint
none
Slide 3 as it appears in Impress none

Description alan 2004-11-14 09:49:27 UTC
In the attached PowerPoint presentation, slide 3, in the mixed Hebrew/English
(upper line), the dollar sign and exclamation points are misplaced  by OOo.
Comment 1 alan 2004-11-14 09:52:54 UTC
Created attachment 19250 [details]
PowerPoint presentation with mixed Hebrew/English text (slide 3)
Comment 2 alan 2004-11-14 09:53:34 UTC
Created attachment 19251 [details]
Slide 3 as it appears in PowerPoint
Comment 3 alan 2004-11-14 09:54:20 UTC
Created attachment 19252 [details]
Slide 3 as it appears in Impress
Comment 4 alan 2004-11-14 09:56:49 UTC
The same problem exists on the bottom line, where the exclamation points and
asterisks next to "Wow, that is great" are reversed. 
Comment 5 wolframgarten 2004-11-15 07:12:13 UTC
Reassigned to Christian.
Comment 6 christian.guenther 2005-01-05 10:16:01 UTC
change the milestone
Comment 7 christian.guenther 2005-03-09 13:27:42 UTC
I can reproduce the bug.
Please have a look.
Comment 8 hdu@apache.org 2005-04-11 12:47:13 UTC
.
Comment 9 alan 2006-08-29 17:17:06 UTC
The problem still exists in 2.0.3, though there have been some changes in the
behavior since the issue was first reported. I'm attaching a screenshot of Slide
5 as it appears in 2.0.3. If you compare it with Slide_5_OO.jpg that is attached
to Issue 37134, you'll notice that while the three dots have moved correctly to
the left, letters are now overlapping each other.
Comment 10 hdu@apache.org 2006-08-30 09:39:25 UTC
It this problem is visible on Windows only then please check again with build
newer than SRC680_m176.
Comment 11 alan 2006-08-30 10:42:52 UTC
Yes, the problem only exists in Windows, and I see that slide 5 looks good in
the latest snapshot build. Thank you for the fix. (The original problem with the
dollar signs and exclamation points in slide 3 remains unchanged, though.)
Comment 12 alan 2006-10-13 09:35:40 UTC
ayaniger->hdu:
Have you had a chance to look at the problem of misplaced weak chars?
Also, I have filed a separate issue for the overlapping characters. It's Issue
70378.
Comment 13 Marcus 2017-05-20 11:08:50 UTC
Reset assigne to the default "issues@openoffice.apache.org".