Issue 37336

Summary: Assertion "wrong value on progressbar" on saving
Product: Calc Reporter: daniel.rentz
Component: save-exportAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, Mathias_Bauer, tenger
Version: 680m62   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
jumping progressbar
none
backtrace none

Description daniel.rentz 2004-11-17 14:23:49 UTC
Load bugdoc from issue 37333, modify, save. The following assertion occurs:

Error: tried to set a wrong value on the progressbar
Comment 1 sascha.ballach 2004-11-29 12:31:15 UTC
change target
Comment 2 sascha.ballach 2005-02-15 11:12:15 UTC
Created attachment 22643 [details]
jumping progressbar
Comment 3 400guy 2010-04-07 17:01:24 UTC
Assertion failure.  Same assertion, but in a Writer document, and
(obviously) a newer version of OO.


This first happened as I was trying to copy information from the frame
presented when you go to <http://www.unixodbc.org/> and select Manuals
from the left frame.  <validator.w3.org> flags 35 errors and 6
warnings on the source of that frame; this may be entirely
coincidental.

In a new Writer document I pasted in the interesting part of the frame
(i.e., from "Welcome to" to "solutions, Inc.)" and tried to save the
file.  I continued past an assertion raised at XMLTextNumRuleInfo.cxx
line 117, and the program said

    Error: tried to set a wrong value on the progressbar
    Abort ? (Yes=abort / No=ignore / Cancel=core dump)


To reproduce

(*) From unixODBC_webpage.tgz
   
<http://www.openoffice.org/nonav/issues/showattachment.cgi/68806/unixODBC_webpage.tgz>
    attached to issue 110671, extract into a convenient directory.
    Expect to get file unixODBC.html and directory unixODBC_files.

(*) In Firefox 3.0, (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9)
    Gecko/2008061015 Firefox/3.0), open the extracted unixODBC.html.
    In the frame on the right, select from "Welcome to" to "solutions,
    Inc.)" (that is most of the frame) and press ctrl-C.

(*) In a new Writer document, press Ctrl-V and Ctrl-Home.

(*) Select menu option File > Save.  In the Save as dialog enter
    filename /tmp/nothing and click Save.

(*) At assertion raised from XMLTextNumberRuleInfo.cxx line 117, click
    No=ignore.

(*) Observe the assertion cited above.


I am running a lightly hacked non-production build of DEV300_m75 on
ubuntu hardy.


I shall shortly attach a backtrace from an occurrence during the "to
reproduce" steps.
Comment 4 400guy 2010-04-07 17:03:32 UTC
Created attachment 68808 [details]
backtrace
Comment 5 Mathias_Bauer 2010-05-19 11:30:23 UTC
We have the same assertion, but the root cause for them most probably is
different. This assertion usually is triggered if a filter has a wrong idea
about what "100%" complete means and later on then sets values >100%. Obviously
this can happen in saving sxc documents or in saving a Writer document.

Having both in one issue makes it hard to assign it to a suitable developer.
Comment 6 Rob Weir 2013-07-30 02:18:55 UTC
Reset assignee on issues not touched by assignee in more than 2000 days.