Issue 38113

Summary: Cell size (height/width)
Product: Calc Reporter: kjohnstn <kjohnstn>
Component: formattingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: gerry, issues, kamataki, mnagashree, peschtra, t.shionoiri
Version: OOo 1.1.2Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
1st part of reproduce steps
none
2nd part of reproduce steps
none
Pic of the grid and cell not lining up.
none
Pic of issue in 1.9.65
none
Spreadsheet that I used so that anyone can check the setting and play it none

Description kjohnstn 2004-11-30 06:34:41 UTC
I tried to set the Row Height and Column Width to 10.00pi, but it doesn't get
set quite right. The actual exact cell size is 9.9758pi (wide) x 9.9628pi
(tall). If I turn on Grid at 1.00pi and scroll through the sheet, the cell
borders "drift" relative to the grid point background.

I tried tweaking the Height and Width to 10.01pi, but the actual exact size got
*SMALLER*. I couldn't iteratively narrow in on Height/Width values that matched
the grid, because minimal adjustments caused much larger effects, in
inconsistent directions.

Note: I have also tried OOo1.1.3, and the behavior appears to be identical.
Comment 1 frank 2004-12-07 16:37:30 UTC
Hi, 

nobug found so far. Setting the column width / row height with the spin button
may give you such a problem, this is because the underlying measurement system
is metric und must be converted. If you type 10 directly into the number field,
this is set correctly.

Frank
Comment 2 frank 2004-12-07 16:37:45 UTC
closed wfm
Comment 3 kjohnstn 2004-12-08 05:02:22 UTC
I typed 10 directly into the number field.

After I set the height/width, if I select a row and right-click "Height..." it
*says* "10.00". But it's not true.

Please try this: Set row height = 10pi, column width = 10pi. With the Draw tool,
draw a small square 1pi by 1pi. Select this square, right-click "Position and
Size". Set X position = 0, Y position = 500pi. Scroll down to row 51. The square
should be perfectly in the top left corner of cell A51. For me, it's not. It's
not even close. It's about 20% down from the top of row 51; or approx 2pi error
in 500.

Cut the square. Select cell A51, and paste the square back into it again. It
appears in the top left corner of the cell. Right click "Position and Size"
again. The X position of the top left corner of cell A51 should be 0, and the Y
position should be 500pi. For me, it's not. For me, the Y position is 498.13pi -
about 2pi error. (Also note that the anchor symbol for the square is not in cell
A51, it's up in cell A50.)
Comment 4 abdul 2005-01-07 04:27:16 UTC
Unable to replicate the Bug.

closing wfm...
Comment 5 peschtra 2005-01-08 21:52:55 UTC
I can confirm this issue in 1.1.4 & 1.9.65. My measurements are in pica and I
didn't use the spin button, all were entered directly as 10.00pi.

You can see the screenshots replicating the instructions below in ss 1 & 2.

SS 3 illustrates the main issue, that either the cell size in picas in not
calculating correctly. (Either that or both the grid and the object position and
size are calculating wrong. Which may make sense if the draw functions are
separate from the cell size.) Either way, something is wrong.

Where the gird ends at 500 pi does not line up with the bottom of row 50 which
is where 500 pi should occur.

SS 4 is a replication of the issue in 1.9.65.

Abdul & fst -> What were you using that couldn't duplicate it, maybe it is a
Windows issue?
Comment 6 peschtra 2005-01-08 21:54:45 UTC
Confirmed in 1.1.4 & 1.9.65.
Comment 7 peschtra 2005-01-08 21:55:21 UTC
Created attachment 21253 [details]
1st part of reproduce steps
Comment 8 peschtra 2005-01-08 21:55:44 UTC
Created attachment 21254 [details]
2nd part of reproduce steps
Comment 9 peschtra 2005-01-08 21:56:16 UTC
Created attachment 21255 [details]
Pic of the grid and cell not lining up.
Comment 10 peschtra 2005-01-08 21:56:35 UTC
Created attachment 21256 [details]
Pic of issue in 1.9.65
Comment 11 peschtra 2005-01-08 21:57:04 UTC
Created attachment 21257 [details]
Spreadsheet that I used so that anyone can check the setting and play it
Comment 12 baaann 2005-01-09 01:04:27 UTC
I can also replicate 1.1.3 on Slackware 10 
Comment 13 grsingleton 2005-01-09 01:40:49 UTC
Confirmed in 1.9m67. Grid is skewed dramatically from what is expected. Changing
units to metric, specifically mm, leaves the grid exactly where is was before.
i.e. no change.

Furthermore Help does not address this but that is another issue.
Comment 14 frank 2005-01-10 09:13:47 UTC
Hi Niklas,

please have a look at this Issue.

Frank
Comment 15 diane 2005-01-10 15:01:00 UTC
an excellent discussion about this issue lives in the users list archives:
http://www.openoffice.org/servlets/ReadMsg?list=users&msgId=1700824
Comment 16 Marcus 2017-05-20 11:13:49 UTC
Reset assigne to the default "issues@openoffice.apache.org".