Issue 38822

Summary: Pls. enhance font matching for e.g. "SunSans-Regular"
Product: gsl Reporter: ulf.stroehler
Component: codeAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P4 CC: issues
Version: 680m65   
Target Milestone: AOO PleaseHelp   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description ulf.stroehler 2004-12-10 16:48:40 UTC
This is a follow-up issue to internal #110298#:

From #110298#:
"as seen by HDU an me, some Sun fonts are known as e.g. SunSans-Regular (with an
hyphen instead of a blank in its name); in this case the name gets stripped to
"sansregular" and in a second step to "" an empty string. Hence the font
matching only relies on the attrbutes of the font name, which lead on a "fedora
core 2" to an b&h lucida bitmap font to be matched to.
This problem is currently workarounded by several new "SubstFonts" sections in
VCL.xcu for "sansregular" , "sansdemi" , "sansheavy" , "sansbold" , "sansitalic"
and so on."

US->HDU: you volunteered for a real/better solution.
Comment 1 hdu@apache.org 2004-12-13 09:01:49 UTC
.
Comment 2 thorsten.ziehm 2005-04-11 15:47:03 UTC
Because of limited resources we have to re-target this issue to the next
release. => set to OOo2.0.1
Comment 3 hdu@apache.org 2005-05-26 10:55:07 UTC
I'm sorry that there are not enough resources to change this behaviour for 2.0.1
Comment 4 Marcus 2017-05-20 11:29:47 UTC
Reset assigne to the default "issues@openoffice.apache.org".