Issue 3886

Summary: Does not have sub-pixel (rgb) AA on Linux
Product: gsl Reporter: Unknown <non-migrated>
Component: codeAssignee: hdu <hdu>
Status: CLOSED DUPLICATE QA Contact: issues@ui <issues>
Severity: Trivial    
Priority: P4 CC: issues, stp, ulf.stroehler
Version: 641   
Target Milestone: AOO PleaseHelp   
Hardware: PC   
OS: Linux, all   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description Unknown 2002-04-05 18:46:59 UTC
The anti-aliasing in OOo doesnt seem to follow the setting in my Xftconfig (do
you use Xft at all? It would be nice if you did). And I so it does no do
sub-pixel anti-aliasing. Sub-pixel AA is much much nicer on my laptop and it
would be very nice if you supported it.
Comment 1 stefan.baltzer 2002-06-24 11:22:46 UTC
Reassigned to Ulf.
Comment 2 ulf.stroehler 2002-06-24 17:54:32 UTC
No, as far as I know we don't care about the settings in the
Xftcongfig file as we provide our own freetype.

US->HDU: could you do pls. some more investigation (put in your
opinion) on this issue, before sending it as a feature request to FT.
Thank you.
Comment 3 christof.pintaske 2002-06-24 18:49:28 UTC
HDU is on vacation, so no SUN but lots of sun. We do not use Xftconfig
since we do not use Xft. We will reevaluate the issue whe Xft becomes
a stable and integral part of XFree86. 
Comment 4 hdu@apache.org 2002-07-15 12:57:26 UTC
HDU->US/FT: I agree that subpixel-AA would be a nice feature  
  
The subpixel AA is a very nice feature of XFT and we are  
considering ways to use it despite the issues mentioned below.  
  
XFT is very promising from a display standpoint and also  
for generalizing font discovery, font fallback and  
configuration issues like you mentioned. There are some  
problems with using it now though:  
  
- the basic promise of generalizing the above mentioned items  
  only works when it is generally available and the API and  
  configuration settings are stable. This is not the case yet  
  on all relevant X11 platforms.  
  
- for some "exotic circumstances" like CJKV or CTL issues and  
  even for printer layout we need very tight control over the  
  fonts/glyphs and their fallbacks. With some work newer XFT  
  allow this freedom, but the main point of XFT of making this  
  work transparent for upper layers gets kind of pointless. Like  
  in "all pain, no gain".  
  
- for legal reasons we have to have very tight control of the  
  features compiled into libraries that XFT links to. Currently  
  we do this by compiling them ourselves and linking them 
  statically. With linking to a system provided XFT we might 
  expose us to problems from this direction.  
  
Comment 5 falko.tesch 2003-09-12 14:03:18 UTC
+1 for Herbert.
Please bring it up in Feature discussion. Thx.
Comment 6 falko.tesch 2003-09-12 14:03:48 UTC
started
Comment 7 bettina.haberer 2004-04-08 18:51:25 UTC
Hello Herbert, how is the state now? Was ist possible to get something done
concerning sub-pixel AA?
Comment 8 hdu@apache.org 2004-05-14 15:54:32 UTC
We should do it but I doubt the OOo 2.0 target....
Comment 9 Martin Hollmichel 2004-05-28 17:43:51 UTC
according to the announcement on releases
(http://www.openoffice.org/servlets/ReadMsg?list=releases&msgNo=7503) this issue
will be re-targeted to OOo Later.
Comment 10 gawron 2007-10-25 17:33:31 UTC
Any news on this issue? It's 2007 and still no AA in OpenOffice in Linux (at
least not on Ubuntu Gutsy Gibbon version...)... 
Comment 11 hdu@apache.org 2008-08-05 14:43:31 UTC
Implemented for OOo >2.4 in issue 85470.

*** This issue has been marked as a duplicate of 85470 ***
Comment 12 hdu@apache.org 2008-08-05 14:44:07 UTC
Closing.