Issue 38999

Summary: Problem with CTL Arabic fonts
Product: gsl Reporter: pfafakos <pfafakos>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: flibby05, hdu, issues
Version: OOo 1.1.3Keywords: oooqa
Target Milestone: AOO PleaseHelp   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Problem with justification and display none

Description pfafakos 2004-12-14 20:42:20 UTC
Dear developers of the OOO Community,

I am using OOO 1.1.3 to format an arabic document in Windows 2000.

I am trying to replace the MS Office application with OpenOffice.

I have noticed that the CTL presentation of arabic characters in OOO differs 
from the CTL presentation of arabic characters in MS Word 2000.

The font I am using is the same, but the actual drawn glyphs are different.

What could be wrong?

I will post a follow up with an http link to submit some samples.

Thank you in advance,

Panayiotis Fafakos.
Comment 1 flibby05 2004-12-14 21:11:58 UTC
set prio P1 -> P3
Comment 2 ulf.stroehler 2004-12-15 07:13:01 UTC
US: thanks Max!

@submitter: why not attach the document in question and a screenshot that shows
the difference to this issue?
Comment 3 ulf.stroehler 2004-12-15 07:14:34 UTC
Corrected Component and CC-ing HDU.
Comment 4 michael.ruess 2004-12-15 08:12:57 UTC
please attach the offending document to this issue, so that we can reproduce and
fix the problem here. You can also send the document directly
(mru@openoffice.org) for the case it contains confidential data. Feel free to
re-open the issue when you've done.
Thanks for supporting us!
Comment 5 pfafakos 2004-12-15 22:37:24 UTC
Created attachment 20556 [details]
Problem with justification and display
Comment 6 pfafakos 2004-12-15 22:38:59 UTC
Submited files for examination.

Comment 7 pfafakos 2004-12-15 22:44:24 UTC
By the way, I have tried to use print screen to do the screen captures, and 
then paste the clipboard image into OOO 1.1.3 but the image would not be pasted.

I used MS Word to create the file with the screens captured by pasting them 
from the clipboard.

Then I opened OOO to save it as .sxw.

Should I open another issue for not pasting from the clipboard?



Comment 8 michael.ruess 2005-01-05 10:50:49 UTC
MRU->US: THe import looks quite ok, but the glyphs are drawn slightly incorrect.
They are partly painted over the right page border.
Comment 9 ulf.stroehler 2005-06-27 13:16:16 UTC
Setting Target.
Comment 10 hdu@apache.org 2005-07-11 13:41:53 UTC
HDU->FME: As far as I see Writer does latin justification instead of kashida
justification. IMHO we really should do kashida justification not only when the
language is correctly set to Arabic but also when the script suggest is Arabic.
It is easily recognizable from the unicodes used if this is the case

Another issue seems to be with the import filter which doesn't import the text's
language attribute.
Comment 11 frank.meies 2005-07-12 11:08:19 UTC
FME->HDU: There are a couple of features that rely on a correct language
attribute. We should fix this in the filter.

FME->FR: As discussed, the language attribute is lost during import. Please have
a look.
Comment 12 Mathias_Bauer 2006-01-20 16:49:28 UTC
Currently no resources available -> later
Comment 13 Rob Weir 2013-07-30 02:46:59 UTC
Reset assignee on issues not touched by assignee in more than 1000 days.