Issue 39658

Summary: grid subdivision should change number of intervals, not number of dividing points
Product: Draw Reporter: morganolsson <fri>
Component: viewingAssignee: requirements <requirements>
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: issues, oo, peschtra, rb.henschel
Version: 680m65Keywords: oooqa, rfe_eval_ok, usability
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 39831    

Description morganolsson 2004-12-29 11:34:20 UTC
The behaviour of grid subdivision is unusual to other programs, and what is 
worse, is it do not follow the online help.  As the help describes the logical 
behaviour found in other programs, i think the help shall stand as is, and Draw 
program should be corrected.
Tested in OOo 1.1.4 and 1.9.m65 (680_m65) on MSWin2k, identical behaviour.

To see this:
Go to Menu: Tools->Options... OpenOffice.org Draw / Grid
Turn on "Snap to grid" and "Visible grid"
Set division to 1 cm, and Subdivision to 10 (both X and Y)
In every other program i have used, that makes the program step in mm (1 cm 
subdivided in 10 parts)

Here on OOo we need to set the subdivisions to 9 when we want 10 steps per 
division.  Not logical, not like othe rprograms do it, and not as help say.

(try for example by drawing a rectangle, while watching the dimension in bottom 
status bar while you draw)

(One explanation: It seems OOo is counting the dots between the divisions 
although the settings read subdivisions.  Strange and unusual idea)

Press [Help] while in the grid settings, and scroll to read about "Subdivision". 
There you see that it say "Specify the number of intervals between grid points"

This is a clear descrition, and like other program si have used do it.
Lets illustrate just to be very clear...  Below i try to illustrate a part of 
the grid, along a by subdivision dotted line from 1 to 2 cm in Y direction.
Top and bottom "_" are whole-centimeter-lines, between them are 10 intervals 
each one mm:

10  _ (master grid line at 1 cm)
11  . < interval 1 between 10 and 11 mm, then a dot
12  . < interval 2 between 11 and 12 mm, then a dot
13  . < interval 3 between 12 and 13 mm, then a dot
14  . < interval 4 between 13 and 14 mm, then a dot
15  . < interval 5 between 14 and 15 mm, then a dot
16  . < interval 6 between 15 and 16 mm, then a dot
17  . < interval 7 between 16 and 17 mm, then a dot
18  . < interval 8 between 17 and 18 mm, then a dot
19  . < interval 9 between 18 and 12 mm, then a dot
20  _ < interval 10 between 19 and 20 mm, then master grid line at 2 cm

Clerly there are 10 interval (or subdivisions) between each master grid line. 
(Analog to 10 millimeters between each centimeter line)

But i need to set 9 subdivisions in order to get ten!

The OOo program seem to think "9 _visible dots_" between master grid lines thus 
making ten intervals when we set it to 9, which in my opinion cleraly is wrong 
according to both the help file and common usage.

I think the help file is right, and the program action wrong.

If it is an issue, now before 2.0 is the right time to correct.
(it is probably only a line of code, but the problem is to decide what is the 
correct behaviour)

I would vote for doing it exaclty like the help say:
"Specify the number of intervals between grid points"

Maybe in the settings dialog, the word should be changed to "sub-intervals" 
(between grid lines)  As maybe divisions have been read in different ways by 
help author and programmer already ;)

Also discussed in mailing list discuss@openoffice.org my post "OOo Draw Grid 
Subdivision definition bug?", Date: Tue, 28 Dec 2004 00:02:57 +0100
Comment 1 peschtra 2004-12-29 21:04:17 UTC
Confirmed in OOo 1.1.4
Comment 2 wolframgarten 2005-01-03 08:32:06 UTC
As far as I can see there is no other behaviour as it is described in the help.
So I set this to enhancement because that's what it is.
Comment 3 morganolsson 2005-01-03 17:15:57 UTC
The help say exactly:
"Specify the number of intervals between grid points"

But to get ten intervals we need to enter "9"

So, the program is definately not operating as described in the help file.

This also is not like people are used to, and is getting a pain when jumping 
between 10 and 20 intervals for example (1 and ½ mm on a 1cm base grid), where 
we need to enter 9 and 19 respectively.  Besides not as described in help, it is 
confusing.  I would call it a defect, repairing a defect is a enhancement, so 
whatever you call it... it should be repaired.
Comment 4 lohmaier 2005-01-03 18:08:02 UTC
confirming. The behaviour matches the dialog, but not what is written in Help.

I'd love to see that the behaviour would be changed so that you would be able to
adjust the number of segments, not the number of dividing points.

I wrote a seperate issue 39831 regarding the help.
Comment 5 lohmaier 2005-01-03 18:10:11 UTC
adjusted summary. original summary: "Grid Subdivision is weird and not as
described in help"
Comment 6 bugsi 2007-10-04 00:37:43 UTC
I just began trying out OpenOffice while looking for a Windows program similar
to "Omnigraffle" for Macintosh.  The DRAW module looked promising.  But the very
first thing I tried to do was to create a flowchart where I needed to add shapes
that snapped to a grid, and I ran into this issue.  It uses an extremely poor
choice of how to subdivide a measurement unit.  If I want eights-of-an-inch, I
need to choose Inch, and then set subdivisions to. . .7!  (which adds seven
evenly spaced grid dots *between* the end-dots of the measurement unit.  This is
a moronic way to handle this, every other program on earth would call this "8
subdivisions of the inch".  -I can get what I want (eighths of an inch) but I
have to set the divisions to "7" to get it.  (And the rulers are fixed to 10ths
of an inch, which is an equally annoying problem.  -And alt-drag does not do a
copy+paste, but again, this is another separate issue.  (Which when combined,
will keep me from using this application.)
Comment 7 morganolsson 2007-10-05 10:38:02 UTC
Thank you for commenting.
I was beginning to think nobody use OOo draw...
Yes it is annoying OOo does this in another way than any other tool i have seen.

 ( <paranthesis> About your other issue:
As for learning how to do things, please first ask on user forum, and if a 
feature do not exist then file a request in a aseparate issue here.

In OOo Draw you can copy while dragging an object by the Ctrl key, then click 
and drag.  First enable this feature by setting a mark in right place in Tools-
>Alternatives->OpenOffice.org Draw.
    </parantesis> )

As for the subdivisions, it would be nice if there eventually would be a 
dicision about if OOo will continue to do this in a different way than any 
other program, or it will be fixed to work the logical way.
Soon 3 years have passed and it is still registered as enhancement without 
target version.
Comment 8 bugsi 2007-10-05 16:46:55 UTC
Thank you for the reply, and the additional info about Ctrl+drag.  The
subdivision problem really is quite bad, I can't imagine how any engineer *that
has ever used a graphic drawing program before* would implement dividing a
measurement unit by offering a box to enter "how many dots to add between
endpoint?" -To me it is clearly a case of a programmer who doesn't actually use
Draw apps making the control.  I don't understand why this hasn't been fixed,
all it would take is using exactly what is already there, but adding "n-1" dots
when the user enters "n" subdivisions.

The result, however, is someone like me who eagerly considered using the
application, but immediately ran into an issue like this:  -Definitely wrong,
and easily fixable- Only to find that the issue was reported three years ago and
never fixed.  This just sends a message to me that sorely needed fixes to really
bad user interface implementations in OpenOffice apparently don't get fixed, and
that is enough to send me running and screaming towards a better commercial
application.

It's really sad that there is not a simple and effective diagramming application
for Windows, Omnigraffle is simply an amazing program on Macintosh, with no
as-simple and as-powerful equivalent on Windows.  OpenOffice Draw was
recommended as a possible alternative, but after seeing this giant flaw, I'm
turning to Illustrator for my Windows diagramming needs instead.  Compared to
OpenOffice it is big, overkill, and expensive; but to Adobe's credit, it is
engineered by people who really do understand computer drawing, and any flaws
like this one in OpenOffice were corrected long ago.

I don't know what one has to do, to get this issue fixed in OpenOffice.  If
three years of knowing about it has resulted in nothing, I hesitate to wonder
how long it takes to fix really serious bugs?  Personally, I can't take this
product seriously if programmers don't take reports of flaws like this seriously.

I hope I don't sound too negative, but I had high hopes for OpenOffice, and I
think I learned "the hard way" that it's just not the contender it is purported
to be.  Perhaps a company selling commercial software has a greater interest in
improving their products than a company that makes no money on a product by
distributing it as free, opensource software.  Still, if it's opensource, you'd
figure somebody would have corrected this by now.

I think I agree with you, maybe there really is nobody using the draw module. 
My guess is the write module is the most-used OpenOffice component, as an
alternative to Word.
Comment 9 Regina Henschel 2012-08-26 21:04:54 UTC
The field counts spaces now, no longer dots, in AOO 3.4.1