Issue 40717

Summary: Bullets On/Off Button doesn't work -- The Bullets are invisible
Product: Writer Reporter: peschtra <peschtra>
Component: editingAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: hdu, issues, jclift, nospam
Version: 680m65Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Click on Bullet Button
none
When I use the context menu
none
list Issue
none
list issue 2
none
Version 1.7.6 of OpenSymbol font
none
My Open Symbol Font
none
Screenshot of m79 showing OpenSymbol font and invisible bullets
none
Open Symbol Version #
none
No bullet in 1.9.79
none
Bullet in 1.1.4
none
Screenshot of Justin's languages settings (zipped bmp file)
none
Screenshot of Insert -> Special Character on Justins PC. none

Description peschtra 2005-01-15 06:44:28 UTC
When I click on the Bullets On/Off Button, a bulleted list doesn't start.
However, if I open the context menu and go to Bullets/Numbering and start a
list, a bulletd list starts.

This happens in 1.6.65 & 1.9.69.

Thanks.
Comment 1 peschtra 2005-01-15 06:45:06 UTC
Created attachment 21541 [details]
Click on Bullet Button
Comment 2 peschtra 2005-01-15 06:45:53 UTC
Created attachment 21542 [details]
When I use the context menu
Comment 3 michael.ruess 2005-01-17 08:28:24 UTC
Do not have the problem. Maybe the OpenSymbol font is not installed?
Comment 4 peschtra 2005-01-17 16:35:57 UTC
OpenSymbol TT is installed.

It appears to be an issue of the styles not being set up properly. When I try to
start a list by double clicking on like List 1 in the stylist the indentation
happens, but no bullets. When I open up the styles and try to modify it, there
are no symbols associated with it. (list_issue.jpg)

If I associate the symbol with the list style, then everything works when I
start a list with a style, but still no luck with the Bullets & Numbering
button. When I click the button, it indents, but no symbol. When I go into
Bullets & Numbering Options from the new list, it says the bullet is supposed to
be there, but it doens't actually show up in the list. (list_issue2.jpg)

When you say it works for you, do you mean that off a fresh install on Win XP
when you press the Bulleted list button on the main toolbar, a list with bullets
starts? I don't understand why mine wouldn't work, I don't have this issue with
1.1.4.

Thoughts?
Comment 5 peschtra 2005-01-17 16:36:23 UTC
Created attachment 21616 [details]
list Issue
Comment 6 peschtra 2005-01-17 16:36:53 UTC
Created attachment 21617 [details]
list issue 2
Comment 7 michael.ruess 2005-01-18 14:34:52 UTC
MRU->FME: though I cannot reproduce the problem, I can imagine what the problem
is. Systems where only OpenSymbol is installed seem to have this. 
See on peschtra's last screenshot: there you can see, that "Tahoma" is displayed
as font for the bullet. Normally in SO it is StarSymbol, and it seems, that it
is not correctly replaced by OpenSymbol. When I delete StarSymbol from my
system, the dialog displays "MS sans serif" instead of StarSymbol.
What is your opinion?
Comment 8 peschtra 2005-01-18 23:40:40 UTC
Is there a place where I can change the default bullet font?
Comment 9 frank.meies 2005-01-19 06:45:35 UTC
FME->IH: Looks like the OpenSymbol font is broken. I had a look at the
OpenSymbol font installed on my machine and the one which is part of SRC680m72.
Both of them actually seem to be empty. Please have a look.
Comment 10 nospam 2005-01-20 15:47:42 UTC
IH: I did not change anything in the font in this area? So I do not know how to
fix this? Did it really work in older versions?
Comment 11 frank.meies 2005-01-20 16:02:32 UTC
FME->IH: As discussed, back to you.
Comment 12 frank.meies 2005-01-20 16:03:22 UTC
.
Comment 13 nospam 2005-01-20 17:03:49 UTC
IH: fixed in CWS extras17.
Comment 14 nospam 2005-01-31 11:40:52 UTC
.
Comment 15 nospam 2005-01-31 11:41:58 UTC
..
Comment 16 nospam 2005-01-31 11:42:28 UTC
...
Comment 17 ulf.stroehler 2005-02-01 10:33:56 UTC
Reopening for reassignment.
Comment 18 ulf.stroehler 2005-02-01 10:35:15 UTC
Reassigning to module owner.
Comment 19 ulf.stroehler 2005-02-01 10:36:01 UTC
Setting back 'fixed'.
Comment 20 peschtra 2005-02-02 05:33:31 UTC
I what version, or at what point should a person see this work? It doens't in
1.9.74.
Comment 21 michael.ruess 2005-02-08 09:01:53 UTC
Reopened.
Comment 22 michael.ruess 2005-02-08 09:04:58 UTC
The problem still exists. Clicking the Bullets-on-button will show an empty
numbering label; means: bullet is not shown in CWS extras17.
Comment 23 michael.ruess 2005-02-08 09:33:19 UTC
*** Issue 42252 has been marked as a duplicate of this issue. ***
Comment 24 nospam 2005-02-09 09:28:41 UTC
.
Comment 25 michael.ruess 2005-02-09 09:40:44 UTC
Checked again on different WindowsXP system and it works with OpenSymbol 1.7.6
in the CWS. Looks like a problem of the other WinXP system I used.
Comment 26 michael.ruess 2005-02-09 09:43:14 UTC
Verified fix in CWS extras17.
Comment 27 peschtra 2005-02-13 03:29:00 UTC
How does a person get a new copy of Open Symbol?

I still can't get this to work on 1.9.78.

Thanks.
Comment 28 michael.ruess 2005-02-14 07:27:16 UTC
MRU->IH: could you please attach a version of OpenSymbol 1.7.6 to this issue?
Thanks a lot!
Comment 29 nospam 2005-02-14 08:09:04 UTC
Created attachment 22573 [details]
Version 1.7.6 of OpenSymbol font
Comment 30 peschtra 2005-02-15 00:59:11 UTC
This (attachment) is what I see when I downloaded and installed the new font. Is
that it should look like.

I still have the bullet issue.
Comment 31 peschtra 2005-02-15 00:59:36 UTC
Created attachment 22629 [details]
My Open Symbol Font
Comment 32 michael.ruess 2005-02-15 10:40:48 UTC
Sometimes Windows has problems when a font has been exchanged. Please delete
again, reboot system and install the new OpenSymbol font.
What you see on your screenshot is o.k.
Comment 33 justinclift 2005-02-24 08:03:19 UTC
Hi,

I'm experiencing this exact same problem with m79.

The other applications on this (new) build of XP SP1 are:

 + Microsoft Office XP
 + Adobe Acrobat Reader

0 other installed apps.

I've installed m77 on this box, then deinstalled it and installed m79.

For me, when I create any text in writer, highlight it, then try to bullet it,
the text is correctly indented but no bullet symbol appears.

After reading this IZ, I've uninstalled m79, deleted the OpenSymbol font from
C:\Windows\System32, rebooted, and installed m79 again, then rebooted again just
 to be sure.

Still no change.  The bullets are invisible.

Any recommendations?  This is a complete blocker for developing Writer training
flashes on that cover bullets. :(

(Also, would it be ok for someone to please change the Summary line to be a
better description like "Bullets are invisible"?  Almost didn't look at this
issue because of the misleading name...)

Regards and best wishes,

Justin Clift
Comment 34 justinclift 2005-02-24 08:05:00 UTC
Typo in my last comment.  I deleted OpenSymbol from C:\Windows\Fonts, not
C:\Windows\System32.

;)

Regards and best wishes,

Justin Clift
Comment 35 justinclift 2005-02-24 08:07:57 UTC
Created attachment 22973 [details]
Screenshot of m79 showing OpenSymbol font and invisible bullets
Comment 36 justinclift 2005-02-24 08:10:37 UTC
Oops, just checked in EIS and it looks like this will be integrated in m80.

So, I need to wait a week or so I guess.

+ Justin
Comment 37 peschtra 2005-02-24 11:16:00 UTC
@Justing -- I changed the summary, although in reality, anyone can. When you are
entering a comment, just edit the summary as you would any other text box.

I am not sure where you checked whatever and EIS, but I would confirm that it
doesn't work in 1.9.79 even after re-installing OpenSymbol.
Comment 38 nospam 2005-02-24 11:25:28 UTC
IH: If you install the OpenSymbol font attached to this issue it should
definitely work - regardless of which Office you use. I can not understand why
it does not work for you - sorry
Comment 39 peschtra 2005-02-24 11:32:36 UTC
Can you please explain how to uninstall/reinstall the font.

I deleted it from the font folder. Rebooted and copied the opensymbol file I
downloaded here.

Not sure what else to do.
Comment 40 nospam 2005-02-24 12:27:33 UTC
IH: I think you do nothing wrong in the installation process. If you double
click on this font you should see a lot of squares and a version numer 1.7.6.
You can check if the font contains the characters on the right places if you
open a textdocument in Office and then select Insert->Special Character and
choose OpenSymbol as the font. Then you can search for the normal single bullet
(it is in line 5 the 3rd from left) and it should have Unicode Position 2022
(you can see this in the bottom right in this window). If this value is correct
the bullets should work in the text document if you activate numbering/bullets
or choose bullets.
Comment 41 justinclift 2005-02-24 12:50:43 UTC
Hi,

I'd love to have been able to change the Summary, but it's not a text box for
me.  All of the fields are standard text (not editable text boxes) except for
the "Additional comments" field, the dependency field, and the blocks field.

With the mention of EIS (to check when we'll see this fix), here's the
description of it that Frank Schönheit (Sun) gave me the other day:

***********

Without going into detail: Developers work on branches only (so-called
CWS [1]), while the snapshot is made from cvs-HEAD. FIXED means the fix
made it onto a branch only.

If you want to see the status of the branch where an issue is fixed, go
to eis.services.openoffice.org, menu "Child Workspaces"/"Search", and
search for the issue. This gives you an idea of the status of the child
workspace, and also into which milestone it is integrated.

If you don't want that much detail, look for CLOSED: According to "A
bug's lifetime", described at http://qa.openoffice.org/issue_handling/,
an issue is CLOSED when it's verified that the fix made it into the
developer snapshots ([2]) (the so-called "master").

So if the issue is CLOSED it means it should be fixed in the master, if
it is still RESOLVED, it is either not yet integrated, or not yet verified.

***********

Going there and searching for "extras17" (which mru said this issue is fixed in)
brings us to this URL with the latest information of the fix:

http://eis.services.openoffice.org/EIS2/servlet/cws.ShowCWS?Id=2061&Path=SRC680%2Fextras17

That URL says this fix is integrated in m80, and we're only running m79, which
is why we still have the problem.

OOo2 Beta _might_ be m80 or above, but I'm not sure at this point.

Hope that helps. :)

Regards and best wishes,

Justin Clift
Comment 42 nospam 2005-02-24 13:02:01 UTC
IH: As already mentioned: You do NOT need to wait for m80 - you can simply
install the OpenSymbol font attached to this issue here and you can use ANY
office to test the fix. (see my last comment for info about testing) For this
fix nothing else than the font is changed (it has not to do anything with the
office-code itself) and this fontfile is already attached to this issue here.
Comment 43 peschtra 2005-02-25 01:02:39 UTC
@Justin -- Sorry, thought everyone could change the summary, I guess you have to
have volunteer priveleges. Sorry if I was gruff. :(

@IH -- I really am not trying to be a pain, if I am being a pain, I greatly
apologize, I just can't figure out what I am doing wrong. I have attached three
files. The first is a picture of my OpenSymbol font so you can see it is 1.7.6.
I also have attached a picture of my special character menu in 1.9.79 that shows
my cursor at U+2022 and no bullet there. The third is a picture of special
character menu in 1.1.4 where you can see my cursor at position U+2022 and there
is a bullet.

Do you have anythoughts on why this isn't working?

Thanks again.
Comment 44 peschtra 2005-02-25 01:03:52 UTC
Created attachment 23008 [details]
Open Symbol Version #
Comment 45 peschtra 2005-02-25 01:04:19 UTC
Created attachment 23009 [details]
No bullet in 1.9.79
Comment 46 peschtra 2005-02-25 01:04:37 UTC
Created attachment 23010 [details]
Bullet in 1.1.4
Comment 47 peschtra 2005-02-25 01:58:41 UTC
I know you said it doesn't matter, but I just installed 1.9.8 and I have the
same issue.

Thanks.
Comment 48 justinclift 2005-02-25 03:01:46 UTC
Hi "ih",

Using the font attached to this issue doesn't appear to fix the problem.

The steps I tried are:

Delete the OpenSymbol font from the C:\Windows\Fonts directory.

Reboot.

Download the font attached to this issue:

http://www.openoffice.org/nonav/issues/showattachment.cgi/22573/opens___.ttf

Copy it to the C:\Windows\Fonts directory.  Windows automatically pops up a
percentage bar dialog titled "Installing new font".

Reboot, just in case it's needed.

Start OOo m79.  Type some text, highlight it, then click the Bullets button.

The text is indented, but the bullets are still not visible.

As an additional thought, peschtra has attached a PNG image of how the
OpenSymbol font looks ons his system:

http://www.openoffice.org/nonav/issues/showattachment.cgi/22629/opensymbolfont.png

This is exactly how your supplied OpenSymbol font appears on my system when I
double click it.  It opens up and just has square boxes.

Is there any chance this may be caused by language settings in XP?  I have _all_
of the additional languages and the Asian languages installed as well as
English, though English is the default.

I'll attach a screenshot of my language settings, in case that helps.

Regards and best wishes,

Justin Clift
Comment 49 justinclift 2005-02-25 03:02:34 UTC
Created attachment 23012 [details]
Screenshot of Justin's languages settings (zipped bmp file)
Comment 50 justinclift 2005-02-25 03:13:48 UTC
Hi ih,

I just understood your comment about going to Insert -> Special Character and
looking for the bullet character there.

I've just done that with your font attached to this issue (this PC definitely
has your font installed, I've rebooted several times since) and the character
shown is completely empty for position u2022.

Screenshot attached.

Regards and best wishes,

Justin Clift
Comment 51 justinclift 2005-02-25 03:14:40 UTC
Created attachment 23013 [details]
Screenshot of Insert -> Special Character on Justins PC.
Comment 52 nospam 2005-02-28 08:22:53 UTC
IH-> peschtra and justin, thank you for you great help here in the last days. It
seems that the problem you experience is not a problem of the font itself. On
some systems it works and on some  (yours included) it does not. We will try to
have a meeting here today with some developers to find out what is going wrong here.
Comment 53 hdu@apache.org 2005-03-01 10:19:16 UTC
There definitely is a problem with the font. Just open it in with the "Character
Map" application to see the problem. You'll find this application in
Start->Accessories->SystemTools.

That it "worked" in 1.1.4 has a different reason: OOo/SO tries very hard to
display text correctly even if there are some problems. In the case of 1.1.4 the
"glyph fallback" feature was triggered, which means, that the bullet one can see
was not from the problematic font, but from another font, e.g. Andale. This
heuristic changed from 1.1.x to 1.9.x: OOo now trusts the font more than the
system services.

Anyway: in this case the glph fallback feature should have never been triggered.
Neither in 1.1.x nor in 1.9.x. Im not sure yet why the font causes problems for
all applications though...
Comment 54 michael.ruess 2005-03-06 10:39:08 UTC
*** Issue 44112 has been marked as a duplicate of this issue. ***
Comment 55 michael.ruess 2005-03-16 14:21:10 UTC
Colsed. At the moment, we leave th font "as is". There are still remaining
problems on SOME Wondows systems. For this there has been reported issue 45163,
so please do not reopen this issue. Thanks!
Comment 56 peschtra 2005-03-16 16:33:34 UTC
OOC, why was this closed in favor of the other one?
Comment 57 michael.ruess 2005-03-16 16:46:01 UTC
Because the general problem has been fixed and a remaining issue exists (which
does not occur everywhere). So to keep issue handling conveniant in a way, we
use a new issue for this.