Issue 41097

Summary: Styles and Formating vs Stylist
Product: ui Reporter: sgautier.ooo
Component: uiAssignee: e.matthis
Status: CLOSED IRREPRODUCIBLE QA Contact: issues@ui <issues>
Severity: Trivial    
Priority: P3 CC: issues, peschtra, stx123
Version: 680m69   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description sgautier.ooo 2005-01-21 14:38:10 UTC
Hi, 
Stylist has been renamed as Styles and formating. 

This renaming is very confusing for previous users that has to deal with a lot
of new features, new elements/order of GUI and the names of new files format.
This name was OOo only, making the feature specific to the product. Stylist is a
marketing topic for most of us (NLC I named) as is the Navigator or OOo toolbars. 
The name itself described the feature and its functionality and allow us to
explain why styles are so important for interoperability purposes.
More, the term Stylist is used in all our books, guides, How-tos, training
material (even for the next release 2.0 for which we have already prepared
material and for which companies migrating directly on 2.0 have already prepared
this material).
It even appears in the help files (yes it's in old terms index, but you have to
quit the actual help page, go to the index, imagine/undersand what is the
Stylist and go back to what you're trying to learn...).
So in order to take into account previous users (they have make the success of
OOo), in order to take into account new users and in order to don't confuse both
of them with new terms that they will find nowhere in books, how-tos, on line
help, please, move forward and keep the term Stylist instead of Styles and
formating. This last wording change a fabulous tool in a usual functionnality.

Kind regards
Sophie
Comment 1 colm.smyth 2005-01-21 15:17:00 UTC
Ian Lynch wrote:

> On Fri, 2005-01-21 at 12:35, Charles-H.Schulz wrote:
>
>  
>
>> You know, there are also a lot of MS Office users who never found the
>> styles functionnalities in MS Office... :-)
>>   
>
>
> Probably he majority
>
>  
>
Yes, but users found it in StarOffice/OpenOffice.org because we have a Stylist
feature, not because we named it "Stylist". 

For the Stylist we have a help index entry: "Stylist; see Styles and Formatting
window" 

Existing users will easily find the new feature, and new users will more easily
find it with the new name.
Comment 2 sorel 2005-01-21 15:37:23 UTC
Justifying the renaming of "Stylist" into "Styles and formating" by analogy with
M$Office's terminology is not a long term argument. Or maybe we should drop the
OOo nickname and call it wOOord, don't you think so?

I don't believe one should name OOo's exclusive features after something that
looks similar in M$O. Instead, I'd prefer hearing "Hey, this feature doesn't
exist in M$Office, OOo is great" from a new OOo user.

Moreover, The "Stylist" command is available under the "Format" menu so it's
somewhat obvious (and even more for a M$O user) that Stylist deals with
formating. I find the command access "Format/Styles and formating" a little
redundant.
Comment 3 andreschnabel 2005-01-21 18:22:23 UTC
I just filed issue 41106 as a counterpart of this one, so we can have a balanced
voting (pro "Stylist" here and pro "Styles and formatting" at 41106)
Comment 4 bmarcelly 2005-01-23 16:53:33 UTC
It seems Sun marketing is not concerned with current users. It is not acceptable to 
rename a functionality which has not really changed.

In the Stylist window there is another change : the "Numbering Styles" icon is now 
called "List styles". This cosmetic change was done without thinking at the on-line 
help which currently ignores the new name.
Search in help index :
  numbering styles 
  styles;organizing - Numbering Style

All this futility costs a lot of time and is no help to the user.
Comment 5 lucnovales 2005-01-24 09:32:33 UTC
Stylist represents a tool. It is the part of openoffice I prefer enhance, when I
present these tools. It allow to know the difference between both office suites.
The aim of OpenOffice.org suite is structuring documents, using styles (as
previous Ileaf or other suites), it is an opportunity to improve users
formation. Renaming stylist as Styles and formating is a nonsense, and we will
return to "SPACE, TAB and CR" formating documents.

best regards,
Luc.
Comment 6 redlet 2005-01-24 10:18:54 UTC
My parents gave me a Christian name and I'm keeping it until the end. When a
tool remains the same, it's name should remain the same as well. Renaming
Stylist as Styles and formating has no interest. It could even confuse users. If
this tool is renamed, it just mean that what you know today about OpenOffice
will be false tomorrow. OpenOffice would be something you have to learn again
from time to time. This is a very bad idea. It makes me think of Microsoft.
Please, don't have a Microsoft behaviour.
Comment 7 stefan.baltzer 2005-01-24 17:56:33 UTC
SBA->LIZ: Please take over.

My 2 cts: What about a questionnaire during setup "What is your favorite name
for the function/dialog/button [XYZ]" This would serve ALL users best (OK,
beside those that prefer NOT to answer 3000+ questions brefore working with the
office :-)
SCNR
Comment 8 ralphie 2005-01-25 12:55:31 UTC
Please let the labelling be "Styles and Formatting" just like suggested in the
UI specs and don't make any rushed and ill-thought out changes right before the
release.

"Styles and Formatting" is the much better term, because it describes what you
can do with this menu item. I always associated a hairdresser with "Stylist" ;)

I think users of previous versions will not be that much confused, because
a) the term is very similar
b) the actual palette window looks identical
c) there certainly will be release notes detailling the changes
d) even the shortcut is the same

Furthermore the new term can now be sensibly translated into the many laguages
OOo ships in.

I do think however that having an entry for "Stylist" in helpcontent pointing to
"Styles and Formatting" would be a good idea.
Comment 9 e.matthis 2005-01-25 16:31:48 UTC
Accepting issue.

Folks, I haven't read the discussion yet, so I need time for that. 
There were various reasons we saw the need to change the name of the Stylist.
But can say a few things off the top of my head.

The funny thing is, the window of the tool never was titled "Stylist", as the
window title changed according to whichever type of style had been selected
(Paragraph Styles, Character Styles, etc) so for many users the only way they
would have identified this tool as the "Stylist" would have been the tooltip
over the icon. That was one of the reasons we changed the non-standard behavior
of the window to now retain a stable title that could clearly identify the
window and be used in documentation. 

BTW, the OOoauthors documentation for OOo 2.0 is already written and refers to
"Styles and Formatting window" (e.g see
http://oooauthors.org/groups/authors/userguide2/commonfeatures/draft_pub/Styles_GS_V2.sxw/download)
, likewise the online Help provided by Sun has already been written with "Styles
and Formatting" and translated into the 10+ languages that Sun pays for.

We by no means wanted to upset present users of OOo and StarOffice, but we
discovered that most users (perhaps, less saavy users than those who are fully
immersed in the OOo project and especially the marketing thereof) did not know
what the Stylist did and if they ever did finally understand it, it had taken
sometimes months for them to reach that point. 

As you all agree, the styles functionality is better than in Microsoft Office
and should continue to be marketed as such. There is no reason why the community
has to stop calling it the "Stylist" in colloquial speech. The entry "Stylist"
will still be in the online Help so users can find it easily. 

More later...
Comment 10 e.matthis 2005-01-28 18:43:42 UTC
At present, I think this is a cultural issue and must be decided for each
language. I've heard that someone is going to contact SO marketing, so that
should be interesting, but from what I can tell so far, the localizations should
make their own choice. 

It is not uncommon that the translation into a target language differs from the
source language. In Italian, "Stylist" was kept, for example, without any fuss
at all. It may be wise to introduce "Stylist" back into the German version
(after all it was invented by a German in the first place), but as far as I can
tell from the various messages on several mailing lists, the English speakers
prefer Styles and Formatting because it is clear and finally means something,
whereas several people were confused or put off by the "hairdresser" term
"stylist". Marketing is definitely cultural to an extent. Not everything can be
universally applied.

I also feel that if the voting were to be more meaningful, it would be by
language. My initial impression is that German and French are the groups that
want Stylist name back. That is not reason for me to change the English because
those are completely different markets/audiences.

Holding the issue to see what happens next...  
Comment 11 peschtra 2005-01-30 07:22:17 UTC
TO address a few points:

1) Very sad that we are changing something else just to be like "everyone else."
These changes are made because people are confused. Rather than pander to these
people, we don't we EDUCATE THEM and make the computer world better.

2) I am tired of whoever is in charge of this thing not given a rat's patoot
about the current OOo users. We matter to. We have helped build this thing and
spread the word. If we are alinated, this new bread of easily confused users
will not be very helpful. Give the dedicated loyal users from kind of respect.
We are told this is a "community", but it is becoming less of one.

3) Why was the change made? I still haven't seen a reason. Saying it is okay
becayse the OOoAuthors have finished a doc is not a reason. They wouldn't have
had to change the doc from Stylist to Styles & Formatting if OOo hadn't changed.  

4) Finally, why it should be kept. As it has been explained, this is a unique
feature of OOo. There is a list of styles (a Stylist if you will) from which one
of many defined styles can be selected and changed. It is not a place where one
changes the Formatting of something, it is a place where picks a styles. The
formatting menu is where you pick the font or other attributes of one selection
of text. There is a difference.
Comment 12 e.matthis 2005-02-01 10:03:21 UTC
Hi Peter,
I responded to you in the thread  "Stylist = Styles & Formatting" on the
ooo.discuss list Jan 31, so I am not going to respond again here.

Hi All,
Please also read my posting to the discuss list Jan 31. If you can read German,
please also feel free to read my message to the de.dev list Jan 31.

Summary for this issue:
"Styles and Formatting" is and will remain the English name for the window
formerly known as "Stylist". As I coordinate both English and German UI
terminology, I will work with the ooo.de community to find conscensus on the
German name. That discussion has begun on the German mailing list where it
belongs. (not in this issue)

As I am not responsible for any other localizations, they are not my concern.
This issue is incorrectly logged by a French speaker regarding an English term.
(Each localization is separately responsible for its own terminology except when
legal issues are concerned, e.g. registered product names) 

Setting this issue on the English term "Styles and Formatting" to "Works for me".
Comment 13 e.matthis 2005-05-23 14:41:32 UTC
closing