Issue 41264

Summary: unnecessary reformatting when dragging rows
Product: Writer Reporter: richlv <richlv>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P4 CC: issues
Version: 680m71   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description richlv 2005-01-25 10:22:03 UTC
create a new writer document. insert a table with one column and 4 rows.
format all cells to 'number'. input "1" in 2nd row, "2" in 3rd and "3" in 4th.
save the document, close it, reopen.

select 3 cells with contents, drag them one row higher (only "1" is preserved, 
issue 41173).

undo. click anywhere outside the table.

document now is marked as edited (though the only change is undone) 
and undo history has an item "format cell". last cell (row 4) is formatted 
incorrectly (as text, not as number)

undoing this "format cell" seems to do nothing (at least visible). document 
still is marked as edited.
now _redo_ menu has an item "format cell". after re-doing, last cell is 
formatted correctly (as number). document still is marked as dited, though.
and now _undo_ menu has an item "format cell". undoing this again seems to do 
nothing and finally the document is marked as unedited.

it seems that before moving cell contents oo.org unneccessarry has twice 
reformatted cell. undoing/redoing these actions also is pretty awkward 
(theirsequence and results seem incorrect).
Comment 1 michael.ruess 2005-01-26 16:05:38 UTC
MRU->ES: an Undo/Redo problem.
Comment 2 eric.savary 2005-03-11 02:05:32 UTC
fixed as described in m84.
But follow the description and do the Drag&Drop
Then undo.
You will notice that the wrong format is applied (numbers that where lef aligned
are now right alligned)

Feel free to change the target ;)
Comment 3 eric.savary 2005-05-19 11:55:36 UTC
correct target set.
Comment 4 andreas.martens 2005-05-25 10:14:57 UTC
Considering the effort, the priority, the risk and our resource planning I've to
retarget this issue to OOo Later.
Comment 5 Marcus 2017-05-20 11:24:23 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 6 Marcus 2017-05-20 11:25:46 UTC
Reset assigne to the default "issues@openoffice.apache.org".