Issue 41457

Summary: User Interface Enhancement for Case Options
Product: Writer Reporter: mkol <m_kolman2>
Component: uiAssignee: requirements <requirements>
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description mkol 2005-01-27 13:11:25 UTC
OOo 1.1 writer contains many options for changing character cases. These 
options are scattered at different places and are in varying forms. e.g. 

(1)
Format -> Case/Character -> Uppercase
Format -> Case/Character -> Lowercase
For Non Asia Languages like English only these 2 are selectable. It gives 
false impression to the New users that writer has only these 2 case options.

(2)
Format -> Character -> Font Effects -> Effects -> Capitals (A Redundant Entry)
Format -> Character -> Font Effects -> Effects -> Lowercase (A Redundant Entry)
Format -> Character -> Font Effects -> Effects -> Title
Format -> Character -> Font Effects -> Effects -> Small Capitals

Will Not user interface be more consistent and clear if all these option are 
put together, Redundant Entries are removed and some more case options are 
provided. e.g.

...............................................................................
Format -> Case/Character -> Without (To remove other case options)
Format -> Case/Character -> UPPERCASE (Menu option also written in uppercase)
Format -> Case/Character -> lowercase (Menu option also written in lowercase)
Format -> Case/Character -> Title case ( Menu option also written in title 
case)
Format -> Case/Character -> Small Capitals ( Menu option also written in small 
capitals)
Format -> Case/Character -> Sentence case (New feature, First character of 
sentence capital, rest characters small, Menu option also written in sentence 
case)
Format -> Case/Character -> tOGGLE cASE (New feature, Aaa Bbb -> aAA bBB, Menu 
option also written in toggle case)
...............................................................................
Format -> Case/Character -> Other Options for Asian Languages etc.
...............................................................................
Comment 1 michael.ruess 2005-01-27 13:48:29 UTC
Reassigned to requirements.
Comment 2 mkol 2005-02-03 02:36:37 UTC
Please also have a look at the closely related issue number 41938  (URL is 
http://www.openoffice.org/issues/show_bug.cgi?id=41938  )

Comment 3 mkol 2005-03-20 22:27:17 UTC
Case formatting should be available in *All* components of OOo and not only in 
word processor just like Bold, Italic, Underline etc.

If users will type text, then they will also want to case format it.
Comment 4 ace_dent 2006-01-30 22:18:49 UTC
Thank you 'mkol' for such a thorough analysis of this feature, however, this is
a duplicate of Issue 1601. I will transfer your comments to #1601 on your
behalf, as I think they will assist the discussion. The other issue you raised
{Issue 41938), which discusses non-persistent case formatting is also very
useful. I will add a reference to this in #1601. I hope that's ok with you.

As a possible workaround, I copy this from 'lars', Issue 60702:
"...sentence case is achievable via a macro: Tools->Macros->Run Macro-
>OpenOffice.org Macros->Capitalise"

Regards,
Andrew

*** This issue has been marked as a duplicate of 1601 ***
Comment 5 ace_dent 2006-03-16 09:01:48 UTC
Closing.