Issue 41688

Summary: Quattro Pro 6.0 import filter
Product: Calc Reporter: mmeeks <mmeeks>
Component: codeAssignee: oc
Status: CLOSED FIXED QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues, jody, oo, ooo, sshilpa, stp
Version: 680m74   
Target Milestone: ---   
Hardware: All   
OS: All   
URL: http://specs.openoffice.org/calc/filters/qpro/qpro6.sxw
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
A sample quattro pro file that tests formulas.
none
Specification for QPro 6.0 filter work
none
much more comprehensive formula test - cf. all sheets ...
none
Testdocument for various font types
none
sample test document
none
fixes
none
fixed font file
none
QPro6 format Testdoc none

Description mmeeks 2005-01-31 09:46:45 UTC
Check-in Shilpas Quattro Pro 6.0 import filter.

Suitable test (.wb2) files can be found here:

http://go-oo.org/ooo-build/test/qpro/

Specification posted to the specs list etc.
Comment 1 mmeeks 2005-02-01 12:06:04 UTC
Committed; Eike could you have a read of the changes ? we also need a suitable
QA person to assign it to in EIS when you're happy.
I've committed this to the new CWS: 'qpro02' since I managed to screw up qpro01.
Comment 2 ooo 2005-02-07 17:02:21 UTC
Michael,

You mentioned
> Specification posted to the specs list etc.
but there is no specification available. Specs also don't go to any list, but
instead an "iTeam" is formed (at least a developer, one member of user
experience, a QA representative, and a member of the documentation team) who
have to agree on a spec, and the spec is to be checked in to the CVS  of
specs.openoffice.org, in this case specs/www/calc/...

Eike
Comment 3 sshilpa 2005-05-16 09:53:25 UTC
Created attachment 26191 [details]
A sample quattro pro file that tests formulas.
Comment 4 frank 2005-06-07 11:13:11 UTC
*** Issue 48585 has been marked as a duplicate of this issue. ***
Comment 5 sshilpa 2005-06-09 08:44:55 UTC
Created attachment 27037 [details]
Specification for QPro 6.0 filter work
Comment 6 frank 2005-06-09 11:09:58 UTC
*** Issue 48585 has been marked as a duplicate of this issue. ***
Comment 8 mmeeks 2005-06-13 12:11:38 UTC
Created attachment 27128 [details]
much more comprehensive formula test - cf. all sheets ...
Comment 9 mmeeks 2005-07-28 10:29:03 UTC
Eike - over to you - who are we blocking on here ?
Comment 10 ooo 2005-07-29 18:23:15 UTC
Aligning target to CWS qpro03.
Comment 11 ooo 2005-09-02 13:07:28 UTC
Hi Shilpa,

Sigh.. I already thought we were through with this and wanted to set the CWS to
ready-for-QA, but I just tried the formulat.wb2 attachment in a non-product
version of the CWS I resynced to m126 yesterday. It throws a zillion
debug-output assertions about undefined TokenPool states. Please fix that.

Btw, you seem to have two OOo accounts, sshilpa and shilpas, which one to use?

Thanks
  Eike
Comment 12 sshilpa 2005-09-05 05:24:24 UTC
I will look at the issue that u have mentioned. My account that i use is shilpas. 
Comment 13 sshilpa 2005-10-06 09:03:18 UTC
Created attachment 30167 [details]
Testdocument for various font types
Comment 14 sshilpa 2005-10-06 09:04:07 UTC
Created attachment 30168 [details]
sample test document
Comment 15 ooo 2005-10-12 15:51:53 UTC
Hi Shilpa,

Please use appropriate mime types, *.wb2 are not of type
application/vnd.sun.xml.calc. If nothing fits or there is no proper mime
type for the file format, use application/octet-stream for binary files.

In the current implementation present in CWS qpro03, the FON.WB2 looks
almost good. Almost, because cells C7:C12 are not bold as they claim to
be, and G4 is bold italic instead of bold underlined, G11 and G12 are
bold italic underlined and not bold underlined like the rest of the
column, though the content says bold italic instead, which may be
a copy&paste error.

In complex.wb2, almost all cells are italic underlined, except a few
where it seems other attributes are set. The font sizes are not
imported, should they? The spec doesn't mention it.

After having again applied the latest patch you sent by mail, the
results of FON.WB2 did not change, but complex.wb2 now displays all
cells that previously were italic underlined as bold italic underlined.
This seems to be an error. I assume that those cells should not have
a font attribution at all instead.

Please consider the unitialized array memory of ScQProStyle I mentioned
in my reply mail together with how the font style indices are used for
a possible cause of the error.

Please submit a working fix (cvs diff -u -r cws_src680_qpro03) until
Monday next week, otherwise we may have to postpone the CWS to OOo2.0.2

Thanks
  Eike
Comment 16 mmeeks 2005-10-14 16:16:50 UTC
So - this is *embarassingly* bad; sorry for the unnecessary pain Eike.

* Your comments on formatting are all correct - þe FON.WB2 is badly constructed
& inaccurate. The good news is though that it renders the same with OO.o &
Win32. I attach a fixed font2.wb2 file that should do better (at least for the
bits you pointed out).

* Shilpa didn't understand about initializing members; I've fixed that.

* I added the font height import in passing too.

Sorry for the pain.
Comment 17 mmeeks 2005-10-14 16:17:33 UTC
Created attachment 30440 [details]
fixes
Comment 18 mmeeks 2005-10-14 16:19:58 UTC
Created attachment 30441 [details]
fixed font file
Comment 19 oc 2005-11-04 11:56:10 UTC
spec-link added
Comment 20 oc 2005-11-04 12:55:35 UTC
Filter is not registered in MIME, and task is in wrong status (not fixed)
Comment 21 ooo 2005-11-07 14:20:39 UTC
As already clarified internally, this is a misunderstanding. It is not necessary
to have a distinct MIME type assigned. Furthermore, there is no MIME type
registered with IANA, see
http://www.iana.org/assignments/media-types/application/, only some types used
in the wild, for examples see http://filext.com/detaillist.php?extdetail=WB2
Comment 22 ooo 2005-11-07 14:37:04 UTC
Reassigning to QA again.

re-open issue and reassign to oc@openoffice.org
Comment 23 ooo 2005-11-07 14:39:11 UTC
reassign to oc@openoffice.org
Comment 24 ooo 2005-11-07 14:41:57 UTC
reset resolution to FIXED
Comment 25 frank 2006-01-24 13:13:49 UTC
Created attachment 33521 [details]
QPro6 format Testdoc
Comment 26 frank 2006-01-24 13:15:14 UTC
Sorry to tell you but this Issue isn't fixed from my point of view.

Comment 27 mmeeks 2006-01-24 13:42:29 UTC
fst: interesting - when I load your test sheet I get a dialog saying:

Title: Quattro Pro
Text: ! "Unknown records encountered. This file may be created by the new
release of QPW.: Z:\AOUPEC~0.WB2 {FileOpen}"

Are you sure you're only using the formulae & functions available in QPro 6.0 ?
;-> re-marking FIXED => back to QA.
Comment 28 mmeeks 2006-01-24 14:05:58 UTC
So - checkout:
  http://go-oo.org/~michael/qpro.png
  http://go-oo.org/~michael/oopro.png

Ultimately - I'm not too interested in completeness here - what is there is
useful & usable. Lets cut the spec. down to list only the functions that work &
calculate the expected result here - and leave the rest as an added bonus.
Comment 29 frank 2006-01-27 13:15:32 UTC
verified on cws qpro03
Comment 30 frank 2006-01-27 14:09:09 UTC
changed target
Comment 31 frank 2006-01-27 14:51:19 UTC
changed Issue type to FEATURE on request
Comment 32 oc 2006-02-10 14:46:13 UTC
closed because feature available in OOo2.02m156