Issue 42078

Summary: Cannot open in Spreadsheet html document named .xls
Product: Calc Reporter: acidumirae <acidumirae>
Component: viewingAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description acidumirae 2005-02-04 16:41:15 UTC
Missing feature:

In OO 1.1.4 you can open html document named file_whatever.xls in
spreadsheet and work with it as a spread sheet if it has tables inside

Now in Office 2.0 it is always opening Writer/Web :(
Even when you try to open file from spreadsheet.
Comment 1 frank 2005-02-11 12:02:51 UTC
Hi,

the problem is just that all versions prior to 1.9.x are falsly opening such
documents in Calc. The type detection trys to open the file as Excel but there
is no Excel code but HTML. So the document is opened in writer/web as this is
the application used to work on such documents.

To get such documents opened in Calc you have to choose the filter type HTML.

Nevertheless I set this one double to Issue 8967 as it deals with the type
detection as well.

Frank

*** This issue has been marked as a duplicate of 8967 ***
Comment 2 frank 2005-02-11 12:03:07 UTC
closed double