Issue 42711

Summary: Form created with wizard, doesn't keep data source when saved
Product: Base Reporter: justinclift <jclift>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: 680m77   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description justinclift 2005-02-14 09:23:27 UTC
Hi,

In OOo2 Base (680m77) after I've created a new form with the Wizard, if I do a
File -> Save Copy as, then close the document and open the saved one, it's no
longer linked to the data source.

I then have to go into the Database Design/Edit mode, right click a form
element, select Form, choose the correct data source from the Data source drop
down, and then close that dialog.  If the document is saved now, it keep track
of things properly.

Seems like a bug, and that when the initial form is saved, it should also
correctly save the data source along with it.

Regards and best wishes,

Justin Clift
Comment 1 erzielin 2005-02-16 07:31:50 UTC
Confirmed the behavior here. Is the application behaving as intended?

Windows XP Pro SP2, hotfixes to 2/05
Java JRE 1.4.2_06
Build 680m77
Comment 2 Frank Schönheit 2005-02-16 10:09:53 UTC
confirming, grabbing, targeting

In fact it is a bug that the data source is not stored with the form. However,
changing this would require quite some effort (since the save could would need
to know whether it's saving into the DB doc, or into the file system), and given
that there's a workaround (yes, an ugly one), I think "OOo 2.0" could not be
justified.

Thanks for reporting, anyway :)
Comment 3 enpizafapw 2010-11-10 21:22:10 UTC
Created attachment 73671
Comment 4 Marcus 2017-05-20 10:47:51 UTC
Reset assigne to the default "issues@openoffice.apache.org".