Issue 4309

Summary: Editing of locked documents is possible
Product: General Reporter: osavill <osavill>
Component: uiAssignee: thorsten.martens
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P2 CC: issues
Version: 642   
Target Milestone: OOo 1.1 Beta   
Hardware: Other   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description osavill 2002-04-29 13:02:10 UTC
When somebody is editing a document in Word other people get read only access 
to it (usually a good give away is the existance of a "~" file in the same 
directory).

However this does not occur with OO. This can lead to all sorts of errors and 
confusion if anyone edits and saves a document with OO that is also currently 
being worked on by somebody else using Word !
Comment 1 stefan.baltzer 2002-04-29 16:20:46 UTC
Owen: I never heard about Word running on LINUX ;-)
Please light me up what system environment (Network, drive sharing)
you are talking about.
Comment 2 osavill 2002-04-29 17:00:10 UTC
Most people around here only use Window$. They run Word on Window$. I
am the only one who uses OO, even though there is a Window$ version
available :-(  We access all the company wide documents from a central
server PC (presumably running some version of Window$). When everybody
is using Word it is simple to control access. The first accessor gets
read / write access, everybody else just gets read access. However,
the fly in the oitment is me and OO :-) OO is quite happy to access
the document, change it and then write it out to disc ! When the
person editing the document in Word writes their copy all my changes
are then overwritten ! Currently I have to make very sure I look for
files starting with a "~" which usually means that Word (or possible
Window$ itself) is accessing the document. 

Apparently NTFS supports file locking at the OS level, so I assume
this a non Window$ NT / 2000 / XP OS problem ?
Comment 3 stefan.baltzer 2002-04-29 17:20:51 UTC
Thanx, I thought so.
Changed component to framework.
Comment 4 Joost Andrae 2002-04-29 17:43:48 UTC
Joost->Owen: please clearify where the documents are located (Windows
or Linux). Is SAMBA in use ? (In this case it might be an issue with
the SAMBA configuration). Another Hint: Please have a look at the
OpenOffice.org startupscript on your Linux box. There you could
activate two entries
export SAL_ENABLE_FILE_LOCKING=1
and
export STAR_PROFILE_LOCKING_DISABLED=1

If you activate them you need to make sure that a "lockd" is running
on your system (it's the daemon which processes file locking).
Comment 5 osavill 2002-04-30 10:26:14 UTC
The documents are indeed on a Window$ machine and are being navigated
to via SAMBA.

lockd is running.

I did what you suggested in your reply and I can no longer save the
document when Word has it open.  :-) 

But, I don't know this until I try to save the document  :-(

I would be nice to get an information panel about the locked status of
the file during the document loading process.
I would be even better to get notification when the document is no
longer locked and I may save it.

and ...

The dialog just says the "General input / output error" - it may be
better to add something about being locked, it gives a more
comfortable feeling to the user by indicating this is not a permenant
situation for this file !

Since OO does not hold a permanent lock on the file, unlike Word, the
only option if someone edits the document, while I have it open, is to
loose all my changes and do a File-->Refresh, or to loose the other
persons changes by simply saving my edits over theirs. You may have to
put a merge option in ! :-)

Moreover, if they have made their edits and saved the document AND
exited Word before I have saved my changes I will not even know that
someone else was editing the document and all their changes are now
lost !
Comment 6 stefan.baltzer 2002-12-16 13:51:58 UTC
Reassigned to Thorsten.
Comment 7 thorsten.martens 2003-01-06 12:13:14 UTC
The missing file-locking feature will be fully implemented in a
staroffice 6.1 (build 644 or higher) and a appropiate OpenOffice
version. A locked file can`t be opened in edit mode in such a version.
The user gets a message, which gives the chance to open a new
document, using the locked one as a template.
Comment 8 thorsten.martens 2003-01-14 11:29:03 UTC
*** Issue 6690 has been marked as a duplicate of this issue. ***
Comment 9 thorsten.martens 2003-02-13 14:34:18 UTC
Has already been fixed in an internal 644 build, which will become a
SO 6.1 and a OO 1.1 Beta.
Comment 10 thorsten.ziehm 2003-05-20 11:23:00 UTC
Verified in OOo 1.1 Beta2.
Comment 11 thorsten.ziehm 2003-05-20 11:25:14 UTC
closed ...