Issue 44307

Summary: incorrect table column dragging
Product: Writer Reporter: richlv <richlv>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: cno, issues
Version: OOo 2.0 Beta   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Description Flags
testcase none

Description richlv 2005-03-07 09:35:03 UTC
see attached testcase. try dragging the border between first and second column 
without first dragging the border between second and third column
Comment 1 richlv 2005-03-07 09:40:10 UTC
Created attachment 23439 [details]
Comment 2 michael.ruess 2005-03-08 13:17:20 UTC
I do not have a problem moving the border between first an second row in the
table. Tried on Windows and Linux. 
What does happen on your machine? will this try only give you the second border
to grab?
Comment 3 richlv 2005-03-08 13:23:14 UTC
yes, when i try to drag first border i always grab the second one.

hmm, strange. managed to test this on another machine - no such problem. what 
could be the cause and is there something i can test ?
Comment 4 michael.ruess 2005-03-08 14:36:52 UTC
Maybe it is because you run your Linux with a certain desktop theme, where the
cursor has smth. special?
Comment 5 richlv 2005-03-08 15:19:34 UTC
i'm running both machines with the same theme (widgets, cursors etc)

i also can't think of any configuration or software differences.

as soons as borders are close enough (it seems to be ~ 1cm at 100%zoom on 
104x768) clicking on left border always selects the right one
Comment 6 michael.ruess 2005-03-08 15:33:43 UTC
Hm, I am runnning out of ideas... maybe:

- the desktop environment (KDE, Gnome...)
- Xserver (graphics card)

I tried on two Linux systems running 1024x768 and 1280x1024 resolution.

If this is only reproducable on this only machine, we must close this issue;
does not look like a problem of OO.
Comment 7 eric.savary 2005-03-09 09:54:26 UTC
Well, er, I can reproduce it. MRU, do you have any idea who I could send it to?
Comment 8 michael.ruess 2005-03-09 10:16:18 UTC
MRU->ES: FME should be the correct DEV contact.
Comment 9 eric.savary 2005-03-09 10:25:46 UTC

->FME: if you need help to reproduce, just call...
Comment 10 michael.ruess 2005-06-01 08:05:14 UTC
*** Issue 50152 has been marked as a duplicate of this issue. ***
Comment 11 pbowers 2005-06-01 13:27:06 UTC
Issue 50152 introduced problem with *rows* as opposed to columns and reproduced
the problem on a windows XP machine.  Thus it's nothing specific to a particular
linux desktop assuming that the row- and column-problem are duplicates.
Comment 12 pbowers 2005-06-02 21:35:27 UTC
I installed the same version on a 2nd computer (also running windows XP -- this
time professional) and got the exact same behavior.  It seems to be not
absolutely consistent but nonetheless very easily reproduced.  

To reiterate from 50152 how to reproduce this:

Create a table in Oo Writer with 2 rows and 2 columns.
Attempt to make the bottom row larger by dragging the very bottom border of the
table down.  Instead of the bottom row being enlarged, the top row is enlarged.

The same thing happens if you have 3 rows except in this case it is the
2nd-to-last (actually same as above, but different description).
Comment 13 michael.ruess 2005-09-30 09:02:22 UTC
*** Issue 54629 has been marked as a duplicate of this issue. ***
Comment 14 michael.ruess 2007-03-01 07:41:45 UTC
*** Issue 74985 has been marked as a duplicate of this issue. ***
Comment 15 michael.ruess 2007-05-10 15:29:14 UTC
*** Issue 76643 has been marked as a duplicate of this issue. ***
Comment 16 cno 2007-05-11 12:44:16 UTC
I cannot reproduce the problem with Rich's document.
Nor can I reproduce the problem pbowers describes.

However, what I notice: dragging to change the row heigth, does not work when
the cursor is out of the table. Dragging to change the column width, is not
sensitive for this.
I've no idea if this is related; just mention it.
Comment 17 goldenband 2007-10-11 17:43:50 UTC
Is this bug the same as Issue 33810?
Comment 18 richlv 2007-10-12 09:32:56 UTC
it indeed seems to be similar to that issue, yes.

as for the problem itself, i could not reproduce it anymore with m231.
but given how not everybody was able to reproduce it, i'd like to know that 
everybody can not reproduce it anymore ;)
Comment 19 clespantleri 2010-11-10 16:17:10 UTC
Created attachment 73135