Issue 44857

Summary: Ctrl++ does not respond when assigned to Insert/Cells as a hotkey
Product: Calc Reporter: dkheng <dkheng>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: firefox_97, haxwell, issues, mail.info
Version: OOo 2.0 BetaKeywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description dkheng 2005-03-12 03:32:24 UTC
when using the open office 1.1.4, after assign the Ctrl++ key with "insert 
cell", it can be used to Insert Cell, Column and Row. But now can not assign 
in the version 2 beta.

Besides that, the Ctrl+- key can be used to delete the cell, Column and Row. 
But now when press the Ctrl+- the delete sheet dialog box appear automatically.
Comment 1 haxwell 2005-03-16 22:56:20 UTC
Confirmed.

In Calc, 

1. Go to Tools > Customize > Keyboard.
2. Under Category, choose Insert. Under Function choose Cells.
3. In the Shortcut Keys listbox, scroll till you see Ctrl++. Select it.
4. Click the Modify button. Click OK.

Clicking Ctrl++ does nothing. But if you look under the Insert menu, you see
that Insert > Cells has Ctrl++ assigned to it as a hotkey.

Using OOo 1.9.84 on Win 2000 SP4.
Comment 2 frank 2005-04-07 11:58:08 UTC
Hi Niklas,

is it your construction site ?

If not please re-assign to the correct developer.

Frank
Comment 3 christof.pintaske 2005-05-25 13:35:25 UTC
Retargeted to Office Later, due to lack of resources we have to concentrate on
the most relevant issues for the next micro update.
Comment 4 ds13 2006-01-17 19:36:06 UTC
He ho, I'm not alone!

I have the same problem as dkheng. Though I can't compare it to OOo 1.1, since I
didn't use it very intensely, I can confirm this behaviour for 2.0 and 2.0.1.

Beginning with 1.9.79, I think, I tried out OOo. Then, occasionally, Ctrl++
worked after configurating it. 
But in 2.0 and 2.0.1 I simply can't activate it.
I had done it exactly as haxwell described it: Customize -> Keyboard -> Insert
-> Cells (no matter if checking the radio button for "OpenOffice.org" or
"Calc"). No reaction!

Opposite to that, "Insert cells: down" and "Insert cells: right" *does* work -
but not the universal way as offered in the Insert-Menu, automatically
recognizing if to insert either a row or a column.
I find it quite disturbing, because for keyboard-users this will be one of the
most-used shortcuts.

I tried the German version of OOo 2.0 and 2.0.1 on Win2000 and WinXP.
Comment 5 ds13 2006-01-29 19:06:13 UTC
Hello,
as mentioned on January 17th, my German OOo 2.0.1 for Windows isn't customizable
for inserting cells as the "Cells..."-Command in the Insert-menu does: The
keyboard shortcuts I tried simply didn't work. (I used Ctrl++, but other
shortcuts didn't work either, e.g. Shift-F10.)

Now, I tried this with the English version and here amazingly, the problem does
*not* occur! So it seems to be a problem of the German localized version.
Where can this be handled? Would you please forward this issue to the right
recipient?

Thank you!
Comment 6 ds13 2006-02-28 22:07:25 UTC
Forget it, my mistake.

What doesn't work:
Insert -> Insert Cells ("Zellen einfügen" in the German version) 

What will work:
Insert -> Cells ("Zellen" in the German version)

Sorry.

It just would be fine if OOo-Calc would have Ctrl++ and Ctrl+- preconfigured
this way, as Excel behaves.
Comment 7 thefox97 2009-04-23 17:11:01 UTC
Ctrl-+ will only work with the numpad plus sign.  On the keyboard to get a plus 
you have to press Shift plus the equals key.  I think this keystroke would then be 
Ctrl-Shift-Equals, which is not the same as Ctrl-+.  I think ctrl-= or ctrl-+ 
should both work.  Or at least add ctrl-= as a possible shortcut.
Comment 8 Marcus 2017-05-20 11:13:13 UTC
Reset assigne to the default "issues@openoffice.apache.org".