Issue 4509

Summary: Regression line with prediction and split screen in the horizontal plane
Product: General Reporter: forficula <davidbissett>
Component: chartAssignee: bjoern.milcke
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P5 (lowest) CC: issues, matthias.mueller-prove
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: PC   
OS: Windows ME   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description forficula 2002-05-05 07:23:50 UTC
As far as I can see, it is not possible to extend the trend line to make 
predictions and the formula for the line and R squared values cannot be added.  
These would be nice enhancements.

Also, while it is possible to split the screen vertically, it does not appear 
possible to split it horizontally.  This would be a nice enhancement.  Thanks.
Comment 1 frank 2002-05-06 07:57:15 UTC
Hi Falko,

one more for you.

Frank
Comment 2 forficula 2002-10-28 22:09:54 UTC
This will need development by someone else as I cannot achieve this.  
I just made the suggestion.
Comment 3 frank 2002-10-29 08:28:51 UTC
Hi David,

this is an enhancement and therefore was assigned to Falko.

Please don't change such assignments.

Frank

Hi Falko,

again 1 4 u.

Frank
Comment 4 Unknown 2003-04-14 01:27:15 UTC
A polynomial regression (fit) is by far more useful to me than any of 
the present regression offerings.  This, and having the regression 
equation displayable on the chart are essential to making the OO 
spreadsheet a powerful tool for me and many of my fellow grads here.  
I was trying to get my project group to all use Star Office (since 
it's available on all the campus computers), so that i could more 
easily share my (OO) documents with them, but when it came time for 
data analysis and the regression feature was found wanting, they went 
back to M$.  I was hoping there would be improvements in the new beta, 
but since there's not, i hunted up this issue and am voting for it.




Note that this affects all versions, not just WinME, but it won't let 
me change it.






Some keywords for others searching for this:


Taylor data analysis polynomial fit
Comment 5 falko.tesch 2003-10-01 10:14:38 UTC
FT->BM: Can you please help me with this issue?
Comment 6 bjoern.milcke 2003-10-06 17:55:25 UTC
1. The regression curves are not painted from x_min to x_max of the
x-axis, but only from the smallest occuring x-value to the largest
one, thus no extrapolation is possible.  I think, it would be nice to
add a check-box that determines, if extrapolation is visible or not.
2a. Adding the formula is a quite complex thing.  It would require the
implementation of a full-featured formula-parser, and would also
require some thought on the GUI -- a text-field where you enter a
formula is maybe not what 'high-level' users of OOo expect.
2b. I am not too familiar with R^2 values, but aren't those calculated
values?  Do you want to show this value in the legend?
3. What exactly do you, David, mean by splitting horizontally? I
presume you mean, you can group your data into groups of different
y-value ranges by introducing a second y-axis, but there is no similar
approach for x-values, right?
Comment 7 bjoern.milcke 2003-10-08 16:28:45 UTC
I think it would make sense to think about a solution for 1. In my
point of view, 2a. is far too complex to implement. 2b and 3 need more
input.

On second thought, I suppose 2b means not adding the formula of a
regression, but adding the calculated regression parameters in the
legend.  This makes perfectly sense (and was also requested by other
users).  Maybe also R^2 values, but I think we should first check, if
this is needed by more people and what underlying formula should be
taken for calculation.
Comment 8 falko.tesch 2003-10-15 09:06:44 UTC
FT->MMP: Please see statement from Björn made already on this issue. I
think we may not need this in 2.0 but it is a good idea its successor.
Comment 9 matthias.mueller-prove 2003-10-20 16:40:00 UTC
for feature comission OOo 3
Comment 10 gt73 2004-05-25 09:12:15 UTC
Hi,

I'm a bioinformatic using Ooo Calc on Linux in my every day work. I really need
the equation R^2 when making charts with regression lines. Please do your best
to implement such a feature, thanks.

Comment 11 rhbrody 2004-05-31 14:47:04 UTC
Hi,

I am a physician tracking the lung function of asbestos workers over time to 
look for an abnormal rate of loss of function.  It is helpful to have the linear 
regression line plotted on the XY chart (as can currently be done), but what I 
really need is the numeric slope of the line displayed on the chart, to 
quantitate the rate of loss of function.  This apparently cannot be done in OOo 
1.1.1.
Comment 12 bettina.haberer 2004-11-29 17:56:50 UTC
Rassigned to Björn.
Comment 13 jumbo444 2005-03-18 16:44:19 UTC
I voted for the equation of regression curve be given with legend (R² would be a
bonus). I think that polynomial regression is an other important missing
feature. It will be long to wait till 3.0...
Comment 14 IngridvdM 2005-04-14 16:31:45 UTC
-The extrapolation of regression curves is addressed with Issue 5085.
-The display of regression curve parameters is targeted with Issue 7998.
-An additional polynomial regression type is targeted with Issue 20819
-I don't understand what is ment by splitting the screen.

As it is quite unpractical to handle container issues like this with multiple
requests I close this one as a duplicate in favor of the issues above which do
concentrate on a single problem each. Those issues already got a higher priority.

For the screen splitting issue please submit a new issue with more detailed
information. Thanks.


*** This issue has been marked as a duplicate of 5085 ***
Comment 15 IngridvdM 2005-04-14 16:32:53 UTC
closed as duplicate