Issue 45163

Summary: Bullet symbols on some systems not displayed in OpenSymbol font
Product: Installation Reporter: pefix <felixpeters>
Component: codeAssignee: stefan.baltzer
Status: CLOSED FIXED QA Contact: issues@installation <issues>
Severity: Trivial    
Priority: P2 CC: askoorb, hdu, issues, jclift, khirano, nospam, peschtra, ulf.stroehler
Version: OOo 2.0 BetaKeywords: oooqa
Target Milestone: OOo 2.0   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 59997    
Attachments:
Description Flags
OpenSymbol Font (V1.7.7)
none
OpenSymbol (V1.8)
none
A patch for fontforge to allow unicode encoded symbol fonts like OpenSymbol to work on Win32
none
A corrected version of the patch for fontforge
none
OpenSymbol font created by the patched version of fontforge
none
Good bullets
none
This is the good, new open symbol font
none
This is the old, bad open symbol font none

Description pefix 2005-03-16 10:27:31 UTC
When using the old function of typing <hyphen><space> Tesxt <return> the list is
being created, however, not depicted in the word processor.
Example:
"-" " "  "Hello World!" "<_|"
should be:
   - Hello World!
Current depiction:
     Hello World!
Comment 1 michael.ruess 2005-03-16 14:15:30 UTC
This problerm occurs on SOME Windows systems (not all). Also I have two Win
Systems, where this problem occurs.
Problem is, that some Bullets like the default bullet (from toolbar button) and
the "-" bullet (as described above), generated from Autoformat feature, will not
be displayed in the document view. Also the needed region in the special
character dialog (U+2013 - U+2030) diplays empty characters where some bullet
symbols should be.
Maybe the OpenSymbol font interferes with one or more fonts from other
Applications (like MS Office 200x).
We MUST solve this somehow in the future; means: someone must debug this (at
least on my machine), so that we can catch it.
Comment 2 justinclift 2005-03-16 14:38:42 UTC
Hi,

If this turns out to be a "incompatible with MS Office" (of some version), then
this is going to have bad ramifications for large rollouts, corporates, and
migrations.

I know it's probably a sleazy trick, but are we able to copy the
missing/overwritten characters to another position that doesn't get
over-written, then have OOo use those ones instead?  By default I mean?

Not sure if this would break backward and forwards compatibility, but it might
make things work sooner rather than later.

Regards and best wishes,

Justin Clift
Comment 3 peschtra 2005-03-16 16:32:52 UTC
Not sure why Issue 40717 was closes in favor of this, but I have included
several screen shots of my system not working on that issue, so if some are
needed, that is where they are.

I am also willing to be a test pigeon for this issue if one is needed as I am
one of the ones this affects.

Thanks.
Comment 4 hdu@apache.org 2005-03-17 13:16:46 UTC
HDU->IH: as seen in issue 40717 this is a problem with the OpenSymbol font. I
have no idea why the original issue was closed...
Comment 5 hdu@apache.org 2005-03-17 13:20:31 UTC
should have been IH instead of HI
Comment 6 peschtra 2005-03-17 23:49:08 UTC
I asked the same question.

This is copied from 40717, posted by mru:

"Because the general problem has been fixed and a remaining issue exists (which
does not occur everywhere). So to keep issue handling conveniant in a way, we
use a new issue for this."
Comment 7 nospam 2005-03-21 10:49:39 UTC
IH: I am searching for a solution on this problem! Does anyone have an idea? I
tried so many different things now. I am using fontforge as the font edit tool
and I have really no idea what is going wrong with this font and why it does not
work on some systems.
Comment 8 nospam 2005-03-22 09:45:52 UTC
Created attachment 24144 [details]
OpenSymbol Font (V1.7.7)
Comment 9 nospam 2005-03-22 09:46:11 UTC
IH: I have attached a new version of the font (1.7.7) to this issue. Could all
of you please test if this version is better than the current one?
Comment 10 hdu@apache.org 2005-03-22 10:15:15 UTC
The new OpenSymbol version doesn't work on the WinXP here in the charmap
application, sorry.

I also tried to make the opens.ttf work on XP by using even the latest CVS
version (20050318) of fontforge. Even the advice in the fontforge mailing list
thread "Font edited by FF won't load in Windows XP" didn't help either. Also
disassembling the font didn't show any problems to me yet...

HDU->US: This issue is in my opinion a showstopper for OOo 2.0...
Comment 11 nospam 2005-03-22 12:58:53 UTC
IH: I also think that this is a showstopper - but I will not say this too loud
because at this moment I have really no idea how to fix this ;-)
I also have some news: I was able to generate a font that work in charmap, but I
used fontlab to generate this test-font. I was very happy but then I saw that it
did not export the characters in the private use unicode area - so my problem is
to generate a font that works even in charmap on windows and also includes the
private use area. 
Comment 12 ulf.stroehler 2005-03-22 13:27:07 UTC
Anyway, if someone wants this issue to be fixed for final this should be made
public. Hence I'd plead to P1 or at least P2.

From what we know so far Opensymbol doesn't work at all but GlyphFallback hides
this lack of functionality.
Comment 13 nospam 2005-03-22 14:14:06 UTC
IH: I have set the target to OOo 2.0. I have attached a new version (1.8) - I
hope that this is a good one :-)
Comment 14 nospam 2005-03-22 14:15:22 UTC
Created attachment 24155 [details]
OpenSymbol (V1.8)
Comment 15 nospam 2005-03-22 14:24:04 UTC
IH: set to P2.
Comment 16 nospam 2005-03-22 14:26:18 UTC
IH: by the way: the "new" 1.8 Version is a version generated in fontographer -
it looks like all fontforge versions did not work correctly.  
Comment 17 ulf.stroehler 2005-03-22 14:27:25 UTC
> IH: I have set the target to OOo 2.0. I have attached a new version (1.8) - I
> hope that this is a good one :-)

Nope, I won't accept this procedure!!
I expect a FIXED and TESTED (on all affected platforms!) version and a CWS. I
will not rely on any "hope" anymore. If QA will get the slightest notion that
you again delivered untested code (a font in this case) you'll immediately get
that CWS back. High time also for your team to comply with common development
praxis in this house.
Comment 18 hdu@apache.org 2005-03-22 15:17:11 UTC
Created attachment 24165 [details]
A patch for fontforge to allow unicode encoded symbol fonts like OpenSymbol to work on Win32
Comment 19 hdu@apache.org 2005-03-22 15:33:46 UTC
I found out, what decides which version of the OpenSymbol font is accepted or
rejected on the Win32 platform: The "good" versions either had the "symbol flag"
or they had a version 0 of the OS/2 table in the font. Other versions of the
OS/2 table require more info about the code pages supported by the font. Since
OpenSymbol doesn't support any of the traditional code pages it just indicates
support for the symbol code page. The Win32 platforms doesn't expect a font
which only supports a symbol code page to be unicode encoded...

The workaround for this is to not claim any knowledge about supported codepages
when the font just supports unicode encoded symbols. This can be accomplished by
using a version 0 OS/2 table for the exported font.

Version 1.8 of the OpenSymbol font IH provided as attachment above works,
because this font just claims to support Latin-1 and Win32 happily accepts that.
On the other hand support for Latin-1 is non-existant in OpenSymbol, so there
may be some side-effects, e.g. not accessable symbols on a chinese Win98...
Comment 20 nospam 2005-03-22 15:42:05 UTC
IH->HDU: please attach a new version of OpenSymbol build with your patched
FontForge. I can not apply your patch to my fontforge at the moment because I
can not recompile fontforge on my OS X computer. I think the best solution is to
put a patched 1.7.6 opensymbol font that works even in charmap into the product.
If we do this we will not have any problems on WIN98 systems and we also do not
lose any fixes I did to the font in the last releases. 
Comment 21 hdu@apache.org 2005-03-22 16:00:57 UTC
*** Issue 45618 has been marked as a duplicate of this issue. ***
Comment 22 hdu@apache.org 2005-03-22 16:05:03 UTC
Created attachment 24168 [details]
A corrected version of the patch for fontforge
Comment 23 hdu@apache.org 2005-03-22 16:18:31 UTC
Created attachment 24170 [details]
OpenSymbol font created by the patched version of fontforge
Comment 24 tom 2005-03-23 09:01:56 UTC
TV: fixed in CWS opensymbol1
Comment 25 tom 2005-03-23 09:02:38 UTC
tv->us: please verify

re-open issue and reassign to us@openoffice.org
Comment 26 tom 2005-03-23 09:03:43 UTC
reassign to us@openoffice.org
Comment 27 tom 2005-03-23 09:03:58 UTC
reset resolution to FIXED
Comment 28 peschtra 2005-03-24 00:56:02 UTC
I downloaded and installed the file that was uploaded on Mar 22 at 8:18:00 and
installed it on my Win XP Computer running OOo 1.9.86 and I have success. I have
attached three screen shots. (Perhaps the third is unecessary, but it
illustrates the point.)

1) My current program, with a small bullet. (Is this the correct bullet?)
2) The new open symbol font in the Windows font viewer.
3) The old open symbol font in the Windows font viewer, for comparison.

Just tip. You can't uninstall the old OpenSymbol with the QS running. I don't
know if you have to have bother the 1.1.4 and the 1.9.86 QS closed, but when I
had them both running, the old open symbol font wouldn't go away.

Thanks for the hard work on figuring out this odd issue.
Comment 29 peschtra 2005-03-24 00:57:05 UTC
Created attachment 24224 [details]
Good bullets
Comment 30 peschtra 2005-03-24 00:57:29 UTC
Created attachment 24225 [details]
This is the good, new open symbol font
Comment 31 peschtra 2005-03-24 00:57:51 UTC
Created attachment 24226 [details]
This is the old, bad open symbol font
Comment 32 hdu@apache.org 2005-03-24 08:10:10 UTC
Thanks for the feedback.

Even the good screenshots show some oddities that need to be attacked later:
- the symbols look a little fuzzy on a Windows display because the font is not
"hinted" yet.
=> At least for some easy symbols like e.g. the minus or equal symbol this
should be done to make them distinguishable at small pixel sizes.
- the goodopensymbol.png shows that Wndows is still confused by this font:
Opensymbol contains none of the characters displayed in the font preview! The
reason seems to be that since the font doesn't provide any info about the
supported codepages Windows assumes that it supports ASCII.
=> we should add a matching sample text in the name table (NAME id=19)
Comment 33 nospam 2005-03-24 09:48:39 UTC
IH: I would also be very satisfied if I could add truetype hinting instructions
to the font. I tried it with some of the latest releases of fontforge but
unfortunately it seems like they are not saved when the truetype font is
generated. I think we should have a look in the fontforge source code what is
going on there. It would be very goog if we can create a hinted opensymbol for
later releases. 
Comment 34 hdu@apache.org 2005-03-24 11:52:27 UTC
HDU->IH: no worries, the remaining problems have a much lower priority than the
showstopper problem. I suggest to have some followup issues with a 2.x target.
Comment 35 michael.ruess 2005-03-29 08:15:55 UTC
*** Issue 45717 has been marked as a duplicate of this issue. ***
Comment 36 ulf.stroehler 2005-03-29 18:32:58 UTC
sorry to disappoint you guys.
Doesn't work for me on Win98 (W2k is fine though):

 * fontview.exe shows squares
 * bullets in Writer also displayed as squares
Comment 37 ulf.stroehler 2005-03-29 18:36:34 UTC
Fixed But Failed.
Reassigning.
Comment 38 ulf.stroehler 2005-03-30 17:58:05 UTC
Doesn't work on native CJK Win98 (tested chinese trad.) either.
Bullets in Writer displayed as squares. 
Comment 39 nospam 2005-04-04 12:56:06 UTC
IH: could anyone please test if the version 1.8 I attached to this issue works
on Win98? Unfortunately I have no Win98.
Comment 40 nospam 2005-04-06 09:00:59 UTC
IH: the problem of this bug is fixed and we should set up a new bug for the
Win98 problems.
Comment 41 nospam 2005-04-06 09:01:43 UTC
.

re-open issue and reassign to sba@openoffice.org
Comment 42 nospam 2005-04-06 09:01:48 UTC
reassign to sba@openoffice.org
Comment 43 nospam 2005-04-06 09:01:53 UTC
reset resolution to FIXED
Comment 44 stefan.baltzer 2005-04-08 10:34:48 UTC
SBA: Follow up issue (for Win98/SE/ME) is issue 47009.
Set to verified.
Comment 45 michael.ruess 2005-04-19 09:13:18 UTC
*** Issue 47699 has been marked as a duplicate of this issue. ***
Comment 46 stefan.baltzer 2005-04-19 11:10:09 UTC
SBA: OK in OOo 1.9.94. Closed.
Comment 47 michael.ruess 2005-05-09 07:22:42 UTC
*** Issue 48912 has been marked as a duplicate of this issue. ***
Comment 48 askoorb 2005-10-18 11:39:35 UTC
Not sure if this affects this issue, but Issue 9437 has been lounging around 
for some time now (Feb 03) with a similar problem.  Should it be closed as a 
duplicate?