Issue 4679

Summary: can't change CellStyles Properties (soft format) if a sheet is protected
Product: Calc Reporter: Oliver Brinzing <oliver.brinzing>
Component: uiAssignee: AOO issues mailing list <issues>
Status: REOPENED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: cnospam, henry_harris, issues, kpalagin, stefan.weigel
Version: OOo 3.1   
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
demo for issue 4679 none

Description Oliver Brinzing 2002-05-09 08:55:20 UTC
Hi,

I tried changing the "CellBackColor" property of "MyCellCstyle" in a calc
document using
soft format (only 2 of 5 sheets using this CellStyle, the others are protected).

But I can only change the property, if all 5 sheets are unprotected.

If I have to unprotect all sheets before doing this, it's easier to use hard
formating

Is it a bug or a feature ???

First noticed with S0 5.2.

regards 

Oliver
Comment 1 frank 2002-05-13 09:27:24 UTC
Hi Oliver,

I could not reproduce this Issue. Please attach a file that shows such
problems.

Best regards

Frank
Comment 2 Oliver Brinzing 2002-05-13 11:17:17 UTC
Created attachment 1622 [details]
demo for issue 4679
Comment 3 frank 2002-05-13 11:33:59 UTC
Hi Niklas,

this one seems to be yours.

You can create a new cell style and assign it to cells on the
unprotected cells. Modifying this style is also impossible.

Frank
Comment 4 niklas.nebel 2003-01-15 16:16:02 UTC
It's a feature. As soon as any sheet is protected, all cell styles are
considered protected, too.
Comment 5 michael.bemmer 2003-03-11 18:09:12 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 6 michael.bemmer 2003-03-11 18:16:59 UTC
As mentioned on the qa dev list on March 5th I will close all resolved
<wontfix/duplicate/worksforme/invalid> issues. Please see this posting for details. 
Comment 7 frank 2004-09-29 10:45:09 UTC
*** Issue 34767 has been marked as a duplicate of this issue. ***
Comment 8 lolomic 2004-09-29 11:04:51 UTC
From issuer of 34767 :

It is reasonnable to protect style that are used on the protected sheet. This is 
obvious.

However, when a style is NOT used on the protected sheet, it could also be 
reasonnable to make it editable. Or at least warn the user that the "Edit" is 
not possible since there is at least one protected sheet.

I suspect that a less "skilled" user may get mad in finding out why its style is 
not editable.

But this is only my point of view.

Have a nice day.
Comment 9 frank 2005-03-07 14:14:01 UTC
*** Issue 43954 has been marked as a duplicate of this issue. ***
Comment 10 frank 2005-03-23 09:59:51 UTC
*** Issue 43819 has been marked as a duplicate of this issue. ***
Comment 11 kpalagin 2007-02-15 11:27:23 UTC
Due to user's request in http://www.openoffice.org/issues/show_bug.cgi?
id=74565 I will allow myself to reopen the issue.
Comment 12 kpalagin 2007-02-15 11:30:16 UTC
*** Issue 74565 has been marked as a duplicate of this issue. ***
Comment 13 frank 2007-07-30 19:55:39 UTC
*** Issue 80186 has been marked as a duplicate of this issue. ***
Comment 14 deaconctk 2007-07-31 03:35:19 UTC
It would be nice to treat styles differently based on whether they are used in a
protected sheet, but that would be quite challenging.  On the other hand, the
current behavior--acting like it's going to do something with nothing actually
happening--is not a very satisfactory approach.  (Note that attempting to delete
an unused style even gives you a confirmation dialog before doing nothing.)

I suggest as a bare minimum that an error dialog be displayed indicating that
the modify and delete features are disabled because one or more sheets is
protected.  This ought to be a fairly straight-forward change since the logic is
evidently already in place to determine whether a sheet is protected--all that
should be needed is adding the dialog.
Comment 15 Oliver Brinzing 2009-05-19 06:18:14 UTC
issue still open for 7 years now - please close it if it will not be fixed

at least there should be an error box if one tries to change/remove a
style in case a sheet is protected - or the two context menu entries
should be disabled...
Comment 16 niklas.nebel 2009-10-14 17:04:18 UTC
adjusting target
Comment 17 Oliver Brinzing 2015-02-24 18:47:26 UTC
*** Issue 126124 has been marked as a duplicate of this issue. ***
Comment 18 Marcus 2017-05-20 10:44:49 UTC
Reset the assignee to the default "issues@openoffice.apache.org".