Issue 47212

Summary: redraw of screen during dragging scrollbar
Product: Calc Reporter: sandreas41 <sandreas41>
Component: viewingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0 Beta   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
example for showing bug
none
3 screenshots pasted together to show the bug does happen
none
and a simpler motion gif to show difference between up and down none

Description sandreas41 2005-04-12 04:32:00 UTC
When in spreadsheet v1.9.91
open or create a sheet with content to fill the screen. (so there is more than a
simple grid to see)
move mouse over scrollbar on the right side, and drag it up or down.
The yellow help Row# will pop up over the sheet, but the contents behind it will
not be redrawn correctly as the sheet moves up and down.
Comment 1 frank 2005-04-19 14:47:35 UTC
could not reproduce using internal m94 build.

Closing worksforme.

Frank
Comment 2 frank 2005-04-19 14:47:50 UTC
closed wfm
Comment 3 sandreas41 2005-07-13 00:58:53 UTC
Ok, so it doesn't do it all the time, but this bug does seem to require the
background fill to be something other than white.

Worse yet, just changing a few cells to other colors, isn't consistantly showing
the bug.
It seems to be affected more-so when the spreadsheet gets more complex.
I'll upload an example.
Stewart
Comment 4 sandreas41 2005-07-13 01:00:54 UTC
Created attachment 27865 [details]
example for showing bug
Comment 5 sandreas41 2005-07-13 01:09:07 UTC
For maximum visual distortion,
get ( column Q <OR> around column AL ) to be just left of the vertical
scrollbar, then drag the scrollbar up and down.

In this spreadsheet, even the black font on white background cells are affected.
Comment 6 frank 2005-08-03 11:44:38 UTC
Hi,

checked it with various versions and also the latest m122 and could not reproduce.

So closing worksforme.

Frank
Comment 7 frank 2005-08-03 11:44:57 UTC
closed wfm
Comment 8 sandreas41 2007-07-10 01:10:20 UTC
Still seeing this in OOo_2.2.1rc2_20070519_LinuxIntel_install_en-US.tar.gz

Are you sure you can't reproduce it?

Could it be specific to a graphics card?

/etc/X11/xorg.conf
Section "Device"
        Option "SWCursor" "false"
        Option "HWCursor" "true"
        Option "NoLogo" "0"
        Option "NoFlip" "1"
    Identifier     "NVIDIA GeForce4 MX440 DVI"
    Driver         "nvidia"
EndSection

nvidia driver version 8762 in X-Org-7

I tried changing the NoFlip recently, to see if it would fix a bug in a
different software program (blender), drawing the screen, but it did not in my case.
Comment 9 sandreas41 2007-07-10 01:12:47 UTC
Created attachment 46663 [details]
3 screenshots pasted together to show the bug does happen
Comment 10 sandreas41 2007-07-10 01:27:00 UTC
Created attachment 46664 [details]
and a simpler motion gif to show difference between up and down
Comment 11 frank 2007-07-31 14:41:26 UTC
Hi Niklas,

repaint errors occur on my VM Linux machine using 2.2.1 and master m222. Cause
seems to be the tip box for the row.

Frank
Comment 12 Marcus 2017-05-20 11:13:37 UTC
Reset assigne to the default "issues@openoffice.apache.org".