Issue 47377

Summary: Crash on Crash Report.
Product: General Reporter: hwoarang <yoshimit>
Component: codeAssignee: Joost Andrae <Joost.Andrae>
Status: CLOSED DUPLICATE QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description hwoarang 2005-04-13 16:01:54 UTC
Hi. I dont know the exactly component to use.. but you know...

Everytime that OOo call crash report here I receive, before, a fatal error with
this information:

=================================================
CRASHREP causou uma falha de página inválida no
módulo KERNEL32.DLL em 01ef:bff7b992.
Registros:
EAX=00000020 CS=01ef EIP=bff7b992 EFLGS=00010202
EBX=00000000 SS=01f7 ESP=0067e950 EBP=0067e98c
ECX=7c38b4e8 DS=01f7 ESI=00000020 FS=370f
EDX=006950d9 ES=01f7 EDI=7c36bb92 GS=0000
Bytes em CS:EIP:
80 3e 04 74 0f 33 c0 50 50 50 68 05 00 00 c0 e8 
Esvaziamento da pilha:
7c34f744 7c34f639 00000020 7c36bba6 00000000 7c36bb92 7c34f744 00000000 00000000
0067e964 0067e780 0067fb48 7c34240d 7c3821f8 ffffffff 0067fb54 
=================================================

so I close this warning and a popup of OpenOffice.org Document Recovery appears.
I click on Ok button and the c++ error appers:

=================================================
Microsoft Visual C++ Runtime Library

Runtime Error!

Program: C:\ARQUIVOS DE PROGRAMAS\OPENOFFICE2\PROGRAM\SOFFICE.BIN

R6025
-pure virtual funcional call
=================================================

I click on Ok.
and another fatal error appers with this:

=================================================
SOFFICE causou uma falha de página inválida no
módulo KERNEL32.DLL em 01ef:bff9dfff.
Registros:
EAX=0238fe38 CS=01ef EIP=bff9dfff EFLGS=00000206
EBX=819eec4c SS=01f7 ESP=0238fc88 EBP=0238fe38
ECX=000001f7 DS=01f7 ESI=819eec4c FS=3d2f
EDX=0238fe28 ES=01f7 EDI=10a00200 GS=0000
Bytes em CS:EIP:
cc a1 e0 9c fc bf 8b 00 66 64 f7 05 1c 00 00 00 
Esvaziamento da pilha:
62080000 819eec90 819d2d6c 8195caa0 00003484 d48f95f0 00000001 625879d1 62605a7c
00000001 62597be1 00000018 0238fcc8 62605a30 0238fcd0 0238fce0 
=================================================

after this, the OOo restart, the OpenOffice.org Document Recovery popup appers
again, I hit Start Recovery > Next > Next 

the Sending the Error Report popup appear.
I hit Send and another fatal error comes...

Dont know if it matters but I think I should report.

Thank you

Hwoarang

Ooo m91 + pt_br language pack
Windows98SE
Comment 1 Joost Andrae 2005-04-13 16:16:21 UTC
JA: this is a duplicate

*** This issue has been marked as a duplicate of 46856 ***
Comment 2 Joost Andrae 2005-04-13 16:16:44 UTC
JA: closing duplicate
Comment 3 hwoarang 2005-12-08 11:15:03 UTC
After talked to Andreas, I'm reopening this issue for more investigation, as is
not a duplicated of #46856 and I can reproduce with OOo 2.0.1rc2.
Comment 4 stephan.wunderlich 2005-12-08 12:03:18 UTC
sw->hwoarang: Can you please provide a step by step description, so I can see
what you do to make it possible to reproduce the problem.
Comment 5 hwoarang 2005-12-08 18:34:09 UTC
HWOARANG -> SW:

In my case every crash results in no stacktrace to send...

Today I made a CLEAN install (OOo 2.0.1rc3)
I deleted my %PROGRAM_FILES%\OpenOffice2 folder and my
%WINDOWS%\profiles\<user>\Application Data\Openoffice2... I mean, everything
related to OpenOffice that I could find

The steps that make OOo crash here:
(the same that I use to duplicate another bug #51116)

==========================================
1) Connect with your MySQL database (F4 and then 'Edit Database file...')
2) Forms > Use Wizard to Create Form...
3) Make sure that you choose a table with 'date/time' fields...
4) Click on '>>'
5) Next
6) Next (Set up a subform)
7) Select the first option of arrangement (Columnar - labels on left)
8) Finish (twice, the first one will results nothing here)

The OOo will close.
(In my case I used ODBC connector version 3.51.12)
==========================================

After that, I restart OOo and the AutoRecovery appears.
I choose to recovery all documents and everything goes fine.
Then I click Next, Next and the CrashReporter Tool appears.
I click on 'Show Report' and I can't see nothing there.
I click on 'Send' and I got a windows's fatal error (against kernel32.dll)

That's it.
This same behavior happens in my home (another pc and another OS - WinXP SP2)

Thank you.

Hwoarang
Comment 6 stephan.wunderlich 2005-12-09 10:16:03 UTC
sw->msc: the key seems to be the date/time-field ... when a table contains this
the office crashes on creating a form ... since you already take care of the
mentioned issue 51116 I send this to you too
Comment 7 hwoarang 2005-12-09 10:39:04 UTC
Hwoarang -> SW:

I think your comment is for #51116, right?
Did you reproduced the this issue? (no stacktrace to send? - I hope so)

Just to clarify: I cant get any stacktrace to send in ALL crash that I got,
#51116 is just a example.

Thank you.

Hwoarang
Comment 8 marc.neumann 2005-12-09 10:55:13 UTC
hi,

as you test the crashreporter, this is something for you.

bye Marc
Comment 9 hwoarang 2006-01-19 14:16:50 UTC
Today I tried to remove 
\windows\profiles\[username]\Application Data\[OOo dir]

do not help.
I still unable to send crash data to OOo site.

Hwoarang
Comment 10 hwoarang 2006-01-19 15:01:43 UTC
as issue 49284 as more comments and more CC added, I will close this one as double.

btw, it still reproducible with OOo-dev m150 Win98SE.

Thank you

Hwoarang

*** This issue has been marked as a duplicate of 49284 ***
Comment 11 hwoarang 2006-01-19 15:02:00 UTC
closing