Issue 48509

Summary: default language information lost while Copy & Paste
Product: General Reporter: andreschnabel <andre.schnabel>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, ooo, stefan.baltzer
Version: 680m95Keywords: oooqa
Target Milestone: AOO Later   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Description Flags
Screenshot of missing language info
same with m122 on Linux none

Description andreschnabel 2005-05-01 10:00:24 UTC
The charcter format attribute "language" gets lost under certain condidtions
while copy 'n' paste between different OOo Applications.

Try following to reproduce:
- open a new writer document and type some text
- check language setting for this text (leave the default language)
- copy your text (ctrl-c)

- open a new calc document
- enter any cell (press f2)
- paste your text (ctrl-v)
- check language setting of the cell

-> Language attribute is empty

Same behaviour, if you paste the text to a draw textbox or impress text area
This has been tested with m95 + german language pack WinXP and happens, if
default language is not changed for the copied text (no matter, if this is
GErman or English)
Comment 1 thorsten.martens 2005-07-06 10:22:35 UTC
TM->SBA: Problem with the internal clipboard ? Please have a look.
Comment 2 thorsten.martens 2005-07-06 10:35:02 UTC
Comment 3 eric.savary 2005-07-07 14:36:27 UTC
Tested on Linux
I cannot reproduce it in a m112.
Please check again if it still happens.
Feel free to reopen then.
Comment 4 eric.savary 2005-07-07 14:36:43 UTC
Comment 5 andreschnabel 2005-07-07 14:57:05 UTC
checked with m113 (english + german langpack on WinXP)
following my initial instructions, the problem still exists 

I'll check on linux later today 
Comment 6 andreschnabel 2005-07-07 18:01:02 UTC
same on linux (m113 english + german langpack)
Comment 7 andreschnabel 2005-07-07 18:19:07 UTC
Created attachment 27777 [details]
Screenshot of missing language info
Comment 8 jack.warchold 2005-07-20 13:18:25 UTC
confirmed in src680_m119
reassinged to tra
Comment 9 jack.warchold 2005-07-20 13:20:31 UTC
i could only confirm this on win xp. linux looks good here
Comment 10 andreschnabel 2005-08-04 20:57:59 UTC
Created attachment 28502 [details]
same with m122 on Linux
Comment 11 andreschnabel 2005-08-04 20:59:00 UTC
still the same with linux here (m122 + german lang pack on SuSE 9.1, KDE)
Comment 12 tino.rachui 2005-09-06 08:15:18 UTC
TRA: Retargeted due to limited resources.
Comment 13 thackert 2006-06-04 09:52:07 UTC
Hello andreschnabel, *,
I have tested this with OOo 2.0.3 RC5 and Debian 3.1. In this combination the error does not occur. 
Could you test this with Win and SuSE again? Is this issue fixed in the newer version of OOo?

Comment 14 andreschnabel 2006-06-04 10:11:07 UTC
still occures on WinXP as well as on Linux/rpm (SuSE 10)
(OOo 2.0.3RC5, german localization)
Comment 15 thackert 2006-06-04 10:57:03 UTC
Sorry, have to revise my comment again ... :( In my second test it does not function as before, but 
results in the error which andreschnabel has reported ... :( So I can confirm this issue.
Sorry for the inconvenience
Comment 16 tino.rachui 2006-11-17 08:07:43 UTC
tra->mba: One for the writer team
Comment 17 Mechtilde 2006-11-24 20:15:39 UTC
I can confirm it with RC1 of 2.1
Comment 18 Mathias_Bauer 2006-12-06 18:04:41 UTC
Comment 19 thackert 2008-09-26 14:17:38 UTC
Hello Andre, *,
during my TCM test I stumbled upon this issue (again ... ;) ) and have tested it
with OOo 3.0 RC2 under Debian SID/Experimental AMD64. It seems, that this issue
is fixed here now.
Could you (or someone else) test this issue with an other OS/architecture, if it
is really solved, please? Could this issue be closed then?
Comment 20 andreschnabel 2008-09-26 17:01:23 UTC
tested on linux, using OOo 3.0RC2 german localization, deb pakages provided by sun.

The issue is *not* fixed - please read the initial description carefully and
have a look at the screenshots
Comment 21 thackert 2009-08-09 09:05:56 UTC
Hello andreschnabel, *,
after a long time I stumbled upon this issue again and tried to verify it ... ;)
It seems to be fixed on Debian SID AMD64 with OOO310m18. I have tried to follow
your description as carefully as I can. The only "problem", which I have found,
was the change from "Deutsch" to "Standard" ("German" to "Default"), if I copy
text from Writer to Calc. All other mentioned modules use the language "Deutsch"
("German"), if I copy text from Writer to them.
Could you be so kind to test it again with OpenSuse and/or Win$Version and give
me some feedback? Just out of interest: Are you using - like me - the
Germanophone install *debs or the English install with the Germanophone lang packs?
Comment 22 andreschnabel 2009-08-09 10:06:57 UTC
thackert: the issue still exists. according to your explanation that calc uses
"standard" I'd guess you look at the "Numbers" tab in calc cell formatting.
The problem is at the "Font" tab.

I'm using OOO310m18, German build on Kubuntu, AMD64

Anyway .. I'd guess, we have spent more time to again - and again verify this
bug than it would cost an experienced developer to fix this.
Comment 23 thackert 2009-12-20 17:40:16 UTC
Hello André, *,
I have not looked at the numbers tab, but at the font tab ... ;) But now - with
OOO320m8 (3.2.0 RC1) I can confirm your issue under Debian SID AMD64 ... :(
Sorry for the inconvenience ... :(
Comment 24 wope 2010-02-03 12:48:00 UTC
In OOO320m12 it also appears.
If you copy Text from Writer to Calc or Impress, the language Attribute is now
English (USA), and you can not change this.
I testet this with Win XP and SuSE 11.2 64bit, and the languages german and french.
Comment 25 andreschnabel 2010-02-03 13:03:52 UTC
to be more precise: in OOo320m12 the problem is now more generela than before.

Default language is now lost (and set to no language at all) on any
copy-paste operation from writer to calc. No matter if the calc cell is in edit
mode or not.
Comment 26 Olaf Felka 2010-02-03 13:04:46 UTC
I don't see the need for a 3.2.1 target.
Comment 27 Mathias_Bauer 2010-02-09 10:32:35 UTC
taking over
Comment 28 thackert 2010-05-08 17:03:44 UTC
Hello André, *,
I have tested your issue again (only the c&p from Writer to Calc and Impress)
and I hope, it is fixed (at least on my system with Debian SID AMD64,
Germanophone OOO320m17). Would be a nice five year birthday present for this
issue, if it works on other systems as well ... ;)
Would you be so kind to test it on your system again?
Comment 29 andreschnabel 2010-05-08 17:55:36 UTC
it's still the same problem here. Sure you checked the correct language setting?
It's *not* the number format language but the characters (font) language.
Comment 30 thackert 2010-05-29 09:32:47 UTC
Hello André, *,
I /am/ sure, that I have checked the font tab and the last time I have commented
here, it has worked for me. Now I have tested it again and I can - again - 
confirm it ... :( Now I can confirm your comment from February 3rd 2010
13:03:52, that the language entry is empty ... :( Maybe an upgrade of other
software on my OS? Maybe any other impact (solar storm or the like ... ;) )
interfere with OOo? I have not the faintest idea, sorry ... :( And sorry for the
inconenience ... :(
Comment 31 simonbr 2010-11-23 20:48:37 UTC

I have just encountered this problem in OOo 3.3 RC6 (Dutch) on Windows 7/64 (Dutch).

I paste a piece of text from a Writer document, the language of which is set to
Nederlands (NL), into a cell of a Calc document, the language of whose unedited
cells is shown as Nederlands (NL) as well. 

The pasted text is marked as incorrectly spelled and the language setting of it
is blank. 
Comment 32 Marcus 2017-05-20 11:31:08 UTC
Reset assigne to the default "".