Issue 48666

Summary: input of arbitrary unicode characters as defined in ISO 14755
Product: General Reporter: hhielscher <hhielscher>
Component: uiAssignee: eric.savary
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: issues, Mathias_Bauer
Version: OOo 2.0 Beta   
Target Milestone: 3.4.0   
Hardware: All   
OS: Unix, all   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description hhielscher 2005-05-04 02:17:11 UTC
In Gnome2 one can enter Unicode Chacters holding down Ctrl+Shift and typing the
hexadecimal code.
This input method is defined in ISO 14755:
http://www.cl.cam.ac.uk/~mgk25/volatile/ISO-14755.pdf
Comment 1 mci 2005-05-12 11:28:28 UTC
Hi hhielscher,

thanks for using and supporting OpenOffice.org...

mci -> us:
Hi us, please have a look at this issue, thanks...
Comment 2 ulf.stroehler 2005-05-26 14:17:05 UTC
set target.
Comment 3 ulf.stroehler 2005-06-06 15:16:20 UTC
us->hdu: another Unicode compliance task.
Comment 4 hdu@apache.org 2005-07-08 14:04:31 UTC
HDU->US: This is input method related stuff. PL suggests that doing this on
gnome should work in CWS pl06 or >=SRC680m114. Please reevaluate and reassign to
an input method expert if needed.
Comment 5 ulf.stroehler 2006-04-04 17:11:01 UTC
have to reassign issue.
Comment 6 eric.savary 2006-08-16 16:20:27 UTC
ES->PL: it looks like it works on KDE with gtk plugin but not on SUNRay Gnome or
Nevada default Gnome.
Comment 7 hhielscher 2006-08-16 21:19:20 UTC
Still does not work here using 2.0.165.cvs.20060506 on KDE3.5.4/Mandriva
Cooker/i586. Other applications like firefox work fine though,e.g.
Ctrl-Shift+ub6 gives ¶.
Comment 8 hagar_de_lest 2007-03-17 15:36:59 UTC
Is it possible to mark the following similar issues as duplicates of this one
(which seems to be the most up to date and the most precise) ? It could help to
merge the votes.
- Issue 66097 - Unicode input
- Issue 34050 - alternative way of entering unicode characters
- Issue 59974 - Ctrl-Shift Unicode Input Method should apply ...
- Issue 69468 - Keyboard unicode input (Ctrl+Shift+NNN) fails

Also related issue (is it possible to have only one method for all platforms,
using CTRL + SHIFT combination ?) :
- Issue 61540 - Standard MS Windows Alt-Key Unicode input fails

NB: still missing in 2.1 with Gnome 2.14.
Issue 69468 discussion is also interesting (input method change).
Comment 9 philipp.lohmann 2010-07-22 19:42:10 UTC
*** Issue 66097 has been marked as a duplicate of this issue. ***
Comment 10 philipp.lohmann 2010-07-22 19:46:44 UTC
confirm
Comment 11 philipp.lohmann 2010-07-22 19:50:25 UTC
In gtk plugin this works because gtk handles this internally in its input
method. For the generic plugin and its derivatives (e.g. the KDE3/4 plugins) I
have now a similar solution: enter ctrl+shift+u, then a hexadecimal sequence
(while keeping ctrl+shift pressed). Release ctrl or shift or enter a non
hexadecimal code and the sequence is complete; it will the be replaced by its
unicode.

for windows see issue 61540 (as of yet unsolved).
Comment 12 philipp.lohmann 2010-08-10 15:23:20 UTC
please verify in CWS vcl114
Comment 13 eric.savary 2010-08-24 15:22:31 UTC
Verified in CWS vcl114
Comment 14 eric.savary 2010-10-17 09:45:23 UTC
*** Issue 115094 has been marked as a duplicate of this issue. ***