Issue 49871

Summary: Copy/paste of a chart to MS-Word does not keep transparency.
Product: General Reporter: audirac <guillaume.audirac>
Component: chartAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, suporte, tony.galmiche.ooo
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: PC   
OS: Windows 2000   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
to test copy/paste to ms-word of a graph with transparency
none
Table with example of transparent (gradient) chart none

Description audirac 2005-05-25 18:05:22 UTC
When a chart (graph) is copied and pasted from a Spreadsheet into MS-Word, the
transparency rendering is not kept.
A file is attached for test.
Comment 1 audirac 2005-05-25 18:07:19 UTC
Created attachment 26563 [details]
to test copy/paste to ms-word of a graph with transparency
Comment 2 kla 2005-06-14 13:46:31 UTC
Seems to be an Clipboard issue. 
Comment 3 tino.rachui 2005-09-06 07:44:09 UTC
TRA: Retargeted due to limited resources. 
Comment 4 tino.rachui 2006-11-17 08:09:06 UTC
tra->mba: One for the writer team
Comment 5 Mathias_Bauer 2006-12-08 12:00:27 UTC
Looks like a metafile issue. As the metafile works in OOo it could be a bug in
Word, but I don't know. Sven, can you shed some light on this?
(In case that the bug is still reproducible)
Comment 6 suporte 2006-12-23 13:47:04 UTC
Created attachment 41674 [details]
Table with example of transparent (gradient) chart
Comment 7 suporte 2006-12-23 13:51:56 UTC
I think that is the same problem that was found when export a spreadsheet with
transparent (gradient) chart, attached here (chart_with_transparency.ods). I
exported to excel (xls), close the file e reopened the same xls file. The
transparent gradient was changed to solid color.
Comment 8 willi_burkhardt 2008-02-19 09:48:41 UTC
I think it is a Metafile Issue according to my observations below.
For the tests I use Copy/Paste functionality, OO-impress 2.3.1, Powerpoint and 
Word 2003 SP3.
 
Copy from Impress, using "Paste special ..." in MS-Word:
I get the possibility to select "Windows Metafile" "Enhanced Metafile" 
and "Device Independent Bitmap". --> Bitmap copies transparency correctly. The 
others don't. The transparent object colors are correct, the transparency is 
set to 0 instead of the actual value.

When I use Powerpoint to copy from, I have an additional Point "PowerPoint 
Object" available. "Enhanced Metafile" copies transparency correctly. "Windows 
Metafile" creates a dithering that roughly matches the transparency.

If I Copy from Powerpoint to Impress (using "Paste special ...") I have the 
options of "GDI metafile" and, if I copy a Slide, "Microsoft Powerpoint 
Slide". --> both of the options do not copy the transparency. the color is ok, 
but the transparency is set to 0.