Issue 50019

Summary: Cannot apply border formatting to multiple selection
Product: Calc Reporter: theosib <theosib>
Component: formattingAssignee: oc
Status: CLOSED FIXED QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: amy2008, baumux, chris_mux, chrlutz, gaojingmei, issues, ivan.icin, lvyue, michael.haus, michaelhaus, mux2005, niklas.nebel, stp, yonggang.mao
Version: OOo 1.1.4Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: PATCH Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
the updated patch for this issue, but I am still not sure whether it has been ok, niklasn, please see it
none
the updated patch of this issue none

Description theosib 2005-05-30 03:45:37 UTC
It is frequently the case that I want to apply formattings to odd collections of
cells.  I've been doing this to make spreadsheets look readable and
aesthetically pleasing for over 15 years.  Applying formatting to a "multiple
selection" is something I want to do A LOT, but this feature has always been
absent from OOo.  When I first started using OpenOffice, back when Sun first
opened it up, I reported this problem (now absent from your database), and it's
still not fixed.

If I knew how to fix this problem, I would.  Until then, PLEASE, for my sanity,
allow formatting for multiple selections.  I'm begging on my knees!
Comment 1 frank 2005-06-15 11:22:56 UTC
Hi,

sorry to tell you, but using m106 I'm able to use most of the formatting feature
on multiselections.

So I've to close this Issue as worksforme.

Frank
Comment 2 frank 2005-06-15 11:23:12 UTC
closed wfm
Comment 3 theosib 2006-02-05 22:17:43 UTC
Please reopen this.  I'm using a VERY recent OOo 2.0, and I am not able to 
apply borders to multiple selections. 
 
Comment 4 dridgway 2006-02-08 17:15:30 UTC
To reproduce:
  1. Select several non-contigous cells by cntrl-clicking them.
  2. Pick a border (either from Format->Cells...; Borders or from Border toolbar
button).
  -> Error message appears: "Cannot apply border to multiple selection"

Workaround: create a style (Format->Styles and Formatting) with the desired
border, and apply it to the selected cells. This works fine.

Added "border" to summary, as other formatting I've tried works fine on multiple
selections. Changed type to RFE.

There's a bit of ambiguity as to how the desired functionality should work. If
you select a rectangular region of cells and add a border, it's added to the
region as a whole, not the individual cells. If the multiple selection is a
collection of individual disjoint cells, borders on the individual cells would
make sense. But what if the multiple selection includes individual cells and
rectangular regions? Or contiguous nonrectangular regions? Applying a style
avoids this problem by treating everything as a collection of individual cells,
but the border formatting is supposed to deal with regions as regions.
Comment 5 dridgway 2006-02-13 16:30:51 UTC
As per
http://qa.openoffice.org/issue_handling/workflowcharts/RFE_issues_by_QA.sxd,
setting to NEW, assigning to requirements. WRT the ambiguity I mentioned, a
competitor product (Excel 2004) applies borders region by region, with the
regions being the rectangular groups created by single operations inside of the
multiselect sequence, i.e. each click or click and drag creates a new region
which gets its own border. No merging of regions is done.
Comment 6 stp 2006-05-20 14:14:37 UTC
*** Issue 8271 has been marked as a duplicate of this issue. ***
Comment 7 stp 2006-05-22 07:28:12 UTC
*** Issue 65643 has been marked as a duplicate of this issue. ***
Comment 8 frank 2007-08-09 14:27:44 UTC
*** Issue 79239 has been marked as a duplicate of this issue. ***
Comment 9 tommy27 2009-02-05 18:03:54 UTC
a new extension has been released to temporaririly solve this issue until it 
will be fixed by the OOo team.

the extension is called MultiBorders.
u can find it here: http://extensions.services.openoffice.org/project/MB
Comment 10 gaojingmei 2009-05-15 06:44:44 UTC
Created attachment 62280 [details]
the updated patch for this issue, but I am still not sure whether it has been ok, niklasn, please see it
Comment 11 niklas.nebel 2009-05-20 10:28:08 UTC
*** Issue 40574 has been marked as a duplicate of this issue. ***
Comment 12 gaojingmei 2009-05-21 03:04:47 UTC
Created attachment 62400 [details]
the updated patch of this issue
Comment 13 niklas.nebel 2009-05-26 17:33:41 UTC
taking the issue
Comment 14 niklas.nebel 2009-05-26 17:34:49 UTC
One small change was still needed: UnmarkFiltered must be called with a local
copy of ScMarkData, because the selection in the view should not be modified. I
changed that already and added the patch with the change to CWS "calc50".
Comment 15 tommy27 2009-05-26 19:58:15 UTC
nice to see that you fixed this ancient issue!!!
Comment 16 niklas.nebel 2009-05-28 15:21:51 UTC
reassigning to QA for verification
Comment 17 oc 2009-06-08 14:41:25 UTC
verified in internal build cws_calc50
Comment 18 amy2008 2009-07-13 06:39:44 UTC
cc
Comment 19 amy2008 2009-07-14 03:29:33 UTC
Verified in DEV300m51
Closing
Comment 20 fperezpercea 2009-07-23 08:41:17 UTC
When will be available ?  What OOo version ?
Comment 21 tommy27 2009-07-23 09:06:48 UTC
it will be available in OOo 3.2 which should be released in late november 09
Comment 22 fperezpercea 2009-07-23 09:23:56 UTC
Great..!!!  Thanks...
Comment 23 fperezpercea 2010-02-16 17:02:39 UTC
Congratulations....!!!  It is here at last.  

:-)