Issue 50336

Summary: Cannot use character '?' in naming file to save with OOo own dialogs
Product: General Reporter: waustin <waustin>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, khirano, lohmaier, matthias
Version: OOo 2.0 BetaKeywords: oooqa
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description waustin 2005-06-05 14:45:08 UTC
I am running the 104 pre-2.0 beta release on linux and don't know whether this
issue exists in the other platform releases; however, it does exist in earlier
betas as well.

I often create "template" documents with names such as (for example)
        donation_????????_2005-06-??     (with correct extension of course)
This is for either a writer doc or a spreadsheet.

When I try to do this (Save As>enter file name> hit save), the popup window
ignores my input until I select a filename it likes.

Unless this is an "undocumented feature", the programs should allow me to enter
any legal unix/linux filename.  Instead (after going through some of the code)
it fails to match any existing filename and won't let me save under a name
containing the questionmark characters.  (Haven't tried this with asterisks. Hmmm.)

If I save the file under an "acceptable" file name, go to the shell prompt
(xterm, etc.) and rename it to the above name, then I can open it, work with it,
and save it normally, just as I would expect.

If there is a reason to limit savable file names like this, it needs to be
documented - if not, then it is a bug.

Otherwise, no real complaints at all :-) have used staroffice then openoffice
ever since so6.0 and really like it on both linux and solaris (intel and sparc).

(I won't try to guess the priority on this since a workaround exists.  Sorry.)
Comment 1 lohmaier 2005-06-05 15:42:42 UTC
confirming with m104 - You can type them into the dialog, but OOo doesn't save,
it treats it like a search-statement. Works with GTK-load/save dialog.
Comment 2 jolatt 2005-06-05 19:23:56 UTC
Under windows there are some characters (\ / : * ? " < > |) which are not 
allowed in filenames. I don't know, how this is in Linux.
Comment 3 waustin 2005-06-06 05:20:43 UTC
FWIW, after posting this issue, I tried it with an asterisk ('*') - and got the
same behavior (i.e., refuse to save, ignoring attempt).

The other "special windows/dos" characters (<>|\) don't seem to mess things up,
although the colon (":") character save attempt resulted in a "file not found"
message, leading me to assume it was treating the name as <host>:<filename> or
some such - not a problem on this one, however.

Comment 4 michael.ruess 2005-06-06 08:42:02 UTC
Framework issue.
Comment 5 mci 2005-06-14 08:32:59 UTC
Hi waustin,

thanks for using and supportingh

? is used as a wildcard...
?.odt shows you all odt-files with exactly one character (a.odt, x.odt, 3.odt)
??.odt shows you all files with exactly two characters (aa.odt, xx.odt,ab.odt)
*.odt shows you all odt-files (a.odt, x.odt, 3.odt, aa.odt, xx.odt,ab.odt,

This is the same in the Bash: 
% ls 
./        ../       a.odt     ab.odt    abc.odt
% ls ?.odt
% ls ??.odt
% ls ???.odt
% ls *.odt
a.odt     ab.odt    abc.odt

As discussed with ES and US: set to won't fix
Comment 6 waustin 2005-06-16 04:51:37 UTC
I'll resist the urge to say something to the affect that everyone knows what the
unix regular expressions do (wildcards, patterns, etc.); however there are many
other unix/linux programs/utilities which - when presented with a pathname
containing wildcards which does NOT match any existing pathname - treat the
filename as a literal filename and create it.  (For instance go to an empty
directory.  type "> x.???.y" .  Bingo - you have a file named "x.???.y")

The point which I thought I made to begin with is that if this is the behaviour
of OOo, then it should be documented somewhere.  Otherwise it becomes by default
a bug.  If it is documented and I missed it, then shame on me; but having read
most of the docs for both OOo and staroffice, I haven't seen it yet... :-( (sorry).

This is not a gripe - and to leave it "as is" is OK (since a workaround exists)
- but it should be PREOPERLY DOCUMENTED in that case since the behaviour differs
from - and is therefore inconsistant with - that of many other common utilities.
Comment 7 thorsten.martens 2005-06-16 12:46:19 UTC
This one is not a defect but might be somehow a wish for an enhancement for
future OOo versions.
Comment 8 matthan 2008-01-27 23:25:29 UTC
Using OOo 2.3.0 on Ubuntu Linux, I tried to save a new file with a colon (":")
in filename. An error message appeared three times that said something like
(translated from German by me):

"Error when saving the document Unnamed1: the internet connection to service not
accessible could not be established."

As ":" is a valid character in Unix filenames, OOo should allow to choose names
with ":" in it. I understand that ":" refers to <host>:<port> at the moment.
However, I'd put this requirement for a future OOo version thus:

Create a clear separation between saving to local filesystem and saving to
network hosts, so that both methods offer full capabilities (like using all
allowed characters). Also, to the same effect, create a clear separation between
searching for existing file names and entering new file names, perhaps by using
another text box.

Best wishes for all future OOo devs!!
Comment 9 burgrettici 2010-11-11 03:34:12 UTC
Created attachment 74155