Issue 50901

Summary: Add shortcut to jump to recently used slide and view
Product: Impress Reporter: matthias.mueller-prove
Component: viewingAssignee: wolframgarten
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: 680m107   
Target Milestone: OOo 2.0.1   
Hardware: All   
OS: All   
URL: http://specs.openoffice.org/appwide/open_doc_behavior/OpenDocumentBehavior.sxw
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 53542    
Issue Blocks:    

Description matthias.mueller-prove 2005-06-17 12:26:06 UTC
Add a shortcut to jump to recently used slide and view, like Writer used Shift-F5.
see spec for details
Comment 1 matthias.mueller-prove 2005-06-17 12:33:10 UTC
new parent id
Comment 2 matthias.mueller-prove 2005-07-04 12:45:14 UTC
retarget to OOo 2.0
see row 101 in spec
Comment 3 groucho266 2005-07-06 08:31:46 UTC
Accepted.
Comment 4 matthias.mueller-prove 2005-07-06 09:35:15 UTC
The shortcut for calling the Navigator moves to Ctrl-Shift-F5.
cf. row 216 in http://specs.openoffice.org/appwide/menus/ViewMenu.sxw
Comment 5 groucho266 2005-07-06 13:28:21 UTC
Setting target to OOo 2.0.1 because for the new accelerator we need a new slot
and a new string.  This is a UI change that can not be done for OO 2.0.

The positive effect is that now we can make the change together with the Writer
team and share the slot, string, and maybe the CWS for implementing the new
accelerator.
Comment 6 groucho266 2005-08-10 09:03:20 UTC
The feature of opening Impress documents always on the first slide is covered by
issue 50902.
Comment 7 groucho266 2005-08-19 13:10:45 UTC
Adding dependency on new issue 53542.
Comment 8 groucho266 2005-08-22 13:53:51 UTC
Fixed by adding a new UNO command, RestoreEditingCommand, to officecfg, an
associated slot, SID_RESTORE_EDITING_VIEW, to SFX2, and support to SD.  The slot
is handled by ViewShellBase.

Affected files:
/officecfg/registry/data/org/openoffice/Office/UI/GenericCommands.xcu    rev.
1.41.64.1

/sfx2/inc/sfxsids.hrc    rev. 1.81.238.1
/sfx2/sdi/sfx.sdi    rev. 1.67.148.1

/sd/sdi/_drvwsh.sdi    rev. 1.33.130.2
/sd/uiconfig/simpress/accelerator/de/default.xml    rev. 1.3.38.1
/sd/uiconfig/simpress/accelerator/en-GB/default.xml    rev. 1.3.38.1
/sd/uiconfig/simpress/accelerator/en-US/default.xml    rev. 1.5.38.1
/sd/uiconfig/simpress/accelerator/es/default.xml    rev. 1.3.38.1
/sd/uiconfig/simpress/accelerator/fr/default.xml    rev. 1.3.38.1
/sd/sdi/ViewShellBase.sdi    rev. 1.8.154.1
/sd/source/ui/inc/FrameView.hxx    rev. 1.4.38.1
/sd/source/ui/inc/ViewShellBase.hxx    rev. 1.12.130.1
/sd/source/ui/view/ViewShellBase.cxx    rev. 1.20.110.1
/sd/source/ui/view/frmview.cxx    rev. 1.27.32.1
/sd/source/ui/view/makefile.mk    rev. 1.20.130.1
Comment 9 groucho266 2005-08-31 08:19:36 UTC
Reassigned for verification.

re-open issue and reassign to wg@openoffice.org
Comment 10 groucho266 2005-08-31 08:19:43 UTC
reassign to wg@openoffice.org
Comment 11 groucho266 2005-08-31 08:19:52 UTC
reset resolution to FIXED
Comment 12 wolframgarten 2005-09-01 12:09:16 UTC
Verified in CWS.
Comment 13 Uwe Fischer 2005-09-02 12:13:08 UTC
*** Issue 54145 has been marked as a duplicate of this issue. ***
Comment 14 wolframgarten 2005-09-28 13:16:07 UTC
Tested in master m131. Closed.