Issue 51258

Summary: thesaurus in right-click context menu
Product: Writer Reporter: qlex <qlex>
Component: editingAssignee: stefan.baltzer
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: gleppert, issues, Mathias_Bauer, stefan.baltzer
Version: OOo 1.0.0   
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
URL: http://specs.openoffice.org/appwide/linguistic/Thesaurus.odt
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 107209    

Description qlex 2005-06-27 12:59:15 UTC
i'm wondering if the following option will be/ could be included in OO2.0.
when writing a text, one right-clicks on a selected word and synonims appear in
the context menu (instead of having to press ctrl+f7 to bring up the thesarus).
or is there any other quicker way to change words ?
Comment 1 michael.ruess 2005-06-27 13:05:10 UTC
Reassigned to requirements.
Comment 2 ooolist2007 2005-10-19 21:04:33 UTC
*** Issue 44549 has been marked as a duplicate of this issue. ***
Comment 3 lohmaier 2006-08-29 23:09:32 UTC
*** Issue 57595 has been marked as a duplicate of this issue. ***
Comment 4 dprina 2006-11-11 07:59:48 UTC
I think it is better to let user configure all pop-up menu as he can do for menu
and toolbars
Comment 5 zleilndka 2007-04-04 02:29:16 UTC
Would be a great feature that might help some people feel more at ease on Open
Office.  Many of people who have used it off of my laptop ask me how to use the
thesaurus on Open Office.  If it was more similar to the way MS Word does it, I
feel people would be more comfortable in taking a step to using Open Office. 
Comment 6 milek_pl 2007-04-13 16:48:30 UTC
*** Issue 72688 has been marked as a duplicate of this issue. ***
Comment 7 milek_pl 2007-04-13 16:57:11 UTC
*** Issue 70164 has been marked as a duplicate of this issue. ***
Comment 8 mazz0 2008-10-02 15:07:46 UTC
This isn't just a matter of making it more like MS, but simply making it easier
to use - it makes sense to have synonyms in the context menu for a word, as
that's the only context in which they're applicable, and since you have to click
on a word either way it is less effort if the synonyms are right there in the
context menu rather than away in a menu.

Also, I have to agree with dprina - making context menus customizable, like
toolbars, would be a fantastic power-feature.
Comment 9 michael.ruess 2009-02-09 09:50:47 UTC
*** Issue 99013 has been marked as a duplicate of this issue. ***
Comment 10 Mathias_Bauer 2009-05-22 15:41:48 UTC
Target 3.x to give this is better visibility. No promise. ;-)
Comment 11 mazz0 2009-05-22 15:50:08 UTC
Not good enough - I demand a promise!  I demand that you do nothing else until
this is done!  No sleeping, no toilet breaks, no blinking until this feature is
released.  And I want a penguin.
Comment 12 gleppert 2009-05-22 23:20:48 UTC
Thank you mba, this is good news! The thesauri (e.g. the German Openthesaurus)
evolved very much over the last years. It is time not to hide this functionality
anymore. Looking forward to it.

IMHO toilet breaks are o.k.  ;-)
Comment 13 Mathias_Bauer 2009-05-25 11:38:42 UTC
An interesting point: how to proceed when a word has a lot of synonyms, e.g. the
english word "house". Word only displays a fixed number of synonyms that seem to
be a result of an arbitrary selection (or may be the first 8 words, regardless
how many different meanings the word can have). Here's the result in Word 2003:

"home": home, residence, dwelling, abode, domicile, address, quarters
"accomodation": accomodation, building, ... (19 more results)
"family": ... (5 results)
"company": ... (5 results)
"accomodate": ... (6 results)

In the context menu it displays all synonyms of the first meaning and the first
one of the second. Doesn't look like a concept to me.

So what about OOo? We could 

- do it like Word
- only show the "category" synonym (home, accomodation, family, company,
accomodate")
- make each category synonym a popup menu itself, showing the list of synonyms
assigned to that category
- show all synonyms in one popup, separated by category
- ... ?

I would like to move that discussion to dev@ux.openoffice.org, but wanted to
make sure that all people interested in this issue are aware of that.
Comment 14 mazz0 2009-05-25 13:16:38 UTC
How do we join the discussion there?
Comment 15 Mathias_Bauer 2009-05-25 13:36:14 UTC
You can subscribe to the list at ux.openoffice.org or you can post without being
subscribed and read answers in the archive or rely on getting cc:ed by the other
participants (what IMHO won't succeed always). The latter is more awkward and
time consuming (as the archives are not updated permanently), the first option
requires you to cope with some more e-mails (1-10 per day). 

Correction: the list is named discuss@ux.openoffice.org. Sorry for the mistake.
Comment 16 thomas.lange 2009-05-26 09:12:28 UTC
.
Comment 17 eric.savary 2009-11-17 22:35:08 UTC
*** Issue 106974 has been marked as a duplicate of this issue. ***
Comment 18 eric.savary 2009-11-17 22:35:31 UTC
closed
Comment 19 thomas.lange 2009-11-20 14:18:25 UTC
.
Comment 20 thomas.lange 2009-11-20 14:29:30 UTC
As discussed with CD and MBA:
In course of implementing this one for Calc/Draw/Impress it turned out that
those onse use a different UNO slot to start the thesaurus dialog compared to
the Writer application.

The result of the discussion was that the UNO slot ".uno:Thesaurus" should be
discarded and all occurrences need to be renamed to ".uno:ThesaurusDialog".


TL->QA:
The problem with this is that this change (if not done correctly and completely)
has a good chance to break at least the following things:
- application specific help for the thesaurus
- various related keyboard shortcuts
- the c05 and c08 installation sets
Thus be prepared for extensive testing!

If I am to find out about even more things that should be tested because of this
change I will list them here as well.
Comment 21 thomas.lange 2009-11-25 16:59:04 UTC
Files changed:


officecfg:
M      registry/data/org/openoffice/Office/Accelerators.xcu
M      registry/data/org/openoffice/Office/UI/GenericCommands.xcu

vcl:
M      source/window/seleng.cxx

sfx2:
M      sdi/sfx.sdi
M      source/menu/menu.hrc
M      source/menu/makefile.mk
A      source/menu/thessubmenu.cxx
A      source/menu/thessubmenu.hxx
M      source/menu/mnumgr.cxx
M      source/menu/menu.src
M      inc/sfx2/sfxsids.hrc
M      inc/sfx2/mnumgr.hxx

svx:
M      sdi/svx.sdi
M      source/outliner/outlvw.cxx
M      source/editeng/editview.cxx
M      inc/svx/outliner.hxx
M      inc/svx/editview.hxx

sd:
M      sdi/drtxtob.sdi
M      source/ui/view/outlnvsh.cxx
M      source/ui/view/drtxtob.cxx
M      source/ui/view/drtxtob1.cxx
M      source/ui/view/outlnvs2.cxx
M      source/ui/view/drviews7.cxx
M      source/ui/view/drviews8.cxx
M      uiconfig/sdraw/menubar/menubar.xml
M      uiconfig/simpress/menubar/menubar.xml

sc:
M      sdi/editsh.sdi
M      sdi/drtxtob.sdi
M      source/ui/drawfunc/drtxtob.cxx
M      source/ui/view/cellsh.cxx
M      source/ui/view/cellsh1.cxx
M      source/ui/view/editsh.cxx
M      uiconfig/scalc/toolbar/toolbar.xml
M      uiconfig/scalc/accelerator/en-US/default.xml
M      uiconfig/scalc/accelerator/es/default.xml
M      uiconfig/scalc/accelerator/fr/default.xml
M      uiconfig/scalc/accelerator/de/default.xml
M      uiconfig/scalc/accelerator/en-GB/default.xml
M      uiconfig/scalc/menubar/menubar.xml

sw:
M      sdi/_textsh.sdi
M      sdi/swriter.sdi
M      sdi/_viewsh.sdi
M      sdi/annotsh.sdi
M      sdi/drwtxtsh.sdi
M      source/filter/ww8/wrtww8.cxx
M      source/core/crsr/crstrvl1.cxx
M      source/core/crsr/swcrsr.cxx
M      source/ui/docvw/postit.cxx
M      source/ui/shells/drwtxtsh.cxx
M      source/ui/shells/drwtxtex.cxx
M      source/ui/shells/textsh1.cxx
M      source/ui/shells/annotsh.cxx
M      source/ui/config/viewopt.cxx
M      source/ui/uiview/viewling.cxx
M      source/ui/uiview/view.src
M      source/ui/uiview/viewstat.cxx
M      source/ui/inc/view.hxx
M      source/ui/web/web.src
M      inc/viewopt.hxx
M      inc/cmdid.h
M      inc/crsrsh.hxx
M      inc/swcrsr.hxx
Comment 22 thomas.lange 2009-11-25 17:27:10 UTC
Follow-up issue 107209.
Comment 23 thomas.lange 2009-11-26 09:29:59 UTC
Further changes:


customres:
M      c05/xml/uiconfig/modules/simpress/menubar/menubar.xml
M      c08/xml/uiconfig/modules/sdraw/menubar/menubar.xml
M      c08/xml/uiconfig/modules/scalc/menubar/menubar.xml
M      c08/xml/uiconfig/modules/simpress/menubar/menubar.xml
M      c08/registry/data/org/openoffice/Office/UI/GenericCommands.xcu

configmgr:
M      qa/unit/data/org/openoffice/UI/GenericCommands.xcu
Comment 24 qlex 2009-11-27 08:23:28 UTC
Hi guys,
thanx for taking on this issue. I certainly hope that this functionality will
help "convert" more users to OOo!
Since the status is fixed and the ticket is resolved, and discussion is a bit
too tech talk'ish for me, could you let me and others know, which OOo version
will include this functionality ?

thanx in advance,
Qlex
Comment 25 thomas.lange 2009-11-27 08:44:58 UTC
Target is OOo 3.3.
Since there are still some other issues that should be fixed in that same CWS I
think it will be next year before this one turns up in a developer build.
Comment 26 thomas.lange 2010-02-10 07:58:45 UTC
Link to spec added.
Comment 27 thomas.lange 2010-02-23 13:47:16 UTC
.
Comment 28 mohamed2000 2010-05-05 15:21:29 UTC
Openoffice writer is my only document processor writer ....
It will be vey interesting, usefull, better ....... to add this feature to my
favorite and only writer ....
Comment 29 stefan.baltzer 2010-05-21 14:49:00 UTC
Verified in CWS tl74.
Comment 30 eric.savary 2010-05-25 18:05:33 UTC
*** Issue 111825 has been marked as a duplicate of this issue. ***
Comment 31 eric.savary 2010-05-25 18:05:50 UTC
Closed
Comment 32 thadrazdow 2010-08-02 10:11:28 UTC
I would think that this is a no-brainer. Despite the low votes, I think many
users would like to have this option.
Comment 33 eric.savary 2010-08-02 10:41:13 UTC
Integrated in DEV300m82.
Comment 34 radicalchimward 2011-02-16 21:57:19 UTC
synonym provider/thesaurus, convenient dictionary and speed are a MUST for a
great, better than the competition, best of the best word system.

thanks for the needed improvements