Issue 51668

Summary: plugins do not get the focus when using the gtk plugin
Product: gsl Reporter: philipp.lohmann
Component: codeAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: 680m113   
Target Milestone: OOo 3.x   
Hardware: All   
OS: Unix, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description philipp.lohmann 2005-07-07 12:15:29 UTC
- start OOo writer with gtk plugin
- insert a PDF as plugin (using acrobat reader plugin)
- click into the plugin, e.g. into the zoom edit box

-> the plugin does not get the focus

The same is true for other plugins
Comment 1 philipp.lohmann 2005-10-04 13:38:25 UTC
the same goes for java applets

set target to 2.0.1
Comment 2 philipp.lohmann 2005-10-17 10:47:19 UTC
degrade target due to QA workload
Comment 3 philipp.lohmann 2005-11-25 14:38:25 UTC
note: GtkSocket/Plug does not solve the problem, the focus will never leave the
plugin again (which is much worse).
Comment 4 ooo 2006-01-20 12:48:06 UTC
need more time to evaluate and fix this correctly => retargeting to 2.0.3
Comment 5 philipp.lohmann 2006-03-15 14:40:48 UTC
still no good solution
Comment 6 philipp.lohmann 2006-06-30 16:35:27 UTC
still no solution, but people don't even seem to notice -> target 2.x
Comment 7 philipp.lohmann 2007-10-19 14:37:07 UTC
adjusting target due to limited resources
Comment 8 Rob Weir 2013-07-30 02:22:45 UTC
Reset assignee on issues not touched by assignee in more than 2000 days.