Issue 52974

Summary: using system hsqldb
Product: porting Reporter: caolanm
Component: codeAssignee: hjs <hans-joachim.lankenau>
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: Trivial    
Priority: P3 CC: h.mth, issues, rene
Version: 680m122   
Target Milestone: DevTools   
Hardware: All   
OS: All   
Issue Type: PATCH Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 58308, 61189    
Issue Blocks:    
Attachments:
Description Flags
proto patch
none
patch based on cmcs + version check and --with-hsqldb-jar
none
corrected patch
none
hopefully last patch...
none
this should work as a cleaner implementation
none
*groan* $ORIGIN gets expanded of course, new patch
none
updated patch none

Description caolanm 2005-08-06 09:09:50 UTC
patch attached to implement --with-system-hsqldb. Except that the scp2 profile
item is a bit troublesome to #ifdef, the token is too long to token stringify to
base the hsqldb.jar entry off an ifdef properly. Not sure of a better solution
Comment 1 caolanm 2005-08-06 09:10:43 UTC
Created attachment 28530 [details]
proto patch
Comment 2 rene 2005-08-06 18:01:59 UTC
Hi,

I personally think we should do two additional things here:#

- add a flag --with-hsqldb-jar to specify the location/nbame of hsqldb.jar. Some  
   broken distributions don't have it in /usr/share/java

- check the version. I guess we should check that the hsqldb we use is
  >= 1.8.0.0...

Regards,

Rene
Comment 3 rene 2005-08-07 22:06:57 UTC
To be attached patch implements the new suggestions.
Comment 4 rene 2005-08-07 22:07:50 UTC
Created attachment 28551 [details]
patch based on cmcs + version check and --with-hsqldb-jar
Comment 5 rene 2005-08-07 22:14:16 UTC
Created attachment 28552 [details]
corrected patch
Comment 6 rene 2005-08-07 22:14:49 UTC
oops. forgot to conditionalize the perl snippet wrt the jar location. fixed in
corrected patch
Comment 7 rene 2005-08-08 00:52:30 UTC
... and then of course the path has to be changed with a define in scp2....
Comment 8 rene 2005-08-08 00:57:27 UTC
Created attachment 28555 [details]
hopefully last patch...
Comment 9 rene 2005-08-08 03:38:40 UTC
I should have known it. HSQLDB_JAR is not correctly substituted by I don't have
an idea currently how to do that otherwise... Would
-DHSQLDB_JAR="file://$(HSQLDB_JAR)" or something like that work? I doubt it, but...
Comment 10 caolanm 2005-08-08 08:33:37 UTC
http://www.delorie.com/gnu/docs/gcc/cpp_17.html describes how to stringify a
macro, the problem is that the Value line is so long it cannot be stringified,
at least I couldn't figure one out.
Comment 11 caolanm 2005-11-23 13:58:47 UTC
Created attachment 31735 [details]
this should work as a cleaner implementation
Comment 12 caolanm 2005-11-23 14:34:40 UTC
Created attachment 31738 [details]
*groan* $ORIGIN gets expanded of course, new patch
Comment 13 caolanm 2006-01-30 10:40:39 UTC
Created attachment 33684 [details]
updated patch
Comment 14 caolanm 2006-01-30 10:41:33 UTC
I'll try and look after this if jaxpapi gets integrated, and if ValueList idea
gets accepted
Comment 15 caolanm 2006-02-01 13:29:51 UTC
accepted for consideration post jaxpapi integration
Comment 16 caolanm 2006-03-23 11:34:06 UTC
done in systemjava
Comment 17 caolanm 2006-03-24 08:59:47 UTC
reopen for qa
Comment 18 caolanm 2006-03-24 09:00:29 UTC
done in systemjava
Comment 19 caolanm 2006-03-24 09:01:25 UTC
back to fixed
Comment 20 hjs 2006-04-05 17:23:37 UTC
ok
Comment 21 hjs 2006-06-13 13:21:08 UTC
.