Issue 54063

Summary: Color pull down menu should not synch with selection
Product: Impress Reporter: michelezarri <m.zarri>
Component: formattingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, openofficelogin.mbourne
Version: 680m125Keywords: needmoreinfo, oooqa
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description michelezarri 2005-08-31 22:04:45 UTC
At present when a text is selected the pulldown menus in the toolbar for font
color area and highlight synchronise with the selection. CHances are that the
user will want to change the color if the button is used and it is better to
leave the last used one in the quick selection (e.g. if I last used red2, the
button should allow me to select red2 immediately).
Comment 1 michael.ruess 2005-09-01 08:09:36 UTC
MRU->ES: pls evaluate.
Comment 2 eric.savary 2005-09-01 10:30:26 UTC
This is exactly how the font color button works:
- long click on it
-> pull down menu opens
- select green8
-> the selected text gets the green8 color
- close the selection
- select another word
- short click on the font color button
-> the text gets the green8 color (last choosen color)

So I don't understand where the problem is.
Comment 3 eric.savary 2005-09-01 10:30:53 UTC
Changing prio to P3
Comment 4 michelezarri 2005-09-01 12:03:00 UTC
Hello es,

I am very sorry: the issue is not for writer but for impress where the behavior
is the one I described (the color shown in the font colour button synchronises
with the selection). I made a mistake when creating the issue. 

What should I do now? 
Should we close this issue (and I will open a new one) or is it possible to
modify the component field from "word processor" to "presentation"?

Cheers,

Michele

Comment 5 eric.savary 2005-09-01 12:48:44 UTC
Yes it's possible! Look! ;)
Comment 6 christian.guenther 2005-09-01 17:23:38 UTC
This is an enhancement and not a bug.
Comment 7 polis.gints 2005-10-15 11:11:23 UTC
I would like to report that same applies for Calc (RC3) and is very confusing if
moving from Excel.
Comment 8 michelezarri 2005-11-03 14:28:54 UTC
In response to cgu: I think this is a bug. Note that it is inconsistent with
writer where this enhancement/bug has been implemented and indeed the colour
shown in the changeColourMenuButton (whatever the name is) does not change when
the view cursor is moved. 
Comment 9 ace_dent 2008-05-15 12:30:58 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please re-test with one of the latest versions of OOo -
the problem(s) may have already been addressed. Either use the recent stable
version: http://download.openoffice.org/index.html
or consider trying the new OOo 3 BETA (still in testing):
http://download.openoffice.org/3.0beta/
 
Please report back the outcome so this Issue may be closed or progressed as
necessary - otherwise it may be Resolved as Invalid in the future. You may also
wish to search for (and note) any duplicates of this Issue that may have
advanced further :
http://www.openoffice.org/issues/query.cgi
 
Regards,
Andrew
 
Cleaning-up and Closing old Issues as part of:
~ The Grand Bug Squash, pre v3 ~
Comment 10 michelezarri 2008-05-15 12:51:05 UTC
Hello,

Just tested with OOo 3.0Beta2 and the issue remains.

Here's how to reproduce:

1. Create a slide, add some text.
2. Colour a word (say in red)
3. move the cursor to a different word

Effect observed: the colour pull down menu synchronizes with the colour of the text.

In Writer for example, the colour pull-down menu still remains set to the last
colour used, which is much more user friendly. 

Use case: I want to change the colour of many words in my presentation.
I have to follow these steps *for each word*:
1) select the word
2) pull down the font colour selector
3) select the colour

If the font colour menu could remain unchanged I would have to follow the above
procedure for the first word, after which I could simply:
1) select the word
2) click on the font colour icon in the standard toolbar.

Cheers,

Michele
 
Comment 11 hardy314 2009-05-21 00:34:56 UTC
Hello,

this issue remains with Impress 3.1.0. 

It is very annoying when you are creating presentations with some colored text
in it. The above suggested improvement (behavior like in Writer or like in
Powerpoint) would be very helpful.
Comment 12 karstenburger 2010-06-25 12:04:27 UTC
Issue remains in OO 3.2.1 Impress, latest build.

I think the main arguments are:
- tedious and counter intuitive
- color button has practically no purpose than show the current text color, 
which is already visible with the text itself.

In my presentations, I have to use it at least 10 times per page, in about 70 
pages (slides).

An alternative could be to be able to put buttons into the tool bar with 
configurable color, which change the text color. So I would perhaps have three 
buttons for the main three colors I need.
But I think, that is much more work to develop, and it is not consistent with 
rest of OO and with other (e.g. Microsoft) tools.

See users forum: 
http://www.openoffice.org/servlets/ReadMsg?list=users&msgNo=205869

Regards, Karsten
Comment 13 karstenburger 2010-06-25 12:07:06 UTC
I think it is simply a defect, not an enhancement.
Comment 14 mromani 2010-06-25 13:31:02 UTC
*** Issue 54063 has been confirmed by votes. ***