Issue 54423

Summary: Disable hidden icons in the "visible buttons" menu when the Asian or CTL support is disabled
Product: General Reporter: skyhawk1 <davidjstevenson>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, kami911, Mathias_Bauer, ooo, pescetti, prattleonboyo, rb.henschel, tj
Version: OOO 2.0 Beta2   
Target Milestone: AOO Later   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description skyhawk1 2005-09-10 04:49:24 UTC
When the vertical text or vertical callouts buttons are clicked in the pull down
menu at the end of the toolbar or the customize toolbar window, the icon flashes
on the toolbar and then dissappears. Using the visible buttons submenu, the
button in question remains unchecked, however in customize toolbar window, the
button in question is checked. When the toolbar is hidden and reshown, again the
button flashes and removes itself. This occurs in all programs with that
toolbar, and is not document specific.
Comment 1 mjneedles 2005-09-10 07:50:57 UTC
Confirm, but in reverse, on Fedora Core 4, OOo 2.0 m125.

Steps:
1 Open blank Writer document, set Drawing toolbar visible.  The default
configuration has the vertical text and vertical callout icons visible.

2. Attempt to disable (uncheck) the mentioned icons.  

Results: They flash, but remain visible.  The checkmark for Vertical Text does
not go away, but the Vertical Callout checkmark goes away.  The vertical Callout
icon cannot be reenabled from the Visible Icons menu, but it can from the
Configure... dialog.

Hope this helps.
Comment 2 Olaf Felka 2006-03-07 13:57:08 UTC
@ cgu: Please have a look at the drawing toolbar.
Comment 3 christian.guenther 2006-03-07 16:55:39 UTC
set to new and change the target.
Comment 4 christian.guenther 2006-03-07 16:56:35 UTC
I can reproduce the bug.
Please have a look.
Comment 5 Regina Henschel 2006-03-07 18:58:29 UTC
I have no problems with that icons in German OOo202rc3. Be aware that "Enhanced
language support" must be activated in Tools- Options - Lamguage Settings -
Language, otherwise those buttons are disabled.
Comment 6 Regina Henschel 2006-03-07 20:27:04 UTC
Seems to be duplicate to issue 50184.
Comment 7 Regina Henschel 2006-03-08 19:29:05 UTC
*** Issue 56659 has been marked as a duplicate of this issue. ***
Comment 8 Oliver Specht 2006-03-09 07:58:36 UTC
*** Issue 50184 has been marked as a duplicate of this issue. ***
Comment 9 kami911 2006-03-22 17:14:18 UTC
I do not undersatnd why It have to depend on "Enhanced
language support"?
If I enable "Enhanced language support" then I can not get disabled "Vertical
text". So it is an another bug.
mba -> can you help us to destroy these 2 bugs around 2.0.3 od 2.0.4?
Comment 10 Mathias_Bauer 2006-03-24 13:24:13 UTC
Sorry, this is not my playground. I think this is again something our GUI
specialists should judge about.

The reason why these strange things happen was the *explicit* request by them
that we shouldn't display the vertical text and vertical callouts button except
when CTL is enabled. So avoiding this strange behavior would only be possible if
the mentioned requirement was removed.

Christian, any opinions on that?
Comment 11 michael.ruess 2006-07-14 11:50:23 UTC
*** Issue 66622 has been marked as a duplicate of this issue. ***
Comment 12 alfeno 2006-10-20 23:32:51 UTC
I have the same problem with my OpenSuse 10.1

This problem since the first version of Ooo 2.0

When i go to "visible buttons" in the "drawing bar" and i select "vertical
Callouts". It don't appears in the drawing bar.  The same problem occurs in the
formatting bar (right-to-left and left-to-right) in the Ooo writer.
Comment 13 mbayer 2007-07-03 12:28:17 UTC
*** Issue 79104 has been marked as a duplicate of this issue. ***
Comment 14 mbayer 2007-07-03 12:38:22 UTC
Note this is not limited to Draw, nor to the icon "vertical callouts": in
Writer, the right-to-left and left-to-right icons won't appear (visibly) in the
Formatting toolbar even when activated in Tools > Customize (which is the
default), unless "Asian layout" respective "Complex text layout" is enabled in
Tools > Options. (See screenshot in issue 79104.)

These icons should either not be hidden in the toolbar (but grayed out or
something), or made unavailable in the "visible buttons" menu and/or Tools >
Customize dialogue, when Asian and/or CTL support is disabled.

Adjusting Summary.
Comment 15 Regina Henschel 2007-10-27 21:47:26 UTC
*** Issue 83044 has been marked as a duplicate of this issue. ***
Comment 16 T. J. Frazier 2007-12-28 02:40:12 UTC
The situation with the Right-To-Left and Left-To-Right buttons is somewhat worse
than described.  With CTL enabled, these two buttons won't go away.  In short,
they never obey the check-marks in the Visible Button or Customize dialogs.

When CTL is disabled, the dialogs should show these buttons grayed out.
When CTL is enabled, it should be up to the user whether they are visible, just
like any other buttons.  /tj
Comment 17 lohmaier 2009-06-25 21:06:52 UTC
*** Issue 91184 has been marked as a duplicate of this issue. ***
Comment 18 Mathias_Bauer 2009-06-25 22:55:15 UTC
I will move this forward on the ux list. 
Comment 19 Regina Henschel 2010-07-03 10:26:36 UTC
*** Issue 112905 has been marked as a duplicate of this issue. ***
Comment 20 eric.savary 2011-01-22 12:26:36 UTC
*** Issue 116559 has been marked as a duplicate of this issue. ***
Comment 21 PoB 2015-06-16 01:16:32 UTC
Will this problem actually be fixed in v.4.1.1 or what exactly is going on? There is no recent activity on this issue.
Comment 22 Marcus 2017-05-20 10:45:02 UTC
Reset the assignee to the default "issues@openoffice.apache.org".