Issue 5487

Summary: Notes for range of text
Product: Writer Reporter: spetko <ales.spetic>
Component: uiAssignee: max.odendahl
Status: CLOSED FIXED QA Contact:
Severity: Trivial    
Priority: P3 CC: byte, gleppert, ich, issues, martin, mr_smyle, nicolas.mailhot, ooo.redflag, openoffice, pagalmes.lists, pet.ebe, r4zoli, rainerbielefeld_ooo_qa, richlv, stp, thomas.lendo, zerohalo
Version: OOo 1.0.0Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 94949    
Issue Blocks: 90135    

Description spetko 2002-06-02 10:51:45 UTC
Current support for notes is fairly basic. At minimum, support for notes that are linked to a selected text is needed. Currently notes can be 
attached only at the cursor position. You cannot select a text (by highlighting it) and attach a note to the selection. If you do that, the 
selected text is removed and a note is attached the position. Solving this problem would be a major enchancement the OpenOffice. 

Of course a notes display feature, similar to XP (on the right side of the text) would be nice, but not necessary. That can wait for later 
versions.
Comment 1 Rainer Bielefeld 2003-05-23 16:03:15 UTC
Assign, Target Milestone "Future"

Rainer
Comment 2 stefan.baltzer 2003-06-04 14:17:41 UTC
Reassigned to Bettina.
Comment 3 utomo99 2003-10-07 10:19:43 UTC
Please try using the latest OpenOffice 1.1 Final , you can download it
from www.openoffice.org
many bug fixes and enhancements since your version and 1.1 Final . If
the problem still happend in 1.1 please report back
Comment 4 mci 2003-10-16 10:58:23 UTC
*** Issue 20438 has been marked as a duplicate of this issue. ***
Comment 5 michael.ruess 2003-11-10 15:32:17 UTC
*** Issue 22283 has been marked as a duplicate of this issue. ***
Comment 6 rogerathome 2003-11-11 22:08:23 UTC
Don't forget to enhance the import of Word documents when fixing this
issue. See the closed issue
http://www.openoffice.org/issues/show_bug.cgi?id=22283
Comment 7 byte 2004-01-25 03:27:55 UTC
Confirmed: when text is selected, to get the note inserted, the text gets deleted.
Comment 8 lohmaier 2004-02-29 19:42:42 UTC
*** Issue 25965 has been marked as a duplicate of this issue. ***
Comment 9 michael.ruess 2004-12-01 11:01:01 UTC
*** Issue 38156 has been marked as a duplicate of this issue. ***
Comment 10 michael.ruess 2005-10-12 13:11:03 UTC
*** Issue 55801 has been marked as a duplicate of this issue. ***
Comment 11 drjimmy42 2005-10-13 19:21:35 UTC
Not to pile on, but if you type a note without newlines, it doesn't wrap in the
notes UI and continues off to the right indefinitely and makes it very difficult
to read.  However, if you do manually put in new lines, they show up as squares
in MS word comment UI.
Comment 12 aziem 2005-11-03 23:58:21 UTC
This issue has multiple parts:
1. Add note to a range of text.
2. Use margin for notes.

Should these parts be separated into two issues?

Summary: "Notes feature needs improvment" --> "Notes for range of text; Track
notes in margin" for easier searching

Issue 9661 is similar to part #2 here: use margin to track changes.
Comment 13 dave_vcu 2006-04-11 20:47:37 UTC
I teach a university writing course, and the only thing keeping me from having
my students use OOo Writer for their assignments is that I cannot select text
and comment on it directly with Writer's Notes feature. This is a showstopper
for me, which is unfortunate. I teach 50 students each semester in a required
course at a university with 27,000 students. I would like to use Writer, but I
simply cannot with the current state of the collaboration features.
Comment 14 bezvardis 2006-05-25 19:15:57 UTC
:-(( In four years (jun 2002 when it was opened till now - end of May 2006) this feature has not received 
any attention!!! Despite that versions have changed from 1.1 to 2.0.2!!! A range of characters still cannot 
be assigned a note and a MS Word 'comment' is still not visible in OOo.
Comment 15 michael.ruess 2006-07-25 10:48:05 UTC
*** Issue 67744 has been marked as a duplicate of this issue. ***
Comment 16 rettops 2006-12-11 17:25:00 UTC
The notes in Calc are much more usable than the notes in Writer.  How about
using that mechanism for a short-term improvement?
Comment 17 davewt2007 2007-03-12 22:35:51 UTC
I agree that it's really irritating that this issue hasn't been improved yet.
I've posted this on a related thread but I'll post it here to -so apologies to
anyone who's inconvenienced by reading the same remarks. It's just that this
issue is particularly important to me.
_________

I have to agree that the Writer editing tools need an overhaul. They were the
thing that most made me reluctant to ditch word and, while I finally decided to
put up with them, I really would like to see them improved.

To begin with, the method for accepting/rejecting changes on a case by case
basis is really cumbersome when compared with Word. That box that opens up with
the changes listed by time is, so far as I can see, utterly pointless. Why use
that, when it is simply better to scroll through the document?

Secondly, the insert comments feature just doesnt cut the mustard -there also
appear to be problems with comment visibility if the document is then opened in
Word. I do a lot of proof-reading work and 99.9% of my clients use Word - I need
the integration to be seemless because otherwise it looks woefully
unprofessional. When I insert a comment, I don't want a little box in the text
-I want it in the margin. Also, when I select a comment to apply to a peice of
text, I don't want the original text to be invisible when my client opens it in
Word (which has just happened).

Finally, I think that the text crossing out feature when you delete text may
have its uses but most of the time it simply makes the document hard to navigate
and requires me to do a second pass with the changes turned off. This allows me
to do a final edit but it takes for ever to delete anything this way.

Overall, I think OOo is excellent and I don't want to be so negative -but text
reviewing tools are very important to me (and to many others I'm sure) -and I
don't want to be yearning for Word anymore.

Thanks,

David
Comment 18 Mathias_Bauer 2007-05-07 16:56:29 UTC
assigned to mod
Comment 19 max.odendahl 2007-05-08 04:04:20 UTC
Work on a new implementation of notes in the right margin has started. Notes for
a range of text is also planned, but not supported by ODF 1.1, so this will take
a little longer.
Comment 20 eric.savary 2007-06-15 14:04:08 UTC
Just correcting some flags in this issue.
Comment 21 eric.savary 2007-06-16 15:30:27 UTC
*** Issue 12846 has been marked as a duplicate of this issue. ***
Comment 22 eric.savary 2007-06-17 16:30:41 UTC
Hi all!

I am one of the team members working on the new notes concept.

This issue contains many ideas which we cannot implement all at the same time
(due to technical reasons).

So I'm starting splitting this issue and other in sub tasks we can start to work on.

Of course, due to the number of CCs and votes, this issue remains open and will
be used as parent task! :)
Comment 23 eric.savary 2007-06-17 16:32:08 UTC
About the concept of "Displaying notes in the margin" see issue 78578.
Comment 24 max.odendahl 2007-10-06 11:33:39 UTC
Sun introduced a new annotation feature for ODF 1.2, it is now possible to
attach a note to a range of text and not only to a single position.

Therefore we can implement this feature now in OOo. As the timeframe for 2.4 is
too short, I am setting this to 3.0
Comment 25 max.odendahl 2007-10-06 11:35:19 UTC
To make things clear, Sun suggested to introduce this new feature to the ODF TC,
which was accepted by their members.
Comment 26 eric.savary 2008-02-05 19:02:47 UTC
I'm writing "Notes2" to make this issue appear in a query.
Comment 27 michael.ruess 2008-06-10 10:37:56 UTC
*** Issue 90549 has been marked as a duplicate of this issue. ***
Comment 28 zerohalo 2008-09-23 18:35:34 UTC
Another reason why this is important is that when a .DOC file is opened, any comments that spanned a 
range of text are instead "converted" to only be positioned at the end of the text span. Therefore when the 
document is saved back out to DOC format (or even ODF), that information is lost. This creates a major 
compatibility problem if exchanging files with others using Microsoft Word (which is a lot of people), since 
the file returned to them "broke" the annotations. 
Comment 29 ccaughie 2008-10-06 10:29:03 UTC
Has any progress been made on this feature? I was hoping it would be in 3.0 but
it doesn't seem to be present in rc3. The "comments on the right" feature is
there of course, and looks great, but you still can't comment on a range of text
as you can in MS Word.

This is pretty much the only remaining barrier to my team switching to OpenOffice.

Thanks,
Colin
Comment 30 zerohalo 2008-10-06 15:59:07 UTC
Ditto on that last comment. This is the last remaining issue for adoption by my team and other teams I 
work with as well. 
Comment 31 max.odendahl 2008-10-27 01:25:18 UTC
*** Issue 95435 has been marked as a duplicate of this issue. ***
Comment 32 Mathias_Bauer 2008-11-05 12:25:39 UTC
Bookmark refactoring that we need for this feature won't be finished in time -> 3.2.
Comment 33 christoph 2008-11-13 20:33:09 UTC
*** Issue 95993 has been marked as a duplicate of this issue. ***
Comment 34 max.odendahl 2009-07-10 07:13:52 UTC
noone actively working on this currently and bookmark refactoring not done yet,
so I believe this will not make it into 3.2
Comment 35 r4zoli 2009-11-18 12:19:31 UTC
Now that blocking issue solved (94949), any plan for this in OOo 3.3?
Comment 36 gleppert 2009-12-18 21:59:29 UTC
Will this enhancement "Notes for range of text" come in 3.3?
Comment 37 venkumara 2010-02-03 10:39:08 UTC
I notice that OOo 3.1.1 is already allows Bookmarking a 
range. Perhaps the same programming mechanism can be 
applied to Note.

For those who use comment/note, OOo not yet truly capable 
of handling Word DOC.

Hopefully this issue can be resolve soon. Thanks! :-)
Comment 38 venkumara 2010-02-03 10:39:23 UTC
I notice that OOo 3.1.1 already allows Bookmarking a 
range. Perhaps the same programming mechanism can be 
applied to Note.

For those who use comment/note, OOo not yet truly capable 
of handling Word DOC.

Hopefully this issue can be resolve soon. Thanks! :-)
Comment 39 jeffintexas 2011-01-16 08:44:06 UTC
Count me on the list of people who'd like to see this feature be compatible with
Word.   Sounds like it would be super-easy to implement.  Thanks for
re-considering.   
Comment 40 venkumara 2011-01-17 06:41:39 UTC
@jeffintexas and others, (if you have not) please click "Vote for 
this issue" so that it gets the attention that we want.
Comment 41 mroe 2014-03-26 11:40:48 UTC
Comments for text ranges are available in AOO 4.1.