Issue 54890

Summary: Crash after Copy&Paste
Product: Writer Reporter: hte <heike>
Component: editingAssignee: eric.savary
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P2 CC: issues
Version: OOo 1.1.5Keywords: needmoreinfo, oooqa
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description hte 2005-09-21 09:36:17 UTC
After Copy&Paste some text in a document OpenOffice 1.1.5 crashes. The copying
was within the same document.
Comment 1 h.ilter 2005-09-21 10:15:50 UTC
HI->ES: Couldn't reproduce, please investigate.
Comment 2 hte 2005-09-21 10:25:34 UTC
Maybee its important to know that we use the german localisation.
Comment 3 hte 2005-09-21 10:58:34 UTC
Ok I received more informations, my colleague told me that it did not crash but
freeze, like an infinite loop. And this happens only after various copy&paste
actions.
Comment 4 yunkong 2005-10-11 08:04:10 UTC
Hello,

Pls send more info on this. What did you copy/paste and what did the document 
contain. Does it also happen in Ooo 2.0 RC?

A.Y.K. Jong
Comment 5 yunkong 2005-10-25 12:05:15 UTC
Hello hte,

I just tried copying/pasting with OpenOfficeorg Writer 2.0 RC2 (PC, Windows XP 
Professional, English) and I can create a loop:

1. Open a new standard .odt document in writer
2. Type "thisisatest" . No spaces.
3. Select the text with the keyboard command "CTRL + A"
4. Copy the text with the keyboard command "CTRL + C"
5. Paste a couple of lines (6) with the keyboard command "CTRL + V"
6. Copy those six lines again and paste them the same way

Expected Result: Pasting can go on "forever"

However the pasting stops at page 11 or 12 and it is not possible to enter 
anymore text in the document.

If this is the case, then this is a duplicate of ISSUE 17171.

I agree with allsorts46 (last comment in ISSUE 17171) that:
"At the very least, Writer should not allow any actions that would cause this 
to happen, and present an error and explanation to the user. Simply 'losing' 
the text is unnaceptable."

Regards,

A.Y.K. Jong

*** This issue has been marked as a duplicate of 17171 ***
Comment 6 eric.savary 2005-10-25 12:28:46 UTC
closed