Issue 55214

Summary: OOo terminates without visible reason and without saving documents
Product: General Reporter: Rainer Bielefeld <rainerbielefeld_ooo_qa>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: 680m125Keywords: crash, oooqa
Target Milestone: AOO Later   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Error Report text copy none

Description Rainer Bielefeld 2005-09-29 08:26:29 UTC
Again and again I see OOo terminating completely without any visible reason.
It's not a very frequent problem, but very annoying ... 10 documents open, all
with lost changes for the last 14:59 minutes after last automatic-backup :-(

I attached an error report for one of those "silent crashes". The termination
happened, when I tried to egt the cursor by mousepointer between a small
(character sized) image (anchored as character) and the next character; the
image was marked by a mouseclick before, and while I tried to place the cursor,
OOo was terminated without any acvanced warning.

If I remember correctly, the "crash" normally happens when I work in writer, but
I am not sure whether that's the only situation from where the crash happens.

Unfortungately it will be rather difficult to find a method that will make tat
effect  really reproducible.

Definitely I am not the only user with this problem, I read about this problem
in OOo mailing lists.
Comment 1 thorsten.martens 2005-09-29 11:14:20 UTC
TM->SBA: Please have a look. Seems to be more an application (document, writer)
problem than a framework-issue to me. Thanks !
Comment 2 jack.warchold 2005-11-03 15:20:53 UTC
i will investigate on this, i had no crashes with the lates version here on my xp and i 
worked the whole day with it. maybe this was a m125 related problem?

rainer, do yo have this problems with a later version too?

reassigned to jw

set target OOo later
Comment 3 Rainer Bielefeld 2005-11-03 15:47:41 UTC
It's definitively not only a m125 problem, I still haev these "silent crashes"
with 2.0 German version WIN XP: [680m3(Build8968)].

I do not believe that there is only one reason for these crashes, there might be
several unrecognized bugs causing problems.

Even I _never_ heard any reaction except the stupid "Thank you for the
OpenOffice.org Error Report" (and so believe, that they never will be regarded),
I will send several bug reports with reference to this issue.
Comment 4 Rainer Bielefeld 2005-11-04 12:52:01 UTC
*** Issue 57347 has been marked as a duplicate of this issue. ***
Comment 5 Rainer Bielefeld 2005-11-04 12:52:34 UTC
Change OS due to comments in issue 57347
Comment 6 jack.warchold 2005-11-07 15:33:00 UTC
rainer do you have any error report id?
we are highly interested in this issue and i will investigate on this as good as i can.
Comment 7 Rainer Bielefeld 2005-11-08 17:21:59 UTC
How can I find out such error report ID?

I always wrote "This is an error report for issue 55214" into the reports.
Comment 8 Rainer Bielefeld 2005-11-10 09:49:22 UTC
Because I don't have any idea how to find out such "error report id", I attached
a report as textfile.
Comment 9 Rainer Bielefeld 2005-11-10 09:51:13 UTC
Created attachment 31320 [details]
Error Report text copy
Comment 10 Oliver Specht 2005-11-10 14:39:02 UTC
The stack can be seen in internal issue 240887:

sm680mi!SmSymDefineDialog::SmSymDefineDialog(Window* pParent = 00e1e630 ,
SmSymSetManager* rMgr = 0c103278 , unsigned char bFreeRes = 0x1 '')+0x43c
[o:\src680\src.m122\starmath\source\dialog.cxx @ 2158]
sm680mi!SmSymbolDialog::EditClickHdl(Button* pButton = 00e1f120 )+0x2a
[o:\src680\src.m122\starmath\source\dialog.cxx @ 1509]
sm680mi!SmSymbolDialog::LinkStubEditClickHdl(void* pThis = 00e1e630 , void*
pCaller = 00e1f120 )+0xe [o:\src680\src.m122\starmath\source\dialog.cxx @ 1505]
tl680mi!Link::Call(void* pCaller = 00e1f120 )+0x11
[o:\src680\src.m122\tools\inc\link.hxx @ 180]
vcl680mi!Control::ImplCallEventListenersAndHandler(unsigned long nEvent = 0x44e,
Link* rHandler = 00e1f230 , void* pCaller = 00e1f120 )+0x3e
[o:\src680\src.m122\vcl\source\control\ctrl.cxx @ 410]
vcl680mi!Button::Click( void )+0x12
[o:\src680\src.m122\vcl\source\control\button.cxx @ 221]
vcl680mi!PushButton::Tracking(TrackingEvent* rTEvt = 00e1e1c8 )+0x124
[o:\src680\src.m122\vcl\source\control\button.cxx @ 1596]

Comment 11 jack.warchold 2005-11-10 14:51:00 UTC
thank you rainer for the report and oliver for the stackid

i will try to find a way to reproduce this error now knowing where to search in.
Comment 12 jack.warchold 2005-11-10 15:01:08 UTC
correction: the internal issue is issue 126196
Comment 13 utomo99 2007-01-31 03:36:53 UTC
is there any progress since 2005, as this is a crash issue ? 
Thanks
Comment 14 Rainer Bielefeld 2007-01-31 06:13:18 UTC
Just yesterday I saw that again with "2.0.2  German version WIN XP:
[680m5(Build9011)]"