Issue 57094

Summary: Toolbars: up down arrows aren't useable in docked mode
Product: General Reporter: atlanx <atlanx>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, lohmaier
Version: OOo 2.0Keywords: oooqa, usability
Target Milestone: AOO Later   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
This show's the undocked and docked situation. none

Description atlanx 2005-11-01 03:56:05 UTC
If you dock an toolbar on the left or right side of the programmwindow and this
toolbar has an field which has up/down arrows to set an value you can't access
either the up/down arrows nor the valuefield.

This makes it unusable as an docked toolbar.

Example: Dock the Toolbar "Picture" on the left side of OO Writer and you have
no longer access to the transparency value.

You can have an look at the attachement, too.

I have tested it in Writer 2.0 eng and german. (WinXP)
Comment 1 atlanx 2005-11-01 04:06:26 UTC
Created attachment 31067 [details]
This show's the undocked and docked situation.
Comment 2 michael.ruess 2005-11-01 06:34:32 UTC
Reassigned to ES.
Comment 3 eric.savary 2005-11-01 10:07:06 UTC
Reassigned to framework
Comment 4 lohmaier 2005-11-01 23:25:33 UTC
confirming on linux. As described.
Comment 5 mci 2006-01-01 18:00:05 UTC
something for CD?
Comment 6 atlanx 2006-03-04 06:55:41 UTC
Will this get fixed in 2.0.2 or is there a plan to fix this in a later version?
Which version could it be?

Thank you.
Comment 7 thorsten.martens 2006-03-29 06:23:35 UTC
Not reproducible in a m161 build
Comment 8 thorsten.martens 2006-03-29 06:24:30 UTC
closed as worksforme
Comment 9 atlanx 2006-04-02 13:40:44 UTC
What is a m161 build? Is this a build for OO 2.0.3?
I'm working with OO 2.0.2 now and this bug is still there.

If a new picture is needed I can make one. How does it look like in your m161
version? Can you make a picture of this like I have made?
Comment 10 Regina Henschel 2006-04-02 19:49:36 UTC
m161 is a developer snapshot. You can get the public developer snapshots from
http://download.openoffice.org/680/index.html. Note that not every number is
"public".

I use OOo-dev2m162 and the transparency button does nothing, if the picture
toolbar is docked vertically. Therefore it is not fixed. Because this toolbar is
the only place to set transparency, I think that there should be some action,
when clicking that symbol. At least should the online help say that it is not
usable, if the bar is docked vertically.

Comment 11 thorsten.martens 2006-04-04 08:23:33 UTC
TM->CD: Reproducible in a m162 build on WinXP. Please have a look, thanks !
Comment 12 carsten.driesner 2006-04-04 09:02:23 UTC
cd: This issue cannot be fixed for OOo 2.0.3. If we want to support this, we 
have to introduce vertical fields (edit fields, spin fields, etc). These 
controls must be newly implemented.
Comment 13 carsten.driesner 2006-04-04 09:06:40 UTC
cd->pl: If we want to fix this issue, we have to introduce vertical controls. 
Changed Issue Type to "ENHANCEMENT"
Comment 14 philipp.lohmann 2006-04-04 09:55:33 UTC
Also vertical spinfields wouldn't be very feasible; either you make the toolbar
broader, so it can contain a sensible spinfield, or you end up with very narrow
edit field; putting the spinbuttons down instead of right would help here a
little, but would not solve the problem essentially. I would suggest docking
toolbars with spinfields either top or bottom instead.

Transferring feature request to requirements.
Comment 15 atlanx 2007-02-14 08:37:50 UTC
"I would suggest docking toolbars with spinfields either top or bottom instead."

I'm working with an 16:9 Display. This is the reason why I prefer docking left
or right.