Issue 57839

Summary: Value of the function is out of scope.
Product: Calc Reporter: Maciej Nux Jaros <egil>
Component: programmingAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P4 CC: issues
Version: OOo 2.0   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Maciej Nux Jaros 2005-11-13 18:34:08 UTC
Simple - when I create the function:
Function a () as double
   a = 10 'in the "watched variables" I see -> a = <Out of Scope>
end function

It really annoys me because I would have to create some other variable for
debugging - like this:
Function a () as double
   Dim res as double
   res = 10
   a = res
end function
Comment 1 frank 2005-11-13 23:16:21 UTC
Not a bug because a isn't a variable, so no it cant be used as such.

Frank
Comment 2 frank 2005-11-13 23:16:39 UTC
closed invalid
Comment 3 Maciej Nux Jaros 2005-11-15 23:34:19 UTC
What?! Of course it _is_ a variable! It is the returned value and it has to be
put in somewhere. I don't care if it is in accumulator (ax) or on top of the
stock or somewhere else (as it probably is) but it is a variable for me and I
should be right - I'm the user ;>.

Besides that Excel enables this possibility.

OOo has very poor variable watching (can't see contents/structure of objects),
please don't add this one to it's poorness.
Comment 4 frank 2005-11-16 09:01:07 UTC
Hi Niklas,

please comment on this one.

Frank
Comment 5 niklas.nebel 2005-11-16 14:37:53 UTC
This is about the Basic IDE, has nothing to do with Calc.
Comment 6 thomas.benisch 2005-11-16 14:48:26 UTC
TBE->AB: As discussed to you.
Comment 7 ab 2006-03-20 15:54:45 UTC
Indeed this should work, but it could be not so easy to fix and
does not affect general funtionality. -> P4, OOo later
Comment 8 Marcus 2017-05-20 11:13:26 UTC
Reset assigne to the default "issues@openoffice.apache.org".