Issue 57973

Summary: Extension of Change Case (in order to "toggle" all cases)
Product: Writer Reporter: shmuelh <shmuelh>
Component: codeAssignee: requirements <requirements>
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOO 2.0 Beta2   
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description shmuelh 2005-11-16 06:35:13 UTC
Right now, when one goes to Format| Change Case, there are two choices:
Uppercase and Lowercase. I'd like to suggest a third choice: "Change case,"
which will change whatever case it is to the other one. This would make it easy
to program a simple macro which will automatically change the case of the
selected item. Maybe this is possible right now using macro programming, but for
someone with very limited macro programming experience - like me - this might be
an impossible task.
Comment 1 michael.ruess 2005-11-16 08:59:25 UTC
Reassigned to SBA.
Comment 2 stefan.baltzer 2005-12-05 11:30:01 UTC
SBA: This makes sense when the user mistakenly had the <caps lock> key pressed
while writing.
Adjusted summary. Reassigned to requirements.
Comment 3 wspc 2006-11-17 07:38:11 UTC
I would personally really really really like to see toggle case incorporated 
into Writer as it is implemented in MS Word.  As someone who types reports all 
day and accidentally bumps the CAps loCK button - and we all do it 
occasionally, having a quick way (keyboard shortcut is a must) to toggle the 
case of blocked text really makes life easier.  

That is to toggle between: WORD, word, and Word.

The current implementation of case toggle (and why not introduce this across 
the board to all components of Open Office) is clumsy and not consistent with 
the space-age feel of the overall product.  

This is the one thing that is causing me to stick with Office 2003.  I am even 
considering running Office 2003 on Linux with CrossOver, so please please 
attend to this at your earliest convenience. 
Comment 4 stp 2006-11-27 08:17:45 UTC
duplicate

*** This issue has been marked as a duplicate of 1601 ***
Comment 5 stp 2006-11-27 08:18:22 UTC
.