Issue 57984

Summary: Frequent flicker of document after load
Product: Writer Reporter: khbellgardt <bellgardt>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, kamataki, norbert.notz
Version: OOo 2.0   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Document to demonstrate flicker
none
Andrew Pitonyak's free macro document as test file (contains no macros)
none
flicker.odt none

Description khbellgardt 2005-11-16 09:57:06 UTC
After opening a document with many OOoMath formulas the document area flickers
with a period of less than 1 sec for a long time. With a document of ca. 100
pages this lasts about 2 minutes. During this period it is almost impossible to
work with the document because the flickering is very disturbing.

There seems to be exactly one flicker per formula. It is possible to follow the
flicker in the navigator window: at the beginning, all formula objects are
grayed and the turned to active one by one. The flicker stops when all are active.

This behaviour could be reproduced on Suse Linux and Win XP on a number of
different systems.

When the document is opened by OOo1.1.5 there is no flicker at all.

Attached there is a document to demonstrate the effect.
Comment 1 khbellgardt 2005-11-16 09:59:10 UTC
Created attachment 31540 [details]
Document to demonstrate flicker
Comment 2 merschmann 2005-11-16 10:41:27 UTC
I can reproduce this with Ooo 2.0.0, W2K-SP4
Looks as if the system has to parse all formulas
Comment 3 raschmi 2005-11-16 10:49:10 UTC
I can also reproduce this with Ooo 2.0.0,
My System :
Intel 1100Mhz 512MB
suse 9,3 aktually patched
Comment 4 michael.ruess 2005-11-16 13:14:40 UTC
MRU->FME: this sounds quite similar to issue 52205. But here it looks, that the
update/formatting of the Math objects leads to a flickering of the screen.
This can be seen best when scrolling to a page with Math objects right after
opening the document.
Comment 5 probe1 2005-11-16 22:16:24 UTC
Confirmation for 2.0.0-3 Linux P4M 2GH 1GB 32MB graphic card.

Reproducible with such a simple document *without* formulars or embedded object
like Andrew Pitonyak's free macro document (will attach document).

I'm loading this in read-only mode, and this screen irritation lasts a minute or
so. Switching to edit-mode (toolbar button "edit file") does not cure. When
loading multiple documents all of them are affected. If you close one the
remaining document flickers.

Note: total page number of test document in status bar starts with 365 and is
re-calculated according to the flicker down- and upwards, sometimes exceeding
the starting number. End calculation of pages is 360.

I did not observe this behaviour on opening a large spreadsheet.
Comment 6 probe1 2005-11-16 22:20:04 UTC
Created attachment 31572 [details]
Andrew Pitonyak's free macro document as test file (contains no macros)
Comment 7 norbert2 2006-01-07 08:35:02 UTC
I just wanted to file this bug. But I found this existing one.

I encounter this bug after loading my diploma thesis. It contains much formulas.
But I don't know if this is the reason.
Comment 8 rambei 2006-08-11 02:04:01 UTC
I confirm this behavior in 2.0.3. Doesn't occur in 1.1.5. I'm on a Dell
Dimension 2400, WinXP Home. I never use math formulas, so I'm sure that's not
causing the issue in my case. It occurs with a 305 page document. The lower half
of the document area flickers, then the lower one-third. Doesn't seem to happen
in short cdocuments - but I'm not sure, as I've gone back to 1.1.5 to avoid it. :-(
Comment 9 norbert2 2007-02-07 16:31:57 UTC
Hi.

I just found out that this is NOT a formula specific bug:

Please open the attached file "flicker.odt". It flickers, although it contains
nor formulas. But it contains many pictures that are anchored as characters. And
this anchor-mode is default for formulas. So this is a bug that happens with
objects that are anchored as characters, not only with formuals.

I think the summary should be changed to: "Documents with objects that are
anchored as characters show frequent flicker after loading"
Comment 10 norbert2 2007-02-07 16:33:25 UTC
Created attachment 42832 [details]
flicker.odt
Comment 11 iliphilip 2007-02-15 21:26:11 UTC
I experience this screen flicker issue on v2.1 with any large document, it
doesn't need to contain formulas, both when the document loads and when
switching between print layout and web layout. As the page count changes some
part of the displayed text will flicker.  Related issue #: 58348 has more
details on the cause. 

To fully experience how annoying this problem can be download the ascii version
of Pride and Prejudice or whatever from http://www.gutenberg.org/etext/1342,
open it with OO, change the font to arial or verdana, switch to web layout and
start reading. On my system the document in web layout will eventually (a minute
or two) be 6 pages long (bug?) and every adjustment on the way to that number
causes a flicker, the same thing will happen if I switch back to print layout.
An option to make the re-pagination happen right away on open or layout changes
would fix this.  
Comment 12 merschmann 2007-03-16 10:11:48 UTC
Confirming the behaviour again with OOo2.2-RC3, WinXP
Also confirming the behaviour as described by norbert2

Can anyone please check if this is happening only with objects that are anchored
as characters ?