Issue 58203

Summary: OOo should support .ppt created with PPT before Version 97
Product: Impress Reporter: malcomm77 <malcomm77>
Component: open-importAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, rainerbielefeld_ooo_qa
Version: OOo 1.1Keywords: oooqa
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
gzip'd ppt file that's OO is having issue with
none
bugdoc saved with PPT2003 none

Description malcomm77 2005-11-20 22:03:58 UTC
Ubuntu Distribution: openoffice.org2-core 1.9.129-0.lubuntu4

Attempted to open a power point presentation (endo.ppt) and got the following
error message:

"Version Incompatibility. Incorrect file version."

The first thing is that the error message is a little confusing. 'Incorrect file
version' sorta implies there's something wrong with the file itself (data
corruption). If the problem is simply that the power point data format isn't
supported then something like "Version of the Power Point file is not supported"
would seem a better fit. It would also be nice if the error message would say:
here's the version of the file format that you're trying to open and then give a
list of supported file format versions.

The second point would the problem of actually opening the file. Since I don't
really know what version of power point was used, I'm not sure if this portion
of the bug is valid or not.
Comment 1 malcomm77 2005-11-20 22:05:23 UTC
Created attachment 31650 [details]
gzip'd ppt file that's OO is having issue with
Comment 2 wolframgarten 2005-11-21 08:13:28 UTC
Reassigned.
Comment 3 christian.guenther 2005-11-22 17:10:55 UTC
Change the target and set to new
Comment 4 christian.guenther 2005-11-22 17:22:23 UTC
It was saved with a PPT-version older then PPT97 therefore OOo can't load the file.
I saved the file with PPT2003 and now I can load the file without any problems.
I attach the 'converted' file.

Comment 5 christian.guenther 2005-11-22 17:23:40 UTC
We need a rework of the error message when OOo can't load a Document.
Comment 6 christian.guenther 2005-11-24 09:31:55 UTC
Created attachment 31761 [details]
bugdoc saved with PPT2003
Comment 7 ace_dent 2008-05-16 01:41:35 UTC
OpenOffice.org Issue Tracker - Feedback Request.

The Issue you raised is currently assigned to 'Requirements' pending review, but
has not been updated within the last 2+ years. Please consider re-testing with
one of the latest versions of OOo, as the problem(s) may have already been
addressed. Either use the recent stable version:
http://download.openoffice.org/index.html
or consider trying the new OOo 3 BETA (still in testing):
http://download.openoffice.org/3.0beta/
 
Please report back the outcome so this Issue may be Closed or Progressed as
necessary - otherwise it may be Resolved as Invalid in the future. You may also
wish to search for (and note) any duplicates of this Issue that may have
advanced further by checking the Issue Tracker:
http://www.openoffice.org/issues/query.cgi
 
Many thanks,
Andrew
 
Cleaning-up and Closing old Issues as part of:
~ The Grand Bug Squash, pre v3 ~
http://marketing.openoffice.org/3.0/announcementbeta.html
Comment 8 Rainer Bielefeld 2008-05-28 05:09:56 UTC
OS "All" Due to  Issue 46610 /  Issue 90046.
More Meaningful subject
Comment 9 Rainer Bielefeld 2008-05-28 05:11:36 UTC
*** Issue 90046 has been marked as a duplicate of this issue. ***
Comment 10 caolanm 2010-04-14 14:03:31 UTC
*** Issue 46610 has been marked as a duplicate of this issue. ***
Comment 11 Rainer Bielefeld 2010-04-14 15:23:20 UTC
I doubt that this wver will be "fixed". Even my MS PPT Viewer will not open the
sample file, and OOo isn't a tool for paleontologists ;-)

We should be honest and make this issue WONTFIX