Issue 59212

Summary: Rectangles instead of bullets in standard bullet list
Product: Writer Reporter: jr
Component: formattingAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0.1Keywords: regression
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Bullets in 2.0.0 - correct
none
Bullets in 2.0.1 - wrong none

Description jr 2005-12-11 19:26:26 UTC
Found in 2.0.1 RC4, WinXP

Reproduce following steps:
- write some characters in a writer document
- click on icon "Bullets On/Off" to start a list
- press return to create next paragraph
- press tab to change to level 2
- a rectangle instead of a bullet appears (same in level 5 and 8)

I can reproduce this behaviour only with 2.0.1, if I try it on the same system
with 2.0, the bullets are ok. So it seems to be not a font issue.

Another curious thing: If you start the list with F12 (or format - bullets and
numbering) and change it to bullets, the list is ok. If you start another list
in the same document by using the icon Bullets On/Off after that, this list is
ok, too.
Comment 1 jr 2005-12-11 19:27:59 UTC
Created attachment 32288 [details]
Bullets in 2.0.0 - correct
Comment 2 jr 2005-12-11 19:28:31 UTC
Created attachment 32289 [details]
Bullets in 2.0.1 - wrong
Comment 3 jr 2005-12-11 19:30:22 UTC
setting keyword as it's a regression 2.0.0 -> 2.0.1
Comment 4 Regina Henschel 2005-12-11 20:04:02 UTC
That bullet is StarSymbol U+25CB. If you don't have StarSymbol a glyph fallback
is necessary. But U+25CB is not part of OpenSymbol. On my system it falls back
to Andale Sans UI. But that works, so I get no square. See also issue 26319 for
bullet-problems.
Comment 5 michael.ruess 2005-12-12 16:13:53 UTC
The default bullets have changed. But it should not look like on your screenshot.
Please check, which version of the "OpenSymbol" you have installed on your
system. Maybe it is an older one. The newest one is version 1.9
Comment 6 michael.ruess 2005-12-12 16:14:12 UTC
Closed.
Comment 7 jr 2005-12-16 12:05:04 UTC
I have installed OpenSymbol version 1.9

Any idea what else could be wrong? I tested it on two different PCs with WinXP,
same result, big bullets in most of the levels, rectangles in level 2, 5, 8.
Another test with 2.0.1 RC5 on Debian: same result. 



Comment 8 michael.ruess 2005-12-22 14:26:44 UTC
The new bullet format is intended. See issue 42357. 
But I do not have any idea why some are displayed as rectangle symbols on your
system. Here, on several different systems it works properly.
Comment 9 caolanm 2006-01-03 16:46:28 UTC
I can see the problem here
Comment 10 caolanm 2006-01-03 16:46:58 UTC
got some information at issue 59997, marking as duplicate of that

*** This issue has been marked as a duplicate of 59997 ***
Comment 11 caolanm 2006-01-03 16:47:26 UTC
close as duplicate