Issue 59369

Summary: Export table/query data to spreadsheet-type files through menu
Product: Base Reporter: aziem <ahz001>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CLOSED FIXED QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, mail.info, megabandwidth, oooforum, stephencadams, steve
Version: OOo 2.0   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description aziem 2005-12-15 00:13:07 UTC
The requested feature is a menu option to export data from tables and queries to
spreadsheet-type files (.csv, .dbf, .odb, .xls, etc.).  The feature would be
accessed from either the File menu (for example, File->Export) or the context
menu (right click on desired table or query).

A similar but less specific request was filed as issue 41556, but the feature
requested here has some differences:
1. This feature overcomes the size limitations of the spreadsheet as databases
can be expected to exceed 70,000 rows.
2. This feature is accessed through a menu interface which is more intuitive and
usable than copy and paste.  (Many people may not think to use copy and paste.)
3. This feature is for export only.

(Also, this feature complements issue 51904 which requests an import wizard for
spreadsheet-type files.)
Comment 1 marc.neumann 2005-12-15 08:18:20 UTC
Hi,

I reassign this enhancement to the User Experience team for evaluating.

Bye Marc
Comment 2 drewjensen.inbox 2009-12-30 01:41:50 UTC
*** Issue 107632 has been marked as a duplicate of this issue. ***
Comment 3 r4zoli 2010-03-10 12:51:26 UTC
*** Issue 107632 has been marked as a duplicate of this issue. ***
Comment 5 Regina Henschel 2014-09-22 20:09:12 UTC
*** Issue 125655 has been marked as a duplicate of this issue. ***
Comment 6 stephen adams 2014-09-23 08:37:41 UTC
id=125655

Regina Henschel <rb.henschel@t-online.de> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |RESOLVED
         Resolution|---                         |DUPLICATE

--- Comment #3 from Regina Henschel <rb.henschel@t-online.de> ---
If you do not have linked it to an external database engine, then likely the
embedded HSQL engine is used. You should see "HSQL Database engine" in the
status bar. This is a HSQL ver. 1.8.

This database engine does not know a single command to export to csv. You need
several steps:
Create a HSQL "text table": CREATE TEXT TABLE
Connect this text table to the desired .csv file and determine such things as
delimiter and character encoding: SET TABLE
Copy your data from your table into the new, and up to now empty, text table:
INSERT INTO
Perhaps delete the text table or disconnect it from the .csv file.
Find details on text tables in http://hsqldb.org/doc/guide/ch06.html.
That way will give you full control over the export.

But perhaps this simple solution might already work for you:
In menu Tools > SQL...
Write command
SELECT * INTO TEXT "<file name of export without .csv>" FROM "<name of table to
be exported>"
Click Execute
The .csv file is generated in the same directory as the .odb file.
Of cause you have to use your own names instead of the <..> parts.

So "Cannot" is not correct. But you are right, it would be nice to have a UI
for such export. But that is already tracked in issue 59369. There are other
similar request mentioned there.

*** This issue has been marked as a duplicate of issue 59369 ***

The Tools/SQL method fails
Select * INTO TEXT "Sept2014" FROM "september 2014" does not work in OpenOffice 4.1.0 as it says error Undeclared variable: TEXT.
The other method quoted is to complex to use.
MS Access had multiple export options such as CSV, which are used to transfer data to a non-owned application or database where this has been a common transfer format for over 20 years.
Comment 7 oooforum (fr) 2015-11-25 08:01:05 UTC
*** Issue 108583 has been marked as a duplicate of this issue. ***
Comment 8 oooforum (fr) 2015-12-18 14:15:26 UTC
If you want this feature, you can install ExportCSV
http://extensions.openoffice.org/node/18410
Comment 9 oooforum (fr) 2017-01-23 13:44:55 UTC
*** Issue 58915 has been marked as a duplicate of this issue. ***
Comment 10 oooforum (fr) 2017-04-07 08:04:15 UTC
See comment 8