Issue 59495

Summary: object size changes when storing / retrieving in gallery
Product: Draw Reporter: juergen_harms <juergen.harms>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, lars_o_hansen
Version: OOo 2.0.1Keywords: oooqa
Target Milestone: AOO Later   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Description Flags
Gallery object size vs. units of measurement, see my comment of 11h30 19.12.05 none

Description juergen_harms 2005-12-18 11:01:02 UTC
If an object is (1) created in OO draw, (2) than stored in a gallery scheme and
(3) copied from the gallery back into the drawing, its size is different from
that of the source object copied into the gallery in step (1).

1. a rectangle is created using Drawing toolbar -> Rectangle toolbar
2. its size is fixed to 10.00 mm x 5.00 mm (Format -> Position and Size)
3. a new Theme (e.g. dummy) is created in the gallery
4. the rectangle is dragged into this theme
5. the rectangle is selected in the gallery
6. this selection is copied back into the drawing (Insert -> Copy)

-> The size of the object thus created is 9.87 x 5.07 mm rather than the initial
10.00 x 5.00 mm.

The consequence makes it impossible to use gallery objects when creating a
drawing, where the objects copied from the gallery should precisely "click" into
a grid - an essential technique when creating clean joints between different
elements of a drawing.

Note: this bug happens both with "Draw" and "Presentations" (impress). It was
already present in 2.0.0, but OK in the 1.x releases.
Comment 1 lars 2005-12-18 13:38:26 UTC
how do you drag the rectangle into the new theme?
Comment 2 juergen_harms 2005-12-18 20:14:54 UTC
Sorry if I have not been clear enough (hope that I do not exagerate now).

Assuming that the gallery window and the theme have already been opened:

1. Left-button down on the rectangle in the drawing (ie. the object to be
dragged to the gallery)
2. Maintain the left-button down until the cursor changes from the "move" cursor
to a "drag" cursor (after about 1/2 sec.)
3. With the left button still down, drag the rectangle into the theme (the
scrolled canvas of the gallery part of the window)
4. Left-button up

As a result, the object (the rectangle) is added to the gallery theme.

See also OO Help -> Index -> Gallery -> adding pictures

If it is of help, I can post an attachement with the files that contain the
representation of the scheme ( or a sample
drawing - but I think that this is trivial to reproduce

Comment 3 lars 2005-12-18 21:43:35 UTC
Ok, thank you; I can now add graphics to the gallery; unfortunately I cannot 
reproduce your problem with OOo 2.0.1 RC5: the rectangles size is the same as 
the source: 10x5cm; is there anything else you do or any special setting you 
have active?
Comment 4 juergen_harms 2005-12-19 10:35:21 UTC
I have worked with a fresh install of OO 2.0.1-1 and a newly created
~/ directory. I did the following changes in Tools -> Options ->
OO Draw:
 - in General, set the units of measurement to mm
 - in Grid, select snap-to-grid and visible-grid, grid resolution (both axes)
5mm with 1 sub-division.

I think the explanation in the difference of what I see and what you have found
is the setting of the Units of Measurement. I went to mm because this gives me
the best resolution (given the 2-digit-precision) with an easy-to-use unit.

I will try (I am new to your issue tool) to join an attachment, where I did the
exercise of (1) creating a source rectangle, (2) storing it in the gallery, and
(3) retrieving it into the drawing three times: once with uom (units of
measurement) set to inch, once set to cm and once set to mm. Since the grid
points are not easy to see, I joined thin lines to make the gridding better

I then measured the size of the object retrieved from the gallery, with the
initial setting of uom and with setting uom to mm.

This illustrates the original problem and the difference with what you saw when
you tried to reproduce the problem (I guess that your setting is in cm).

Note: from the usage point of view, the precise reading of the measures is
immaterial. What counts is the mis-match between the grid and the size of the
objects. Such a mis-match upsets the "snap-to-grid" mechanism and makes the
objects be placed with a more or less random offset, resulting in fuzzy drawings
with line-ends / object-borders not precisely matching. You can see this easily
in the joined example if you choose a large zoom (for instance 800 %).
Comment 5 juergen_harms 2005-12-19 10:39:05 UTC
Created attachment 32559 [details]
Gallery object size vs. units of measurement, see my comment of 11h30 19.12.05
Comment 6 lars 2005-12-19 17:15:35 UTC
Ok, reproduced. Set Unit of measurement to mm, create a rectangle of 
10x5mm, "drag" it to the gallery, copy it back from the gallery; for me the 
size gets 10,04x5,02mm. Such a change also occurs with Uom set to inches but 
not when set to cm; so confirmed on Windows XP Pro SP2 with OOo 2.0.1 RC5
Comment 7 wolframgarten 2006-01-03 13:24:06 UTC
Comment 8 Marcus 2017-05-20 11:31:32 UTC
Reset assigne to the default "".